LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-05-2004, 02:10 PM   #1
cmon
LQ Newbie
 
Registered: Mar 2004
Posts: 3

Rep: Reputation: 0
Noob Needs Handholding Through P2P Installation


Hi all,

I have been trying to install P2P software on Mandrake 9.0 (KDE 3.0) but to no avail. I am not a computer whizzkid but I am also determined not to run off screaming back to Windoze like some big girl's blouse. I have searched this (top-notch) forum and found various internet pages but still can't install successfully - please can you help?

I have downloaded the following files to /tmp:
gift-0.11.6.tar.bz2;
gift-gnutella-0.0.9.2.tar.bz2;
gift-openft-0.2.1.2.tar.bz2;
apollon-0.9.3-2.tar.bz2.


I found the following script on a web page and popped it into Konsole (super user mode):

cd /usr/local/src/
tar xvfj /tmp/gift-0.11.6.tar.bz2
tar xvfj /tmp/gift-openft-0.2.1.2.tar.bz2
tar xvfj /tmp/gift-gnutella-0.0.9.2.tar.bz2
cd gift-0.11.6
./configure && make && su -c 'make install'
cd ..
cd gift-gnutella-0.0.9
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:/usr/local/lib/
./configure && make && su -c 'make install'
cd ..
cd gift-openft-0.2.1.2
./configure && make && su -c 'make install'

Everything seemed to tick along very well for around 1 minute - lots of positive-looking messages, but then everything stopped with an error message along these lines:

checking ltdl.h usability ... no
checking ltdl.h presence ... no
checking for ltdl.h .... no

configure error:
libltdl is temporarily required. Please install the appropriate library and header files. ....

I have read previously that it is essential to have all the "development" packages installed, so I've done that - any thoughts on how to get this sorted?

Your help will be greatly appreciated.

Cheers,
Cmon.
 
Old 04-05-2004, 02:23 PM   #2
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Not all development packages, no - you just need libtool, I think.

http://www.gnu.org/software/libtool/libtool.html

download the source code and install that as per the INSTALL or README file in the archive. Should be all you need.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm sorry; I need some handholding with a Gaim installation. :( Surfrider Slackware 6 08-24-2005 08:20 AM
Risk of Linux P2P vs. Windows P2P software snatale1 Linux - Software 2 12-04-2004 08:14 PM
P2P software installation troubles dkgilbey Linux - Software 8 11-27-2004 01:39 PM
Noob needing help with P2P crab_2004 Linux - Software 6 10-16-2003 12:51 AM
Handholding for a newbie Punchy Linux - Newbie 4 08-30-2003 04:24 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration