LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-02-2004, 11:40 PM   #1
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Rep: Reputation: 15
Noob Help


Everytime I go to reboot my computer the sound never comes on automatically the only way I can get sound is if i run the soundcard detection program and hit the play sound button then sound works fine after that is there something that i did wrong i have searched and searched but still no luck HELP!!!!! Also if anyone knows of how to make a program execute when my system starts up like scripts or something of that sort that I can have them run automatically when KDE these two things would both be appreciated thanks in advance...

I am using an HP ze4420us laptop
with Fedora Core 3
Connected wirelessly via Ndiswrapper & My Linksys Wireless G Card...
 
Old 12-03-2004, 01:05 AM   #2
musicman_ace
Senior Member
 
Registered: May 2001
Location: Indiana
Distribution: Gentoo, Debian, RHEL, Slack
Posts: 1,555

Rep: Reputation: 46
add a script to start the detection program you spoke of

Call it soundmgr

#!/bin/bash
Type the full path to the sound detection program.


Next, move the script to /etc/rc.d
chmod u+x /etc/rc.d/soundmgr

Assuming you start in rc.5, do the following

cd /etc/rc.d/rc5.d
ln -s ../soundmgr S24soundmgr

You can replace the 24 with any number .
This will automatically run the detection during startup and should solve the problem. If you don't run in run level 5, replace it with 3 or whichever run level you have set.
 
Old 12-03-2004, 08:01 AM   #3
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by musicman_ace
add a script to start the detection program you spoke of

Call it soundmgr

#!/bin/bash
Type the full path to the sound detection program.


Next, move the script to /etc/rc.d
chmod u+x /etc/rc.d/soundmgr

Assuming you start in rc.5, do the following

cd /etc/rc.d/rc5.d
ln -s ../soundmgr S24soundmgr

You can replace the 24 with any number .
This will automatically run the detection during startup and should solve the problem. If you don't run in run level 5, replace it with 3 or whichever run level you have set.
Ok that sounds like something that is dooable but two things one you need root privelages to run this program and it is a gui program so if I was to make a script to run it it will prompt for a root password which isnt a problem cause i know it... But I dont want to have to enter it.Then after you enter the password then you have to hit enter or spacebar to run the test file which is another inconvenice. Finally it will prompt me everytime I load linux if the test file played correctly which will be another annoyance. What I am looking for is something that will make my sound on permentaly it worked fine when I had Red Hat 9 after I ran soundcard detection once and everytime after I rebooted I had sound. So Thanks again but I need something that will load my soundcard automatically...
 
Old 12-03-2004, 08:05 AM   #4
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Debian Testing
Posts: 19,192
Blog Entries: 4

Rep: Reputation: 470Reputation: 470Reputation: 470Reputation: 470Reputation: 470
In a console, use 'su' to become root and type
alsaconf
increase all available volumes and then exit alsaconf
use alsactl store to save the settings

Then check your gui volume control to ake sure that the volume isn't muted.
 
Old 12-03-2004, 08:10 AM   #5
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by XavierP
In a console, use 'su' to become root and type
alsaconf
increase all available volumes and then exit alsaconf
use alsactl store to save the settings

Then check your gui volume control to ake sure that the volume isn't muted.
That alsaconf command doesnt work for me XavierP it says command not found!!!!
 
Old 12-08-2004, 09:41 PM   #6
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Im guessing no one out there could help me out with my sound problem no biggie maybe fedora core 4 will fix my soundcard problem automatically cause i dont know what else to do!!!!!!!!! Thanks anyway for the help that I did get!!!
 
Old 12-09-2004, 12:24 PM   #7
bostontech
LQ Newbie
 
Registered: Dec 2004
Location: Boston
Distribution: all
Posts: 23

Rep: Reputation: 15
You should look into "chkconfig".
This utility will allow you to turn on/off programs at startup.
Example: chkconfig --level 234 sound on (this will allow program "sound" to startup automatically when your system is booted into either runlevel 2,3,or 4.

Hope this helps.

BTG
 
Old 01-02-2005, 09:33 PM   #8
gone15
Member
 
Registered: Sep 2003
Location: New York
Distribution: Fedora Core
Posts: 39

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by bostontech
You should look into "chkconfig".
This utility will allow you to turn on/off programs at startup.
Example: chkconfig --level 234 sound on (this will allow program "sound" to startup automatically when your system is booted into either runlevel 2,3,or 4.

Hope this helps.

BTG
chkconfig does not exist in Fedora's Vocabulary I tried to running it and it wasn't working!!!! I have sound again but I just dont know how to get it to run at the beggining!!! If there was just a way that I could run the soundcard detection program from the command line then it would be no problem!!!!!!
 
Old 01-02-2005, 10:19 PM   #9
SlackerLX
Senior Member
 
Registered: Dec 2004
Location: Herzliyya, Israel
Distribution: SuSE 10.1; Testing Distros
Posts: 1,834

Rep: Reputation: 47
Quote:
Originally posted by gone15
That alsaconf command doesnt work for me XavierP it says command not found!!!!
That alsaconf command will work on your box if alsa, of course, installed. You can live without it, but it's recommended to install it anyways, because many softwares will require alsa.

Regards
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Another nOOb :-) strudders SUSE / openSUSE 3 10-28-2005 02:20 PM
noob with a noob question phoonerorlater Linux - Newbie 2 09-29-2004 03:43 PM
3 Noob Quetions From A Noob DaveyB Slackware 20 08-11-2004 08:00 PM
Firewall help (noob really really huge noob) ProtoformX Linux - Networking 1 03-29-2004 12:19 AM
Complete noob question from a noob noob_hampster Linux - Software 2 09-04-2003 12:03 AM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration