LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 11-14-2007, 03:06 PM   #1
-Pb-
LQ Newbie
 
Registered: Aug 2007
Location: Moscow
Distribution: Slackware 12
Posts: 22

Rep: Reputation: 15
non-Latin characters in file names


Before installing Slack 12 on my Desktop, I copied lots of files from Windows to an external HDD. Now when in KDE,the Russian characters in the file names are displayed incorrectly. Moreover, messages written in Russian by my ICQ buddies (in LICQ) are also a mess.
I ran export LANG=ru_RU.cp1251 and now I can see the file content written in Russian and create Russian named files&folders, but the names of files&folders on the external HDD are still unreadable. I want to use English KDE and be able to see and write Russian characters. How can I solve the problem?

Last edited by -Pb-; 11-14-2007 at 03:07 PM.
 
Old 11-15-2007, 03:10 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,969

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
You should mount your external disk using additional options like:"iocharset=cp1251,codepage=866" or something like that.
Code:
man mount
for more info.

Regards
 
Old 11-15-2007, 05:53 AM   #3
-Pb-
LQ Newbie
 
Registered: Aug 2007
Location: Moscow
Distribution: Slackware 12
Posts: 22

Original Poster
Rep: Reputation: 15
Thank you. I did the following:
1. Ran export LANG=ru_RU.cp1251
2. Ran mount /dev/sdb1 /mnt/hd -o nls=cp1251

Both file names and file contents are displayed correctly.

However, I have one small glitch: when I open Konqueror-Storage Media, names of the present media are Russian, i.e. instead of 30G Media Mounted Hard Disk Volume etc. I see 30G Носитель Mounted Hard Disk Volume etc. And the LICQ interface is also in Russian. This is definitely has to do with changing a locale (see above).
How can I get this to be displayed in English?

Last edited by -Pb-; 11-15-2007 at 06:11 AM.
 
Old 11-15-2007, 06:22 AM   #4
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,969

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
I think that this is a KDE configuration issue. Since you changed language to russian it uses russian to display messages. You can configure it to use eglish but I'm not familiar with KDE to help you further.
Perhaps you can do it setting the LC_MESSAGES to en_US.
Run:
Code:
locale
If LC_MESSAGES is ru_RU.cp1251then:
Code:
export LC_MESSAGES=en_US.UTF-8
and see if it works.

Regards
 
Old 11-15-2007, 07:48 AM   #5
-Pb-
LQ Newbie
 
Registered: Aug 2007
Location: Moscow
Distribution: Slackware 12
Posts: 22

Original Poster
Rep: Reputation: 15
Thank you so much. Now everything works just as I want it to.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot read cyrillic characters in file names hazylama Linux - Software 6 05-01-2007 08:59 PM
How to modify the names of files and replace characters with other characters or symb peter88 Linux - General 2 12-10-2006 04:05 AM
Replacing characters in file names? yuccabrevifolia Linux - Software 1 04-19-2006 02:31 PM
Can i limit new file names created to 8 characters with samba ? amitsharma_26 Linux - Networking 1 12-16-2005 06:42 AM
rename file names with " ? characters fishbonz Linux - Newbie 2 05-31-2005 12:20 PM


All times are GMT -5. The time now is 11:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration