LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   non-Latin characters in file names (http://www.linuxquestions.org/questions/linux-newbie-8/non-latin-characters-in-file-names-599630/)

-Pb- 11-14-2007 03:06 PM

non-Latin characters in file names
 
Before installing Slack 12 on my Desktop, I copied lots of files from Windows to an external HDD. Now when in KDE,the Russian characters in the file names are displayed incorrectly. Moreover, messages written in Russian by my ICQ buddies (in LICQ) are also a mess.
I ran export LANG=ru_RU.cp1251 and now I can see the file content written in Russian and create Russian named files&folders, but the names of files&folders on the external HDD are still unreadable. I want to use English KDE and be able to see and write Russian characters. How can I solve the problem?

bathory 11-15-2007 03:10 AM

You should mount your external disk using additional options like:"iocharset=cp1251,codepage=866" or something like that.
Code:

man mount
for more info.

Regards

-Pb- 11-15-2007 05:53 AM

Thank you. I did the following:
1. Ran export LANG=ru_RU.cp1251
2. Ran mount /dev/sdb1 /mnt/hd -o nls=cp1251

Both file names and file contents are displayed correctly.

However, I have one small glitch: when I open Konqueror-Storage Media, names of the present media are Russian, i.e. instead of 30G Media Mounted Hard Disk Volume etc. I see 30G Носитель Mounted Hard Disk Volume etc. And the LICQ interface is also in Russian. This is definitely has to do with changing a locale (see above).
How can I get this to be displayed in English?

bathory 11-15-2007 06:22 AM

I think that this is a KDE configuration issue. Since you changed language to russian it uses russian to display messages. You can configure it to use eglish but I'm not familiar with KDE to help you further.
Perhaps you can do it setting the LC_MESSAGES to en_US.
Run:
Code:

locale
If LC_MESSAGES is ru_RU.cp1251then:
Code:

export LC_MESSAGES=en_US.UTF-8
and see if it works.

Regards

-Pb- 11-15-2007 07:48 AM

Thank you so much. Now everything works just as I want it to.


All times are GMT -5. The time now is 08:40 AM.