LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-31-2013, 12:27 AM   #1
blueblood
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Rep: Reputation: Disabled
Non-English file name between CentOS and Windows


Hi,

I got a language displaying problem with non-english (which is Korean in my case) when I transfer file from my CentOS VPS to my computer (Windows Vista).

Please see the attachment if you don't get what I mean.
Attached Thumbnails
Click image for larger version

Name:	windows.jpg
Views:	23
Size:	15.0 KB
ID:	13847   Click image for larger version

Name:	linux.jpg
Views:	26
Size:	12.0 KB
ID:	13848  
 
Old 10-31-2013, 05:46 AM   #2
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
The problem is not clearly stated. Is it a case of one OS not displaying the Korean characters, but funny-looking symbols instead? Or do you mean you want the file names displayed in a language other than Korean?
 
Old 10-31-2013, 06:02 AM   #3
blueblood
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Randicus Draco Albus View Post
The problem is not clearly stated. Is it a case of one OS not displaying the Korean characters, but funny-looking symbols instead? Or do you mean you want the file names displayed in a language other than Korean?
The file was renamed in Linux, but when brought it to Windows. Can't read, display funny-looking symbols as you described.
 
Old 10-31-2013, 06:56 AM   #4
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
Then the OS that cannot display the language does not have that language enabled. With a Linux system, it is simply a matter of adding a locale, but I have no idea what the procedure is for Windows.
 
Old 10-31-2013, 11:58 AM   #5
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 276Reputation: 276Reputation: 276
You need to enable Korean language and fonts on the Windows machine. I've forgotten exactly how to do that, and my last Windows experience was on XP, years ago, so it has probably changed anyway. However it's done, you'll need to do that.
 
Old 11-01-2013, 12:08 AM   #6
blueblood
LQ Newbie
 
Registered: Jul 2011
Posts: 5

Original Poster
Rep: Reputation: Disabled
I don't think something need to be done in Windows because it can displays Korean well so far. Btw, I'm a long-time Windows user and a Linux newbie.
 
Old 11-01-2013, 03:56 AM   #7
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: OpenBSD
Posts: 1,644
Blog Entries: 8

Rep: Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577Reputation: 577
So it is your Linux system that cannot display Korean? In that case, you must add Korean to your locales. If you also want to input Korean, you will need to install Ibus or SCIM, including packages for input methods. In this case, one or more Korean input methods.
 
Old 11-01-2013, 06:37 AM   #8
PeterSullivan
LQ Newbie
 
Registered: Aug 2013
Posts: 29

Rep: Reputation: Disabled
You can check file language by simply copying the file text and insert in google translate. Identify the language and install that in your PC.
 
Old 11-01-2013, 06:40 AM   #9
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 308Reputation: 308Reputation: 308Reputation: 308
Quote:
Originally Posted by PeterSullivan View Post
You can check file language by simply copying the file text and insert in google translate. Identify the language and install that in your PC.
The OP knows what language it is. He speaks it. Did you read the initial post?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
non-English post about CentOS router justicier25 Linux - Security 1 08-04-2011 10:55 AM
CentOS /Samba server- XP Windows client file sharing issue 3phoenix Linux - Server 7 11-06-2009 12:05 PM
Windows Permissions on CentOS 5.2 File Server acadata Linux - Newbie 2 03-26-2009 09:18 PM
file sharing from centos 5.2 with windows xp and vista zeus-dice Red Hat 6 08-21-2008 04:11 AM
xcin in english x windows guni Linux - Newbie 0 10-20-2003 03:56 AM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration