LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-22-2004, 01:02 AM   #1
johnnywilhelm
LQ Newbie
 
Registered: Feb 2004
Location: Melbourne, Australia
Distribution: Debian
Posts: 2

Rep: Reputation: 0
NoCorePointer can't start X


Hi there

I'm new to linux and when I start X Windows I get an error. It says to view the log file which I have copied in below.

I'm running my Debian Woody distro in a VMWare Workstation on a Wintel XP Home box.


This is a pre-release version of XFree86, and is not supported in any
way. Bugs may be reported to XFree86@XFree86.Org and patches submitted
to fixes@XFree86.Org. Before reporting bugs in pre-release versions,
please check the latest version in the XFree86 CVS repository

XFree86 Version 4.1.0.1 / X Window System
(protocol Version 11, revision 0, vendor release 6510)
Release Date: 21 December 2001
If the server is older than 6-12 months, or if your card is
newer than the above date, look for a newer version before
reporting problems.
Build Operating System: Linux 2.4.17 i686 [ELF]
Module Loader present
(==) Log file: "/var/log/XFree86.0.log", Time: Fri Feb 20 17:02:08 2004
(==) Using config file: "/etc/X11/XF86Config-4"
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen 1" (0)
(**) | |-->Monitor "vmware"
(**) | |-->Device "VMware SVGA"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(**) Option "AutoRepeat" "500 30"
(WW) Option "XkbCompat" requires an string value
(**) Option "XkbRules" "xfree86"
(**) XKB: rules: "xfree86"
(**) Option "XkbModel" "pc104"
(**) XKB: model: "pc104"
(**) Option "XkbLayout" "us"
(**) XKB: layout: "us"
(==) Keyboard: CustomKeycode disabled
(WW) The directory "/usr/lib/X11/fonts/cyrillic" does not exist.
Entry deleted from font path.
(**) FontPath set to "unix/:7100,/usr/lib/X11/fonts/misc,/usr/lib/X11/fonts/100dpi/:unscaled,/usr/lib/X11/fonts/75dpi/:unscaled,/usr/lib/X11/fonts/Type1,/usr/lib/X11/fonts/Speedo,/usr/lib/X11/fonts/100dpi,/usr/lib/X11/fonts/75dpi"
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules"
(--) using VT number 7

(WW) Cannot open APM
(II) Module ABI versions:
XFree86 ANSI C Emulation: 0.1
XFree86 Video Driver: 0.4
XFree86 XInput driver : 0.2
XFree86 Server Extension : 0.1
XFree86 Font Renderer : 0.2
(II) Loader running on linux
(II) LoadModule: "bitmap"
(II) Loading /usr/X11R6/lib/modules/fonts/libbitmap.a
(II) Module bitmap: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Bitmap
(II) LoadModule: "pcidata"
(II) Loading /usr/X11R6/lib/modules/libpcidata.a
(II) Module pcidata: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) PCI: Probing config type using method 1
(II) PCI: Config type is 1
(II) PCI: stages = 0x03, oldVal1 = 0x00000000, mode1Res1 = 0x80000000
(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 8086,7190 card 15ad,1976 rev 01 class 06,00,00 hdr 00
(II) PCI: 00:01:0: chip 8086,7191 card 0000,0000 rev 01 class 06,04,00 hdr 01
(II) PCI: 00:07:0: chip 8086,7110 card 15ad,1976 rev 08 class 06,01,00 hdr 80
(II) PCI: 00:07:1: chip 8086,7111 card 15ad,1976 rev 01 class 01,01,8a hdr 00
(II) PCI: 00:07:2: chip 8086,7112 card 15ad,1976 rev 00 class 0c,03,00 hdr 00
(II) PCI: 00:07:3: chip 8086,7113 card 15ad,1976 rev 08 class 06,80,00 hdr 80
(II) PCI: 00:0f:0: chip 15ad,0405 card 0000,0000 rev 00 class 03,00,00 hdr 00
(II) PCI: 00:10:0: chip 1022,2000 card 1022,2000 rev 10 class 02,00,00 hdr 00
(II) PCI: End of PCI scan
(II) LoadModule: "scanpci"
(II) Loading /usr/X11R6/lib/modules/libscanpci.a
(II) Module scanpci: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(II) UnloadModule: "scanpci"
(II) Unloading /usr/X11R6/lib/modules/libscanpci.a
(II) Host-to-PCI bridge:
(II) PCI-to-ISA bridge:
(II) PCI-to-PCI bridge:
(II) Bus 0: bridge is at (0:0:0), (-1,0,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
(II) Bus 1: bridge is at (0:1:0), (0,1,1), BCTRL: 0x80 (VGA_EN is cleared)
(II) Bus 1 I/O range:
(II) Bus 1 non-prefetchable memory range:
(II) Bus 1 prefetchable memory range:
(II) Bus -1: bridge is at (0:7:0), (0,-1,0), BCTRL: 0x08 (VGA_EN is set)
(II) Bus -1 I/O range:
(II) Bus -1 non-prefetchable memory range:
(II) Bus -1 prefetchable memory range:
(--) PCI:*(0:15:0) VMware PCI SVGA (FIFO) rev 0, Mem @ 0xf5000000/24, 0xf4000000/24, I/O @ 0x10a0/4
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[B]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[B]
(II) OS-reported resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) Active PCI resource ranges:
[0] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[1] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[2] -1 0 0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
[3] -1 0 0x00001080 - 0x000010ff (0x80) IX[B]E
[4] -1 0 0x00001060 - 0x0000107f (0x20) IX[B]E
[5] -1 0 0x00001050 - 0x0000105f (0x10) IX[B]E
[6] -1 0 0x000010a0 - 0x000010af (0x10) IX[B](B)
(II) PCI I/O resource overlap reduced 0x00001080 from 0x000010ff to 0x0000109f
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[1] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[2] -1 0 0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
[3] -1 0 0x00001080 - 0x0000109f (0x20) IX[B]E
[4] -1 0 0x00001060 - 0x0000107f (0x20) IX[B]E
[5] -1 0 0x00001050 - 0x0000105f (0x10) IX[B]E
[6] -1 0 0x000010a0 - 0x000010af (0x10) IX[B](B)
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[6] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
(II) All system resource ranges:
[0] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[1] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[2] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[3] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[4] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[5] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[6] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[7] -1 0 0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
[8] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[9] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[10] -1 0 0x00001080 - 0x0000109f (0x20) IX[B]E
[11] -1 0 0x00001060 - 0x0000107f (0x20) IX[B]E
[12] -1 0 0x00001050 - 0x0000105f (0x10) IX[B]E
[13] -1 0 0x000010a0 - 0x000010af (0x10) IX[B](B)
(II) LoadModule: "dbe"
(II) Loading /usr/X11R6/lib/modules/extensions/libdbe.a
(II) Module dbe: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/X11R6/lib/modules/extensions/libextmod.a
(II) Module extmod: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension XFree86-DGA
(II) Loading extension DPMS
(II) Loading extension FontCache
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) LoadModule: "type1"
(II) Loading /usr/X11R6/lib/modules/fonts/libtype1.a
(II) Module type1: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.1.9
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.2
(II) Loading font FreeType
(II) LoadModule: "vmware"
(II) Loading /usr/X11R6/lib/modules/drivers/vmware_drv.o
(II) Module vmware: vendor="The XFree86 Project"
compiled for 4.0.2, module version = 10.4.0
Module class: XFree86 Video Driver
ABI class: XFree86 Video Driver, version 0.3
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.2
(II) VMWARE: driver for VMware SVGA: vmware0405, vmware0710
(II) Primary Device is: PCI 00:0f:0
(--) VMware Guest X Server 10.4.0 - build=
(--) Assigning device section with no busID to primary device
(--) Chipset vmware0405 found
(II) resource ranges after xf86ClaimFixedResources() call:
[0] 0 0 0x000b8000 - 0x000bffff (0x8000) MX[B]
[1] 0 0 0x000b0000 - 0x000b7fff (0x8000) MX[B]
[2] 0 0 0x000a0000 - 0x000affff (0x10000) MX[B]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[4] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[9] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[10] -1 0 0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
[11] 0 0 0x000003c0 - 0x000003df (0x20) IX[B]
[12] 0 0 0x000003b0 - 0x000003bb (0xc) IX[B]
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x00001080 - 0x0000109f (0x20) IX[B]E
[16] -1 0 0x00001060 - 0x0000107f (0x20) IX[B]E
[17] -1 0 0x00001050 - 0x0000105f (0x10) IX[B]E
[18] -1 0 0x000010a0 - 0x000010af (0x10) IX[B](B)
(II) resource ranges after probing:
[0] 0 0 0x000b8000 - 0x000bffff (0x8000) MX[B]
[1] 0 0 0x000b0000 - 0x000b7fff (0x8000) MX[B]
[2] 0 0 0x000a0000 - 0x000affff (0x10000) MX[B]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[4] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[9] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[10] -1 0 0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
[11] 0 0 0x000003c0 - 0x000003df (0x20) IX[B]
[12] 0 0 0x000003b0 - 0x000003bb (0xc) IX[B]
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x00001080 - 0x0000109f (0x20) IX[B]E
[16] -1 0 0x00001060 - 0x0000107f (0x20) IX[B]E
[17] -1 0 0x00001050 - 0x0000105f (0x10) IX[B]E
[18] -1 0 0x000010a0 - 0x000010af (0x10) IX[B](B)
(II) Setting vga for screen 0.
(--) VMWARE(0): VMware SVGA regs at (0x10a0, 0x10a1)
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.4
(--) VMWARE(0): depth: 24
(--) VMWARE(0): w.red: 8
(--) VMWARE(0): w.grn: 8
(--) VMWARE(0): w.blu: 8
(--) VMWARE(0): bpp: 32
(--) VMWARE(0): vis: 4
(--) VMWARE(0): vram: 16777216
(--) VMWARE(0): pbase: 0xf5000000
(--) VMWARE(0): mwidt: 2360
(--) VMWARE(0): mheig: 1770
(--) VMWARE(0): caps: 0x00003FF3
(==) VMWARE(0): Depth 24, (==) framebuffer bpp 32
(==) VMWARE(0): RGB weight 888
(==) VMWARE(0): Default visual is TrueColor
(==) VMWARE(0): Using HW cursor
(==) VMWARE(0): Using gamma correction (1.0, 1.0, 1.0)
(II) VMWARE(0): vmware: Using hsync range of 1.00-10000.00 kHz
(II) VMWARE(0): vmware: Using vrefresh range of 1.00-10000.00 Hz
(II) VMWARE(0): Clock range: 0.00 to 400000.00 MHz
(II) VMWARE(0): Not using mode "2364x1773" (width requires unsupported line pitch)
(--) VMWARE(0): Virtual size is 800x600 (pitch 800)
(**) VMWARE(0): Mode "800x600": 100.0 MHz, 90.9 kHz, 101.0 Hz
(II) VMWARE(0): Modeline "800x600" 100.00 800 900 1000 1100 600 700 800 900 (null)
(++) VMWARE(0): DPI set to (100, 100)
(II) Loading sub module "cfb32"
(II) LoadModule: "cfb32"
(II) Loading /usr/X11R6/lib/modules/libcfb32.a
(II) Module cfb32: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "cfb"
(II) LoadModule: "cfb"
(II) Loading /usr/X11R6/lib/modules/libcfb.a
(II) Module cfb: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "mfb"
(II) LoadModule: "mfb"
(II) Loading /usr/X11R6/lib/modules/libmfb.a
(II) Module mfb: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.1.0.1, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.4
Symbol cfb24ScreenInit from module /usr/X11R6/lib/modules/drivers/vmware_drv.o is unresolved!
Symbol cfb24CopyPlane from module /usr/X11R6/lib/modules/drivers/vmware_drv.o is unresolved!
Symbol cfb16ScreenInit from module /usr/X11R6/lib/modules/drivers/vmware_drv.o is unresolved!
Symbol cfb16CopyPlane from module /usr/X11R6/lib/modules/drivers/vmware_drv.o is unresolved!
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] 0 0 0x000b8000 - 0x000bffff (0x8000) MX[B]
[1] 0 0 0x000b0000 - 0x000b7fff (0x8000) MX[B]
[2] 0 0 0x000a0000 - 0x000affff (0x10000) MX[B]
[3] -1 0 0xffe00000 - 0xffffffff (0x200000) MX[B](B)
[4] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[B]E(B)
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[B]
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX[B]
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[B]
[8] -1 0 0xf8000000 - 0xffffffff (0x8000000) MX[B]E
[9] -1 0 0xf4000000 - 0xf4ffffff (0x1000000) MX[B](B)
[10] -1 0 0xf5000000 - 0xf5ffffff (0x1000000) MX[B](B)
[11] 0 0 0x000003c0 - 0x000003df (0x20) IX[B]
[12] 0 0 0x000003b0 - 0x000003bb (0xc) IX[B]
[13] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[B]
[14] -1 0 0x00000000 - 0x000000ff (0x100) IX[B]
[15] -1 0 0x00001080 - 0x0000109f (0x20) IX[B]E
[16] -1 0 0x00001060 - 0x0000107f (0x20) IX[B]E
[17] -1 0 0x00001050 - 0x0000105f (0x10) IX[B]E
[18] -1 0 0x000010a0 - 0x000010af (0x10) IX[B](B)
(WW) VMWARE(0): Failed to set up write-combining range (0xf5000000,0x1000000)
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(**) Option "Protocol" "ps/2"
(**) Mouse1: Protocol: "ps/2"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/mouse"
(EE) xf86OpenSerial: Cannot open device /dev/mouse
No such file or directory.
(EE) Mouse1: cannot open input device
(EE) PreInit failed for input device "Mouse1"
(II) UnloadModule: "mouse"
(II) Keyboard "Keyboard1" handled by legacy driver
(WW) No core pointer registered
No core pointer

Fatal server error:
failed to initialize core devices

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.0.log".
Please report problems to submit@bugs.debian.org.

--
Ok so I can see that it it says No core pointer registered and that it can't find /dev/mouse. no such file or directory.

I am using a MS PS/2 IntelliMouse. It has two buttons and a wheel.

I've spent a few hours on this site looking for help and just can't seem to get the right answer, even though I think this is a fairly common problem.

So, I have tried editing the XF86Config file in vi and tried changing the settings for the mouse.

It was :
Section "InputDevice"
Identifier "Mouse1"
Driver "Mouse"
Option "Protocol" "Mouse"
Option "Device" "psaux"
EndSection

And I changed it to:
Section "InputDevice"
Identifier "Mouse1"
Driver "Mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
EndSection

Then I logged out and logged in again as root, and I get the same message that no such file or directory exisits. /dev/mouse

I've read here on this forum to try using symlink and I can't work out how to do it and where to put the command.

Thanks for reading this long post!
 
Old 02-22-2004, 01:37 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Did you actually edit the correct file (the one
X is actually grabbing)?

/etc/X11/XF86Config-4


Cheers,
Tink
 
Old 02-22-2004, 02:51 AM   #3
johnnywilhelm
LQ Newbie
 
Registered: Feb 2004
Location: Melbourne, Australia
Distribution: Debian
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks Tink!

I was editing the XF86Config file when I should have been editing the XF86Config-4 file. I made the change and X boots up np.

Why are there two files like this?

Cheers

John
 
Old 02-22-2004, 01:21 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Hi!

Hard to give a GOOD explanation...

Originally the -4 convention was being
used when XFree 4.x was introduced,
and it was there so you could have both
3.3.x and 4 installed. Also the formats for
the files slightly differ. Why you still get
both in some distro's is beyond me :}


Cheers,
Tink

P.S.: If you feel that I helped you please
consider taking the time to click the affero
button :}
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
when i try to start samba pdc's smb service nmbd failed to start . sandeepchau123 Linux - Newbie 2 10-20-2007 02:59 PM
disable cold start and warm start snmp traps chkisco Linux - Newbie 0 10-28-2005 03:58 AM
fc2-gnome : Applications dont start / very slow to start nox104 Linux - Software 0 08-18-2004 09:53 PM
How to start korganiser and reminger agent whenever i start the x deskTop seastar Linux - Software 5 08-15-2004 11:29 PM
Can I gett KPPP to start when I start a browser on a network machine? duffboygrim Linux - Networking 0 03-25-2004 05:49 PM


All times are GMT -5. The time now is 03:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration