LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-20-2008, 10:23 PM   #1
flying_suser
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Rep: Reputation: 0
Unhappy No write permission for External HD: Newbie question


I'M a NEWBIE FOR SUSE.

I've version 10.3 installed in it which is most satisfactory for my requierments. I've a NTFS format external harddrive(130 GB Maxtor) which runs on my Win XP perfectly.

However while using that in suse, I'm denied write permission. can anyone help me to solve this problem please.

I'm the sole user of the comp, and work as root.

The files are under /media/disk
 
Old 12-20-2008, 10:57 PM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian stable
Posts: 5,887

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
To be able to write to an ntfs partition, you need the ntfs-3g kernel module loaded. That module comes with OpenSuse 10.3. So, make sure it is loaded (lsmod in a terminal to see the loaded modules; modprobe to load it if it isn't currently loaded).

You also need write permission for the ntfs partition. If the user/group of the partition is root/root, you will not be able to write to the partition. You would have to change the user/group to root/user (owner is root; group is user), then make sure that your user name is in the user group. Also make sure that the user group has write permission for the partition.

chgrp user /media/disk # to change the group to user.

groupadd -A <username> <group> # where username is your user name, and group is the group to add the user name into (in this case, the group is user). The command becomes: groupadd -A <username> user.

To add write permission, chmod g+w /media/disk # to give the group members write permission.
Quote:
I'm the sole user of the comp, and work as root.
Not a good idea. You are setting yourself up for a lot of heartache.

Last edited by bigrigdriver; 12-20-2008 at 10:59 PM.
 
Old 12-22-2008, 05:52 PM   #3
flying_suser
LQ Newbie
 
Registered: Dec 2008
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks I'm able to do it now.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
External USB disk - Only ROOT has Write permission (Suse 10.3) 1kyle SUSE / openSUSE 9 03-25-2008 08:36 AM
Establishing write permission for an external hard drive in SUSE 10.3 Jason21 Linux - Newbie 7 10-26-2007 01:40 AM
External Hard Drive Write Permission Problem RazielX Linux - General 2 09-02-2007 09:45 AM
External Hard Drive does not give me the permission to write erockallstar Linux - Newbie 22 01-29-2007 03:40 PM


All times are GMT -5. The time now is 02:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration