LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-16-2008, 12:20 PM   #16
TommyGun
LQ Newbie
 
Registered: Feb 2008
Location: Norway
Distribution: Ubuntu 7.10 Gutsy Gibbon
Posts: 15

Original Poster
Rep: Reputation: 0

Quote:
Originally Posted by mbecraft View Post
In your router's configuration, do you have the wireless SSID ("Network Name") hidden? That's typically what I've seen happen when it doesn't work correctly. Also, how strong is your WEP key? If it's more than 128-bit (I believe), it's not compatible with the driver.
I don't think the SSID is hidden, it shows up on my friends computer. And I am not really sure about the WEP, I think it's about 128-bit, how do I know?
 
Old 02-16-2008, 12:31 PM   #17
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
Originally Posted by superdave7380 View Post
Okay. I've downloaded the appropriate driver and firmware... (although on Linux-Laptops.net, it says my laptop should work outta the box... I wonder if I already have what I need...)

But wow, those install instructions are ummm... lengthy... and complicated-looking... for someone who's new-ish, like myself.
Well, the command to try would be modprobe ipw2200 as root in a console. If you just get back a command prompt, then the basic driver is there and you probably just have to load firmware. Sorry, I spaced, but the ipw2200 driver has been in the kernel since 2.6.14, so if you have a kernel later than that, it should already be there.


Quote:
Originally Posted by superdave7380 View Post
This is the 3rd time I downloaded Ubuntu. With each distribution, more and more works outta the box... but never everything. This time, it's sooo close. Don't they have a gazillion people working on this? I don't get it. I mean, everyone complains about Windows (myself included...), but everything does work right off the install. No terminal commands needed. How many versions of Ubuntu will be needed to accomplish that?
No, they don't have a gazillion people working on this. The reason that everything works right off the bat with Windows is that the manufacturers actually write the Windows drivers for the stuff they make. Intel is one of the exceptions, but even then, their efforts are concentrated on their newer chipsets, not the older ones like the 2200.
 
Old 02-16-2008, 02:40 PM   #18
superdave7380
LQ Newbie
 
Registered: Feb 2008
Posts: 23

Rep: Reputation: 15
Okay. I entered "modprobe ipw2200"... and got back the command prompt... which means I have it.

I downloaded the firmware, read the instructions as to where to put it... and... it's already there.

Sigh.

NEXT?!

(I haven't tried hitting it yet... though, maybe I should, as I find that works with most electronics...)
 
Old 02-17-2008, 07:16 AM   #19
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
Originally Posted by superdave7380 View Post
Okay. I entered "modprobe ipw2200"... and got back the command prompt... which means I have it.

I downloaded the firmware, read the instructions as to where to put it... and... it's already there.

Sigh.

NEXT?!
OK, well, with the module loaded and the firmware in place, what does the output of iwconfig look like? If there isn't a wireless card there, it is time to spend some quality time with your log files (/var/log/syslog, /var/log/messages and the output of dmesg). There will be a LOT of stuff in those files, but hopefully ipw2200 is leaving some clues as to what could be going wrong.
 
Old 02-17-2008, 07:53 AM   #20
dstuartkelly
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by mbecraft View Post
The only problem I ever had though was getting connected to a secure network that had its SSID hidden. Oh well, probably my install though. Glad to help you out.
Going a little off topic here, apologies.
I had some issues connecting to my access point alright.

Im a little paranoid about my WLAN, so had the following set up.
WPA2
SSID Hidden
DHCP Disabled.
MAC Address filtering.

What I found I needed to do was
Show the SSID
Change WPA to Version 1 and 2
Enable DHCP
Remove MAC Address filtering.

Im sure I added the correct MAC address.
iwconfig told me my wireless was eth1
and ifconfig showed me the Hardware Address of eth1 and that was appropriately added in.

Im not too worried about the SSID being broadcast.
The DHCP should be fixed easily enough.
Id like to put MAC Filtering back on again, will let you know how I get on.

Quote:
Originally Posted by superdave7380 View Post
I haven't tried hitting it yet... though, maybe I should, as I find that works with most electronics...
Ahhhh.. percussive maintenance, nothing finer to get out your frustrations

-Dan

Last edited by dstuartkelly; 02-17-2008 at 07:56 AM.
 
Old 02-17-2008, 02:06 PM   #21
superdave7380
LQ Newbie
 
Registered: Feb 2008
Posts: 23

Rep: Reputation: 15
Okay then....

IWCONFIG --

lo no wireless extensions.

eth0 no wireless extensions.

eth1 radio off ESSID:""
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=off Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

I'm no expert, but I assume that "radio off" bit has something to do with it...

Thanks for the continued help... (they gave up on me at Ubuntuforums...)
 
Old 02-17-2008, 06:28 PM   #22
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Actually, that isn't too bad. Does your laptop have a button or key combo that turns the wireless card on and off? If so, you might try cycling and see if the radio off message goes away. The other thing to do would be to try and configure your card. If possible, it would be easiest to try and do this without WPA/WEP just to keep it simple. Try setting the SSID:

iwconfig eth1 essid YourSSID

Hopefully, if you run iwconfig again, you'll see that the SSID is set and that you get a MAC address in the Access Point field. That would mean you're associated with the wireless AP and can request an IP address with ifup eth1.

Give it a go and post back any errors if it doesn't work.
 
Old 02-18-2008, 03:57 AM   #23
superdave7380
LQ Newbie
 
Registered: Feb 2008
Posts: 23

Rep: Reputation: 15
Alrighty then... we're gettin' somewhere... but we're not there yet.

First off, pressin' the li'l wireless switch on my laptop neither turned the little light on or off, or got rid of the "radio off" message...

I disabled the WPA2 on my router, and set the SSID... That worked... however... it didn't give me a MAC address..:

---
eth1 radio off ESSID:"Home!"
Mode:Managed Channel:0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=off Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
---

Then, for the fun of it, I tried your next step just for the hell of it...

---
david@david-laptop:~$ sudo ifup eth1
Internet Systems Consortium DHCP Client V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth1/00:16:6f:a5:6f:cf
Sending on LPF/eth1/00:16:6f:a5:6f:cf
Sending on Socket/fallback
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 3
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
---

NEXT?!

Oh, did I mention? The "ifup eth1" command gave me "Ignoring unknown interface eth1=eth1"... until I turned off the WPA2... I don't know if that's a clue or not, just thought I'd include everything...

Regardless of my router and it's settings, in the end, I should be able to use Ubuntu's network manager to see all the broadcasting wifi signals, no?

Anyhoo...

Again, thanks.
 
Old 02-18-2008, 05:16 AM   #24
TommyGun
LQ Newbie
 
Registered: Feb 2008
Location: Norway
Distribution: Ubuntu 7.10 Gutsy Gibbon
Posts: 15

Original Poster
Rep: Reputation: 0
I just found out I can connect wirelessly on unsecure networks, like now, I am connected wirelessly. But my home network is a bit more problematic, any idead what to do about it?
 
Old 02-18-2008, 05:23 AM   #25
TommyGun
LQ Newbie
 
Registered: Feb 2008
Location: Norway
Distribution: Ubuntu 7.10 Gutsy Gibbon
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by dstuartkelly View Post
Going a little off topic here, apologies.
I had some issues connecting to my access point alright.

Im a little paranoid about my WLAN, so had the following set up.
WPA2
SSID Hidden
DHCP Disabled.
MAC Address filtering.

What I found I needed to do was
Show the SSID
Change WPA to Version 1 and 2
Enable DHCP
Remove MAC Address filtering.

Im sure I added the correct MAC address.
iwconfig told me my wireless was eth1
and ifconfig showed me the Hardware Address of eth1 and that was appropriately added in.

Im not too worried about the SSID being broadcast.
The DHCP should be fixed easily enough.
Id like to put MAC Filtering back on again, will let you know how I get on.


Ahhhh.. percussive maintenance, nothing finer to get out your frustrations

-Dan
Hey Dan. How did you change your settings? Maybe that's what I need to do as well? Glad you got yours working though.
 
Old 02-18-2008, 05:51 AM   #26
dstuartkelly
LQ Newbie
 
Registered: Feb 2008
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by TommyGun View Post
Hey Dan. How did you change your settings? Maybe that's what I need to do as well? Glad you got yours working though.
Those settings were more router config than anything else.

I just pointed my web-browser at the routers admin interface, went into wireless and changed the settings on it.

This will depend on the router/access point you are using.
If you dont know your router address, and its working wired, check what IP is assigned as your gateway. Put that IP into a web browser and off you go.
If it doesnt respond in a web browser, it may have a telnet server you can connect to.

-Dan
 
Old 02-18-2008, 06:48 AM   #27
TommyGun
LQ Newbie
 
Registered: Feb 2008
Location: Norway
Distribution: Ubuntu 7.10 Gutsy Gibbon
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by dstuartkelly View Post
Those settings were more router config than anything else.

I just pointed my web-browser at the routers admin interface, went into wireless and changed the settings on it.

This will depend on the router/access point you are using.
If you dont know your router address, and its working wired, check what IP is assigned as your gateway. Put that IP into a web browser and off you go.
If it doesnt respond in a web browser, it may have a telnet server you can connect to.

-Dan
Ah cheers! I'll try that as soon as I get home.
Thanks!
 
Old 02-18-2008, 08:29 AM   #28
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
Quote:
Originally Posted by superdave7380
Mode:Managed Channel:0 Access Point: Not-Associated
This is really kind of funky. That channel 0 is just plain wrong, and almost certainly part of what is going wrong. If you know what channel your AP works on, try setting it:

iwconfig eth1 channel X


If you don't know the channel off the top of your head, try scanning for it:

iwlist eth1 scan (and you might have to be root to do it).

Quote:
Originally Posted by superdave7380
Oh, did I mention? The "ifup eth1" command gave me "Ignoring unknown interface eth1=eth1"... until I turned off the WPA2... I don't know if that's a clue or not, just thought I'd include everything...
At this point, I'm not real sure what that could mean. Until you can associate with your AP all sorts of wonky things could be happening with ifup.

Quote:
Originally Posted by superdave7380
Regardless of my router and it's settings, in the end, I should be able to use Ubuntu's network manager to see all the broadcasting wifi signals, no?
I would think so, but I'm not an Ubuntu user, so I guess I don't know for sure. One of the reasons I'm asking you to slog through the console stuff is that if the GUI widgets don't work, you don't see the errors, and therefore have no idea what is going wrong. You' wouldn't believe the number of threads that are variations of "The cursor just goes around and the wireless card just goes blinky, blinky, blinky. What could be wrong?"

Trying to solve that sort of a problem on a forum is pretty much impossible.
Quote:
Originally Posted by TommyGun
I just found out I can connect wirelessly on unsecure networks, like now, I am connected wirelessly. But my home network is a bit more problematic, any idead what to do about it?
Connecting on an unsecured network shows that your card and driver are working, so this is good. If you give us some details about what kind of security you've got on your home network and how you are trying to configure your card, we can give you some better pointers.
 
Old 02-18-2008, 03:48 PM   #29
superdave7380
LQ Newbie
 
Registered: Feb 2008
Posts: 23

Rep: Reputation: 15
Okay...

I set it to channel 1...

---

eth1 radio off ESSID:"Home!"
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power=off Sensitivity=8/0
Retry limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

---

So, that channel: 0 is gone... However, if I scan for a channel, I get "eth1 No scan results"

And now, when I "ifup eth1", I get "Ignoring unknown interface eth1=eth1."

Should I throw my laptop off an overpass into traffic? Would the traffic be superfluous? I mean, off an overpass should be enough...

Could it possibly be a simple hardware issue, ie, Ubuntu will never recognize the little wireless switch on the front of my laptop?
 
Old 02-18-2008, 05:30 PM   #30
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,803
Blog Entries: 1

Rep: Reputation: 416Reputation: 416Reputation: 416Reputation: 416Reputation: 416
That "radio off" thing is still there. Not good. I know, DUH!

I've done a bit of googling and found this in the installation instructions for the ipw2200

Code:
1.4.2 Device Level Sysfs Helper Files
-----------------------------------------------

For the device level files, look in
	
	/sys/bus/pci/drivers/ipw2200/{PCI-ID}/

For example:
	/sys/bus/pci/drivers/ipw2200/0000:02:01.0

For the device level files, see /sys/bus/pci/drivers/ipw2200:

  rf_kill
	read - 
	0 = RF kill not enabled (radio on)
	1 = SW based RF kill active (radio off)
	2 = HW based RF kill active (radio off)
	3 = Both HW and SW RF kill active (radio off)
	write -
	0 = If SW based RF kill active, turn the radio back on
	1 = If radio is on, activate SW based RF kill

	NOTE: If you enable the SW based RF kill and then toggle the HW
  	based RF kill from ON -> OFF -> ON, the radio will NOT come back on

What you need to do is find out of your radio kill switch is causing some problem. I've seen in an Ubuntu forum posting that looking in dmesg could give some clues. So try:

dmesg | grep ipw2200

That also might shed some light on things if something else is going wrong.

Quote:
Should I throw my laptop off an overpass into traffic? Would the traffic be superfluous? I mean, off an overpass should be enough...
I agree that the traffic would be a bit of an overkill, not to mention the safety danger. A reasonable alternative would be the KaleCo High Intensity Road Flare. I would think half a dozen should do the trick.....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Patching kernel on Ubuntu for Acer Travelmate C100 ACPI paradoxdruid Linux - Software 1 04-19-2007 11:13 AM
Mandriva 10.0 on Acer Travelmate 2413WLMin(travelmate 2410 series). Wireless... apolishch Linux - Laptop and Netbook 2 06-05-2006 09:03 AM
Ubuntu 5.04 and Acer Travelmate 8103 aciesd Linux - Laptop and Netbook 2 01-07-2006 09:24 AM
Ubuntu Linux + Acer Travelmate 230XC tsissus Linux - Laptop and Netbook 2 09-02-2005 08:31 PM
Ubuntu on an acer 290 travelmate SD-Plissken Ubuntu 2 08-31-2005 05:01 AM


All times are GMT -5. The time now is 05:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration