LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-24-2013, 01:43 PM   #1
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Rep: Reputation: Disabled
Question No wired internet during linux install


Hi everyone!

I just recently bought all the parts for a computer and my brother helped me to put it together. Then we tried to install Ubuntu, but it could not connect to the Internet so he installed windows 7 for me to search the net for a solution. I have since tried many distros, but none can connect during install or after, through the wired (onboard wired realtek pcie gbe family controller).

I then put in the hdd from my (very) old computer that has xubuntu 32bit installed and it instantly connected to the net!
The only difference I could find was that on this disc, the network was called eth1, but when I try to install Linux on the new computer (with all the new hardware and 64bit, it is being called eth0. I found out how to rename eth0 to eth1, but it makes no difference.

This is so strange, everything else is working perfect. From what I read, many people have problems with wireless connection and other hardware issues, but not with a simple nic.

I am not an advanced Linux user, I normaly just install it and everything is working. But just ask me if you need any more info about my system and so on.

Really hope anyone can help me with this so I can get Bill G out of my life again and feel free

Peace to ya'll!
 
Old 07-24-2013, 02:10 PM   #2
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
I'm not really sure on this one, try to give a specific version of your ethernet card with something like:

Code:
lspci -vv | grep realtek
Also what does the shell say when you try to use dhcpcd on eth0? eg '# dhcpcd eth0'
 
Old 07-24-2013, 02:28 PM   #3
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
Hi flyinggeorge, thanx for your reply,

I logged into the linux mint which I have installed along with win7 and tried to run your comands, but the first one gave no answer whatsoever and the second said it could'nt find eth0.

I then run ifconfig:



ifconfig eth1
eth1 Link encap:Ethernet HWaddr 94:de:80:0f:b5:b1
inet6 addr: fe80::96de:80ff:fe0f:b5b1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:724 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:141 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:92811 (92.8 KB) TX bytes:0 (0.0 B)


ifconfig -a
eth1 Link encap:Ethernet HWaddr 94:de:80:0f:b5:b1
inet6 addr: fe80::96de:80ff:fe0f:b5b1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:873 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:188 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:108699 (108.6 KB) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

Hope this helps you in any way!
 
Old 07-24-2013, 02:35 PM   #4
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
Okay, in the first example it's probably the | grep bit that's screwing you up. It's looking for a case sensitive "realtek" try to post the complete output of "lspci -v" As for the second try dhcpcd on eth1 I didn't realize you had changed it from the typical eth0. Sorry about that.

Just to make your posts more readible, try to utilize the {code} blocks {/code} replace { with [ the code blocks are useful when you have to post output from the shell, makes it easier to tell who is saying what.

Last edited by flyinggeorge; 07-24-2013 at 02:37 PM.
 
Old 07-24-2013, 02:56 PM   #5
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
Ok, I hope I get this right, sorry for newbe-mistakes!

Code:
lspci -v
00:00.0 Host bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (external gfx0 port B) (rev 02)
	Subsystem: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (external gfx0 port B)
	Flags: fast devsel
	Capabilities: <access denied>

00:02.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port B) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=01, subordinate=01, sec-latency=0
	I/O behind bridge: 0000e000-0000efff
	Memory behind bridge: fea00000-feafffff
	Prefetchable memory behind bridge: 00000000c0000000-00000000cfffffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:04.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port D) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=02, subordinate=02, sec-latency=0
	Memory behind bridge: fe900000-fe9fffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:09.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (PCI express gpp port H) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=03, subordinate=03, sec-latency=0
	I/O behind bridge: 0000d000-0000dfff
	Prefetchable memory behind bridge: 00000000d0000000-00000000d00fffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:0a.0 PCI bridge: Advanced Micro Devices [AMD] nee ATI RD890 PCI to PCI bridge (external gfx1 port A) (prog-if 00 [Normal decode])
	Flags: bus master, fast devsel, latency 0
	Bus: primary=00, secondary=04, subordinate=04, sec-latency=0
	Memory behind bridge: fe800000-fe8fffff
	Capabilities: <access denied>
	Kernel driver in use: pcieport

00:11.0 SATA controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode] (rev 40) (prog-if 01 [AHCI 1.0])
	Subsystem: Gigabyte Technology Co., Ltd Device b002
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 19
	I/O ports at f040 [size=8]
	I/O ports at f030 [size=4]
	I/O ports at f020 [size=8]
	I/O ports at f010 [size=4]
	I/O ports at f000 [size=16]
	Memory at feb0b000 (32-bit, non-prefetchable) [size=1K]
	Capabilities: <access denied>
	Kernel driver in use: ahci

00:12.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
	Memory at feb0a000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd

00:12.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
	Memory at feb09000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:13.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
	Memory at feb08000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd

00:13.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
	Memory at feb07000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:14.0 SMBus: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller (rev 42)
	Subsystem: Advanced Micro Devices [AMD] nee ATI SBx00 SMBus Controller
	Flags: 66MHz, medium devsel
	Kernel driver in use: piix4_smbus

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA) (rev 40)
	Subsystem: Gigabyte Technology Co., Ltd Device a014
	Flags: bus master, slow devsel, latency 32, IRQ 16
	Memory at feb00000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

00:14.3 ISA bridge: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller (rev 40)
	Subsystem: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 LPC host controller
	Flags: bus master, 66MHz, medium devsel, latency 0

00:14.4 PCI bridge: Advanced Micro Devices [AMD] nee ATI SBx00 PCI to PCI Bridge (rev 40) (prog-if 01 [Subtractive decode])
	Flags: bus master, VGA palette snoop, 66MHz, medium devsel, latency 64
	Bus: primary=00, secondary=05, subordinate=05, sec-latency=64
	I/O behind bridge: 0000c000-0000cfff
	Memory behind bridge: fe700000-fe7fffff

00:14.5 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI2 Controller (prog-if 10 [OHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
	Memory at feb06000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd

00:16.0 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB OHCI0 Controller (prog-if 10 [OHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 18
	Memory at feb05000 (32-bit, non-prefetchable) [size=4K]
	Kernel driver in use: ohci_hcd

00:16.2 USB controller: Advanced Micro Devices [AMD] nee ATI SB7x0/SB8x0/SB9x0 USB EHCI Controller (prog-if 20 [EHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5004
	Flags: bus master, 66MHz, medium devsel, latency 32, IRQ 17
	Memory at feb04000 (32-bit, non-prefetchable) [size=256]
	Capabilities: <access denied>
	Kernel driver in use: ehci-pci

00:18.0 Host bridge: Advanced Micro Devices [AMD] Family 15h Processor Function 0
	Flags: fast devsel
	Capabilities: <access denied>

00:18.1 Host bridge: Advanced Micro Devices [AMD] Family 15h Processor Function 1
	Flags: fast devsel

00:18.2 Host bridge: Advanced Micro Devices [AMD] Family 15h Processor Function 2
	Flags: fast devsel

00:18.3 Host bridge: Advanced Micro Devices [AMD] Family 15h Processor Function 3
	Flags: fast devsel
	Capabilities: <access denied>
	Kernel driver in use: k10temp

00:18.4 Host bridge: Advanced Micro Devices [AMD] Family 15h Processor Function 4
	Flags: fast devsel
	Kernel driver in use: fam15h_power

00:18.5 Host bridge: Advanced Micro Devices [AMD] Family 15h Processor Function 5
	Flags: fast devsel

01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cape Verde PRO [Radeon HD 7750] (prog-if 00 [VGA controller])
	Subsystem: XFX Pine Group Inc. Device 3248
	Flags: bus master, fast devsel, latency 0, IRQ 76
	Memory at c0000000 (64-bit, prefetchable) [size=256M]
	Memory at fea00000 (64-bit, non-prefetchable) [size=256K]
	I/O ports at e000 [size=256]
	Expansion ROM at fea40000 [disabled] [size=128K]
	Capabilities: <access denied>
	Kernel driver in use: fglrx_pci

01:00.1 Audio device: Advanced Micro Devices [AMD] nee ATI Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
	Subsystem: XFX Pine Group Inc. Device aab0
	Flags: bus master, fast devsel, latency 0, IRQ 75
	Memory at fea60000 (64-bit, non-prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: snd_hda_intel

02:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01) (prog-if 30 [XHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5007
	Flags: bus master, fast devsel, latency 0, IRQ 72
	Memory at fe900000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd

03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd Motherboard
	Flags: bus master, fast devsel, latency 0, IRQ 74
	I/O ports at d000 [size=256]
	Memory at d0004000 (64-bit, prefetchable) [size=4K]
	Memory at d0000000 (64-bit, prefetchable) [size=16K]
	Capabilities: <access denied>
	Kernel driver in use: r8169

04:00.0 USB controller: Etron Technology, Inc. EJ168 USB 3.0 Host Controller (rev 01) (prog-if 30 [XHCI])
	Subsystem: Gigabyte Technology Co., Ltd Device 5007
	Flags: bus master, fast devsel, latency 0, IRQ 73
	Memory at fe800000 (64-bit, non-prefetchable) [size=32K]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd

05:0e.0 FireWire (IEEE 1394): VIA Technologies, Inc. VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller (rev c0) (prog-if 10 [OHCI])
	Subsystem: Gigabyte Technology Co., Ltd GA-7VT600-1394 Motherboard
	Flags: bus master, medium devsel, latency 32, IRQ 22
	Memory at fe700000 (32-bit, non-prefetchable) [size=2K]
	I/O ports at c000 [size=128]
	Capabilities: <access denied>
	Kernel driver in use: firewire_ohci
Code:
dhcpcd eth1
The program 'dhcpcd' can be found in the following packages:
 * dhcpcd
 * dhcpcd5
Try: sudo apt-get install <selected package>
 
Old 07-24-2013, 03:14 PM   #6
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
I haven't looked through all of your lspci yet, but not having dhcpcd seems odd to me. I have always in the past used dhcpcd to connect an interface to the internet. My first thought is to see if you can find a *.deb for dhcpcd. Hopefully someone else will come along and correct me if I am wrong, but I'm pretty sure the network manager uses dhcpcd to connect to the internet also. I'm going to read around a bit hopefully I can help you.

Edit: According to some reading, you might have dhclient instead of dhcpcd. Try 'dhclient eth1'

Edit #2: I should have researched this a little more before posting my initial post. According to your lspci, you have a Realtek RTL8111/8168B which apparently does not work out of the box due to modprobe loading the wrong driver. See the link below for more information.

http://forums.linuxmint.com/viewtopic.php?f=49&t=80757

Last edited by flyinggeorge; 07-24-2013 at 03:20 PM.
 
Old 07-24-2013, 03:24 PM   #7
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
Yeah, I think you may be right there, the network manager is trying to connect for a while, then it sais disconnected and it starts all over again. But why is dhcpcd not being installed?

Thanx for trying to help, i really want to get Linux working so I can start enjoying my new machine!!
 
Old 07-24-2013, 03:38 PM   #8
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
I edited my post above it seems the modprobe is loading a faulty module for your internet card out of the box. The fix seems to be downloading the correct driver from realtek and installing it. You should end up with a *.ko file which you can then load with modprobe. This should fix your issue. If not feel free to report back with any problems. That link again:

http://forums.linuxmint.com/viewtopic.php?f=49&t=80757

As for dhcpcd not being installed, check if you have dhclient.
 
Old 07-24-2013, 03:45 PM   #9
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
Allright, will check this out and report back!
 
Old 07-24-2013, 07:04 PM   #10
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
I tried to load the new driver as mentioned. Did it even twice, once the mint distro and then on ubuntu as seen below:

Code:
danne@ubuntu:~/Dokument$ cd r8168-8.036.00
danne@ubuntu:~/Dokument/r8168-8.036.00$ ls
autorun.sh  Makefile  README  src
danne@ubuntu:~/Dokument/r8168-8.036.00$ sudo ./autorun.sh
sudo] password for danne: 

Check old driver and unload it.
rmmod r8169
Build the module and install
Can't read private key
Backup r8169.ko
rename r8169.ko to r8169.bak
DEPMOD 3.8.0-19-generic
load module r8168
Updating initramfs. Please wait.
update-initramfs: Generating /boot/initrd.img-3.8.0-19-generic
Warning: No support for locale: sv_SE.utf8
Completed.
danne@ubuntu:~/Dokument/r8168-8.036.00$ echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf
bash: /etc/modprobe.d/blacklist.conf: Permission denied
danne@ubuntu:~/Dokument/r8168-8.036.00$ sudo cp src/r8168.ko /lib/modules/3.8.0-19-generic/kernel/drivers/net/
danne@ubuntu:~/Dokument/r8168-8.036.00$ sudo depmod
danne@ubuntu:~/Dokument/r8168-8.036.00$ sudo modprobe r8168
danne@ubuntu:~/Dokument/r8168-8.036.00$
Still don't get no connection, but i found a new entry in BIOS: BIOS Features > Network Device BBs Priorities > Boot Option #1 = Realtek PXE B03 D00
So something must have happened!?

I also tried dhclient and I was told I had no permission for that??

Giving up is not an option since I really don't want to use Windows, but maybe there are other Linux distros that would work better for me, do you know any?
 
Old 07-24-2013, 07:11 PM   #11
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
dhclient has to be run as root. Try sudo dhclient eth1. Second, it looks like you haven't blacklisted the old module.

Code:
$ echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf
The above command needs to be run as root. Try adding sudo to it. Another option is using 'sudo su' to gain access to a root shell when you will be doing lots of work that you need to be root for. This way you don't have to sudo yourself to death. I think sudo -l or -i does something similar. I would bet that r8169 is still loading over the new r8168 module. Once you blacklist the module, just for fun, use rmmod or modprobe -r r8169. Finally, run 'dhclient eth1' all of this needs to be done as root or with 'sudo' in front of it. I don't think it is Ubuntu/Mint's fault. But personally, I have fallen in love with Slackware. Although Slackware is more for users that really want to learn more about the way Linux works. But before you go and re-install or anything, try the above. I bet we can work this out for you.

Also, don't forget to load the new module after blacklisting/rmmoding the old one.

Last edited by flyinggeorge; 07-24-2013 at 07:12 PM.
 
Old 07-24-2013, 08:53 PM   #12
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
Code:
danne danne # echo "blacklist r8169" >> /etc/modprobe.d/blacklist.conf
danne danne # sudo depmod
danne danne # modprobe r8168
danne danne # dhclient eth0
Cannot find device "eth0"
danne danne # dhclient eth1
danne danne #
still not working, but maybe because I did not load the new module as you said, how do I do that?

the lspci -command now returns more info and it says that I'm now using the right driver:

Code:
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
	Subsystem: Gigabyte Technology Co., Ltd Motherboard
	Flags: bus master, fast devsel, latency 0, IRQ 74
	I/O ports at d000 [size=256]
	Memory at d0004000 (64-bit, prefetchable) [size=4K]
	Memory at d0000000 (64-bit, prefetchable) [size=16K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] MSI: Enable+ Count=1/1 Maskable- 64bit+
	Capabilities: [70] Express Endpoint, MSI 01
	Capabilities: [b0] MSI-X: Enable- Count=4 Masked-
	Capabilities: [d0] Vital Product Data
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [140] Virtual Channel
	Capabilities: [160] Device Serial Number 00-00-00-00-68-4c-e0-00
	Kernel driver in use: r8168
I do want to learn more about Linux, until now I have just used it as any OS for getting online and doing everyday stuff. I just recently picked up three books from the library to learn more, but there is nothing on the problem we are trying to solve here. But maybe one day I join you using Slackware
 
Old 07-24-2013, 09:02 PM   #13
flyinggeorge
Member
 
Registered: Feb 2012
Location: United States
Distribution: Slackware 14.0
Posts: 159

Rep: Reputation: 3
You did load the correct module, that's what modprobe r8168 did for you. dhclient should return a lot more information. Just to verify, post the output of ifconfig eth1 on here for us. Chances are you won't find the solution to this issue in a book. This is driver specific problem. I used to have a laptop with a Broadcom 4312 wireless chip and I spent a very long time configuring it. But you are using the correct module now. So please boot back up to your linux and make sure you are using the correct module ('modprobe r8168') then run 'ifconfig eth1' to make sure that the interface is up.

For example, if I run 'ifconfig eth0 down' (I'm using wlan0 but I still have the wired interface eth0) I get: (when running 'ifconfig eth0' eth1 for you)
Code:
eth0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 10:bf:48:2b:b8:d3  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 49
Then if I turn the interface back on with 'ifconfig eth0 up' I get:

Code:
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 10:bf:48:2b:b8:d3  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 49
Notice that under flags, there is "UP"

If your device is up, there should be no problem using dhclient. And if you are using the same connection from Windows to access the internet we can safely rule out that it is faulty.

Edit: I hope one day you do join me using Slackware. I haven't used another distro in two years. Couldn't be happier.

Last edited by flyinggeorge; 07-24-2013 at 09:06 PM.
 
Old 07-24-2013, 09:46 PM   #14
kairaku
LQ Newbie
 
Registered: Jul 2013
Posts: 11

Original Poster
Rep: Reputation: Disabled
The 'dhclient eth1' takes some time, then I am being returned to the promt without getting any info.
The same goes for 'ifconfig eth0 up', it gives me nothing.
Yes, I'm using windows on the same machine to connect to the Internet. So I have to boot between the two, thats one of the reasons why I'm taking so long between posts..

well here is what I get from 'ifconfig':
Code:
danne danne # modprobe r8168
danne danne # ifconfig eth1
eth1      Link encap:Ethernet  HWaddr 94:de:80:0f:b5:b1  
          inet6 addr: fe80::96de:80ff:fe0f:b5b1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:16 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:158 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1399 (1.3 KB)  TX bytes:0 (0.0 B)
          Interrupt:74 Base address:0xa000
 
Old 07-24-2013, 09:56 PM   #15
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mint, OpenBSD
Posts: 11,333
Blog Entries: 12

Rep: Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729Reputation: 2729
Maybe I'm missing something, but eth0 commonly refers to a wired connection and eth1 (sometimes wlan0) commonly refers to a wireless connection. I saw this in your first post:

Quote:
The only difference I could find was that on this disc, the network was called eth1, but when I try to install Linux on the new computer (with all the new hardware and 64bit, it is being called eth0. I found out how to rename eth0 to eth1, but it makes no difference.
I doubt this is helping the situation; instead, I suspect it's muddying the water.

Have you tested with a wired connection?

Edit: I see you have. pardon my brainskip.

Last edited by frankbell; 07-24-2013 at 10:27 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cant connect to internet(wired) on linux maya 13 32-bit .mate pablo.b Linux - Networking 0 05-20-2012 02:34 AM
Linux to PC wired ad hoc network with internet sharing onlyhtml Linux - Networking 2 03-12-2011 12:38 PM
[SOLVED] Used wired to install now on wireless but system waits for wired dhcpoffer. lonniec Linux - Laptop and Netbook 3 03-08-2011 08:52 PM
how to connect wired broadband internet with ip in Linux 'ubuntu' Sanjoy Barman Linux - Newbie 2 07-18-2010 12:09 PM
Linux can't connect to internet with DHCP through Linksys wired router ruslan40321 Linux - Networking 9 03-30-2008 03:08 PM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration