LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 09-07-2012, 10:05 PM   #31
WyattEarp1
LQ Newbie
 
Registered: Sep 2012
Location: Florida
Distribution: BackBox 2.5
Posts: 24

Original Poster
Rep: Reputation: 0

from some quick research, it seems I built the driver against a different kernel then what I actually have?
I am not sure how I did that, or how to build the driver onto the correct kernel...
 
Old 09-07-2012, 10:20 PM   #32
schneidz
Senior Member
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 4,197

Rep: Reputation: 642Reputation: 642Reputation: 642Reputation: 642Reputation: 642Reputation: 642
another diagnostic:
Code:
modinfo /lib/modules/2.6.38-14-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723e/rtl8723e.ko
i think vermagic has to exactly match the output of
Code:
uname -r
i thought modprobe -f was supposed to ignore that parameter but i guess i was wrong.

maybe someone more knowledgeable than me will enlighten us with a solution.


edit: oh wait i think i made a typo:
Code:
sudo modprobe -f rtl18723e
should be:
Code:
sudo modprobe -f rtl8723e

Last edited by schneidz; 09-07-2012 at 10:26 PM.
 
Old 09-07-2012, 11:09 PM   #33
WyattEarp1
LQ Newbie
 
Registered: Sep 2012
Location: Florida
Distribution: BackBox 2.5
Posts: 24

Original Poster
Rep: Reputation: 0
oh shoot, I should have caught that. Looks like it didn't matter though, this is what it returned:
Code:
 me@My-Laptop:~$ sudo modprobe -f rtl8723e
[sudo] password for me: 
FATAL: Error inserting rtl8723e (/lib/modules/2.6.38-14-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723e/rtl8723e.ko): Invalid module format
then the diagnostic you gave me:
Code:
 
me@My-Laptop:~$ modinfo /lib/modules/2.6.38-14-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723e/rtl8723e.ko
filename:       /lib/modules/2.6.38-14-generic/kernel/drivers/net/wireless/rtlwifi/rtl8723e/rtl8723e.ko
firmware:       rtlwifi/rtl8723efw.bin
description:    Realtek 8723E 802.11n PCI wireless
license:        GPL
author:         Realtek WlanFAE	<wlanfae@realtek.com>
author:         lizhaoming	<chaoming_li@realsil.com.cn>
srcversion:     C495D10C50D3C85AE360841
alias:          pci:v000010ECd00008723sv*sd*bc*sc*i*
depends:        rtlwifi,mac80211
vermagic:       2.6.38-14-generic SMP mod_unload modversions 686 
parm:           swlps:bool
parm:           swenc:using hardware crypto (default 0 [hardware])
 (bool)
parm:           ips:using no link power save (default 1 is open)
 (bool)
parm:           fwlps:using linked fw control power save (default 1 is open)
 (bool)
 
Old 09-08-2012, 12:26 AM   #34
WyattEarp1
LQ Newbie
 
Registered: Sep 2012
Location: Florida
Distribution: BackBox 2.5
Posts: 24

Original Poster
Rep: Reputation: 0
by the way, I ran a livecd and there are no network devices detected. Nothing happens with the ethernet cable either.
 
Old 10-06-2012, 12:04 PM   #35
technokiddietoy
LQ Newbie
 
Registered: Oct 2012
Posts: 3

Rep: Reputation: Disabled
Link for anyone who came to this thread looking for an answer

Just in case you find this thread (as I did when I got my new laptop).
You can get the Atheros 1091 Ethernet controller working with the alx drivers, found at:

http://www.linuxfoundation.org/colla...networking/alx

You need the usual build tools (gcc, make, etc) as well as perl.

Hope this helps somebody.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using 2 network cards (wireless & ethernet) under SuSE 10.0 solar_neutrino Linux - Wireless Networking 1 09-18-2006 12:56 AM
wifi drivers with other ethernet cards sardok Linux - Wireless Networking 1 01-02-2006 07:49 AM
Fedora Core 1 as router but realtek ethernet cards don't activate Agapito Linux - Networking 0 02-03-2005 07:22 AM
Ethernet cards gone after dist-upgrade Cyrus XIII Debian 1 04-12-2004 03:19 AM
problem with two realtek 8139 ethernet cards w3bbuilder Linux - Newbie 1 08-15-2003 04:46 PM


All times are GMT -5. The time now is 02:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration