LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No. When I enter IWconfig, I get wlan1... Access point: Not Associated.can't connect (http://www.linuxquestions.org/questions/linux-newbie-8/no-when-i-enter-iwconfig-i-get-wlan1-access-point-not-associated-cant-connect-832095/)

fblack@gsinet.net 09-14-2010 10:56 AM

No. When I enter IWconfig, I get wlan1... Access point: Not Associated.can't connect
 
I'm trying to connect to a wireless network with a rt3070 USB attachment. It's not recognizing any networks. I'm using Slackware 13.1 on a 4-year-old Dell XPS 410.

Drakeo 09-14-2010 11:43 AM

Hey for slackware 13.1 please install wicd from slackware extra for 32 bit x86 here and for 64 bit x86_64
get it here

install reboot and look for the little icon on the bottom right.
I read your other problem from the other thread.
post lsusb thank you.

fblack@gsinet.net 09-14-2010 01:45 PM

I installed it and rebooted. It says no wireless networks were found.

Drakeo 09-15-2010 02:12 PM

open a terminal type modprobe rt3070usb and see if it loads the stable version for that device in the kernel is rt2800usb if you actually installed the rt3070usb you may have a conflict.
that said. open a terminal and assume root type lsusb and post it.

type dmesg | grep error post it
before you built it and why it does not build is the driver is maintained in the kernel. this is the 3070 build README_STA_usb
Quote:

* README
*
* Ralink Tech Inc.
*
* http://www.ralinktech.com
*

=======================================================================
ModelName:
===========
RT2870 Wireless Lan Linux Driver


=======================================================================
Driver lName:
===========
rt2870.o/rt2870.ko


=======================================================================
Supporting Kernel:
===================
linux kernel 2.4 and 2.6 series.
Tested in Redhat 7.3 or later.
that said modrprobe rt2800usb then ifconfig wlan0 up then iwconfig.

fblack@gsinet.net 09-16-2010 09:56 AM

rt3070usb not installed. rt2800 is.

iwconfig gives the following:

wlan1 IEEE 802.11bgn ESSID:"Zm"
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Management:on

Drakeo 09-17-2010 08:14 AM

please
Quote:

assume root type lsusb and post it
and
Quote:

type dmesg | grep error post it
this
Quote:

wlan1 IEEE 802.11bgn ESSID:"Zm"
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thrff Fragment thrff
Encryption keyff
Power Managementn
you do not have your card configured.

wlan1 means you have two devices wlan0 then wlan1.
if you want wlan1 to work you better configure it in WICD.
set it to use wlan1 default is wlan0.

you can always try .
Quote:

dhcpcd wlan1
look at the out put

fblack@gsinet.net 09-17-2010 12:11 PM

WICD was set to wlan1.

lsusb:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0488:0020 Cirque Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 002: ID 045e:00db Microsoft Corp. Natural Ergonomic Keyboard 4000 V1.0
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

dmesg
EXT3-fs (sda1): error: couldn't mount because of unsupported optional features (240)
EXT2-fs (sda1): error: couldn't mount because of unsupported optional features (244)

fblack@gsinet.net 09-18-2010 10:21 AM

dmesg returned this:


rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
rtusb init --->
usbcore: registered new interface driver rt2870
rt3070sta: module license 'unspecified' taints kernel.
Disabling lock debugging due to kernel taint
rt3070sta: Unknown symbol usb_alloc_urb
rt3070sta: Unknown symbol usb_free_urb
rt3070sta: Unknown symbol usb_register_driver
rt3070sta: Unknown symbol usb_put_dev
rt3070sta: Unknown symbol usb_get_dev
rt3070sta: Unknown symbol usb_submit_urb
rt3070sta: Unknown symbol usb_control_msg
rt3070sta: Unknown symbol usb_deregister
rt3070sta: Unknown symbol usb_kill_urb
rt3070sta: Unknown symbol usb_buffer_free
rt3070sta: Unknown symbol usb_buffer_alloc
udev: renamed network interface wlan0 to wlan1
fuse init (API version 7.13)
ppdev: user-space parallel port driver
lp: driver loaded but no devices found
Intel ISA PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
e1000e 0000:00:19.0: irq 28 for MSI/MSI-X
e1000e 0000:00:19.0: irq 28 for MSI/MSI-X
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
rt2800usb 1-1:1.0: firmware: requesting rt2870.bin
ADDRCONF(NETDEV_UP): wlan1: link is not ready

Drakeo 09-18-2010 12:05 PM

this is for slackware 13.1
from the looks of your out put you compiled and installed the 2870/3070 driver and installed it.
or maybe not. any way the driver in the kernel is experimental for the 2.6.33.4 slackware kernel.
.

this is what I did I down loaded and compiledRT8070/RT3070USB(RT307x)

then got the firmware installed iit in /lib/firm

reboot and lets see what are dmesg out put is

fblack@gsinet.net 09-19-2010 12:17 PM

I downloaded and installed the software. /lib/firmware contains 2870.bin.

phy0: Selected rate control algorithm 'minstrel'
Registered led device: rt2800usb-phy0::radio
Registered led device: rt2800usb-phy0::assoc
Registered led device: rt2800usb-phy0::quality
usbcore: registered new interface driver rt2800usb
cfg80211: World regulatory domain updated:
(start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
(2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
(5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
(5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
rt2870sta: module is from the staging directory, the quality is unknown, you have been warned.
rtusb init --->
usbcore: registered new interface driver rt2870
input: HDA Intel Line In at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
input: HDA Intel Mic at Ext Front Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
input: HDA Intel Mic at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
input: HDA Intel Line Out at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
input: HDA Intel Line Out at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
input: HDA Intel Line Out at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
input: HDA Intel Line Out at Ext Rear Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
input: HDA Intel HP Out at Ext Front Jack as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
rt3070sta: module license 'unspecified' taints kernel.
Disabling lock debugging due to kernel taint
rt3070sta: Unknown symbol usb_alloc_urb
rt3070sta: Unknown symbol usb_free_urb
rt3070sta: Unknown symbol usb_register_driver
rt3070sta: Unknown symbol usb_put_dev
rt3070sta: Unknown symbol usb_get_dev
rt3070sta: Unknown symbol usb_submit_urb
rt3070sta: Unknown symbol usb_control_msg
rt3070sta: Unknown symbol usb_deregister
rt3070sta: Unknown symbol usb_kill_urb
rt3070sta: Unknown symbol usb_buffer_free
rt3070sta: Unknown symbol usb_buffer_alloc
udev: renamed network interface wlan0 to wlan1
fuse init (API version 7.13)
ppdev: user-space parallel port driver
lp: driver loaded but no devices found
Intel ISA PCIC probe: not found.
Databook TCIC-2 PCMCIA probe: not found.
e1000e 0000:00:19.0: irq 28 for MSI/MSI-X
e1000e 0000:00:19.0: irq 28 for MSI/MSI-X
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
rt2800usb 1-1:1.0: firmware: requesting rt2870.bin
ADDRCONF(NETDEV_UP): wlan1: link is not ready
UDF-fs INFO UDF: Mounting volume 'UDF Volume', timestamp 2010/09/10 09:29 (1f10)
cdrom: sr0: dirty DVD+RW media, "finalizing"
UDF-fs INFO UDF: Mounting volume 'UDF Volume', timestamp 2010/09/10 09:29 (1f10)
cdrom: sr0: dirty DVD+RW media, "finalizing"
UDF-fs: Partition marked readonly; forcing readonly mount
UDF-fs INFO UDF: Mounting volume 'Sep 19 2010', timestamp 2010/09/19 11:45 (1f10)

Drakeo 09-22-2010 12:32 AM

it seems to be working fine you need to configure it for your router. Why do you use the usb wifi when that dell has a broadcom internal card.


All times are GMT -5. The time now is 06:48 AM.