LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-26-2005, 10:37 AM   #1
pfx
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Rep: Reputation: 0
No Video in X, Unless ..... Sax2 is ran in failsafe mode on each boot


Hello guys,

I've been trying to get my ATI X800 XT to work with 3D Acceleration in SUSE9.3 for a week now. Finally, after installing the latest drivers from suse's website (fglrx-8.14.13-0.1.i586.rpm and km_fglrx-8.14.13-0.1.i586.rpm) using the instructions from the readme file, it worked ... even with 3D enabled!

BUT ......

I can't get into KDE without doing the following on EVERY boot. =(

-Start SUSE via failsafe mode
-login root
-# sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl -i
-# init 5

If I do this on every boot, KDE loads and 3D works perfectly. But if I try to boot normally or startx from failsafe without running sax2, I get a black screen. Hopefully you guys can help me out, I was SO happy when I was finally able to get 3D accelearation to work but can't seem to figure out how to get into KDE without configuring fglrx on each and every boot.

Thanks for the help!
 
Old 06-26-2005, 06:51 PM   #2
otchie1
Registered User
 
Registered: Apr 2004
Posts: 560

Rep: Reputation: 30
I'm tempted to say put that in your boot scripts but that would be kinda ugly.

sax2 is a Suse only thing and the experts in it hang out over in the SuSe subconference (under distros)..probably best to go give them a tug.
 
Old 06-26-2005, 08:09 PM   #3
pfx
LQ Newbie
 
Registered: Jun 2005
Posts: 16

Original Poster
Rep: Reputation: 0
Thank you for the reply!

I had thought of doing the same thing but sax2 is a graphical program, I'm not sure how that would work. I have to run the command, exit sax2 and then startx.

I've changed the default init to 3 so I dont have to use failsafe boot (but still have to run sax2). It works but its kinda annoying doing this on every boot.

I'm almost happy to go though this on every boot because so many people have been unable to get their ATI graphics cards to work with 3d acceleration in linux.

I'll post over in the suse section per your suggestion. I'm still going to keep an eye on this thread so if anybody has a suggestion, let me know! =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
No video in X unless Sax2 is ran on every boot pfx Suse/Novell 18 07-06-2005 10:07 AM
after booting screen goes blank and will not boot in failsafe mode suse 9.1 personal hairy5050 Linux - Software 2 02-19-2005 10:36 PM
suse 9.2 in failsafe mode just hangs johnie1 Suse/Novell 1 01-05-2005 02:21 AM
kde will only start failsafe mode mbucks Linux - Software 2 09-22-2004 11:28 AM
how can I boot windows in "failsafe" mode with LILO? julian_s Linux - Newbie 5 01-19-2004 10:13 AM


All times are GMT -5. The time now is 06:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration