LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-25-2015, 02:37 PM   #1
william_goat
LQ Newbie
 
Registered: Jul 2015
Posts: 5

Rep: Reputation: Disabled
Angry No valid OpenPGP data


I have been all over the net for a week trying to fix this. Cant connect to any keyserver always timing out. Info for linux help is a complete mess. loads of suggestions with no way to tell whats good or bad advice. If anyone can help me fix this. I can read and follow instructions. Please dont suggest:
gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
or
gpg --keyserver keyserver.ubuntu.com:80 --recv-keys 94558F59
or
sudo gpg --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys SOMEKEY
none of this works but you see it repeated all over. If the main repeated solution doesnt work where does a person go? I know im asking a question and voicing frustartion together but linux is like traveling to the new world. One mistake can be fatal and you are all alone at sea. Fix these issues and adoption rates would likely soar. everyone likes free. No one like complicated. I can send terminal output if necessary. Ubuntu 12.04 LTS
 
Old 07-25-2015, 05:28 PM   #2
william_goat
LQ Newbie
 
Registered: Jul 2015
Posts: 5

Original Poster
Rep: Reputation: Disabled
i need help with this:
~$ sudo apt-get install gpa seahorse
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gpa
~$ sudo gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
[sudo] password for j:
gpg: WARNING: unsafe ownership on configuration file `/home/**/.gnupg/gpg.conf'
gpg: external program calls are disabled due to unsafe options file permissions
gpg: keyserver communications error: general error
gpg: keyserver receive failed: general error
~$
 
Old 07-25-2015, 06:05 PM   #3
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 276Reputation: 276Reputation: 276
There is no package named gpa, so you get an error. Why are you putting gpa there? Exactly what do you want to do? Your rant doesn't help, and doesn't explain what problems you're having.
 
Old 07-25-2015, 06:08 PM   #4
Habitual
LQ Addict
 
Registered: Jan 2011
Location: Youngstown, Ohio
Distribution: LM17.1/Xfce4.11.8
Posts: 7,158
Blog Entries: 10

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
Code:
sudo gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
[sudo] password for jj: 
gpg: WARNING: unsafe ownership on configuration file `/home/jj/.gnupg/gpg.conf'
gpg: external program calls are disabled due to unsafe options file permissions
gpg: keyserver communications error: general error
gpg: keyserver receive failed: general error
and without sudo, as myself:
Code:
gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
gpg: requesting key 94558F59 from hkp server pgp.mit.edu
gpg: key 94558F59: public key "Spotify Public Repository Signing Key <operations@spotify.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
jj@my-kungfu ~ $
and as root:
Code:
gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
gpg: directory `/root/.gnupg' created
gpg: new configuration file `/root/.gnupg/gpg.conf' created
gpg: WARNING: options in `/root/.gnupg/gpg.conf' are not yet active during this run
gpg: keyring `/root/.gnupg/secring.gpg' created
gpg: keyring `/root/.gnupg/pubring.gpg' created
gpg: requesting key 94558F59 from hkp server pgp.mit.edu
gpg: /root/.gnupg/trustdb.gpg: trustdb created
gpg: key 94558F59: public key "Spotify Public Repository Signing Key <operations@spotify.com>" imported
gpg: Total number processed: 1
gpg:               imported: 1  (RSA: 1)
I'd say YMMV but it shouldn't. Your results should be exactly the same.
 
Old 07-26-2015, 03:50 AM   #5
fatmac
Senior Member
 
Registered: Sep 2011
Location: Surrey/Hants Border, UK
Distribution: BSD & Linux - As long as they are Lightweight
Posts: 1,491

Rep: Reputation: Disabled
Rants will always get ignored, civility is required to get people to answer your questions.
 
Old 07-28-2015, 02:17 PM   #6
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 4,087
Blog Entries: 10

Rep: Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520Reputation: 1520
Quote:
Originally Posted by william_goat View Post
i need help with this:
~$ sudo apt-get install gpa seahorse
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package gpa
~$ sudo gpg --keyserver hkp://pgp.mit.edu --recv-keys 94558F59
[sudo] password for j:
gpg: WARNING: unsafe ownership on configuration file `/home/**/.gnupg/gpg.conf'
gpg: external program calls are disabled due to unsafe options file permissions
gpg: keyserver communications error: general error
gpg: keyserver receive failed: general error
~$
Sorry you're having difficulties, and feel that the Linux experience is very bad.

We'll try to work with you towards a solution.

Sounds like you're trying to install Seahorse. Is this correct?

Can you respond telling us which Linux distribution and release you are running? If you don't know, we can likely offer some commands or other information to help you determine that information. This will help with people giving you correct answers.

Regarding apt-get, I see that you are using sudo, and this is good because it is the correct way. Sudo is a way to give a normal user, super-user, or admin, level privileges in order to do something like a software install.

Another possible suggestion is if you happen to be running a graphical desktop, many of the distributions have software package manager interfaces which you can run from the desktop. And then within those they'll allow you to search for things like "seahorse" and check check it off and install it. The best of those interfaces will also pop up stuff like "By installing this you need other stuff, which has been highlighted and selected ... Agree? Y/N". Again, we'd need to know your distribution in order to provide a better recommendation.

Things to remember:
  1. Using apt-get you need to be on the Internet because the package installer will look to the network for the files it needs to download
  2. A good first step is to run "sudo apt-get update" before doing anything. What this does is update what's called the "repository" which is the list of sites the installer goes to in order to download latest files.
  3. Two potential issues are:
    1. What version of your distribution you are running. If you happen to be running something very old, say you inherited a system or were given a system, or merely downloaded a very old version of Linux, this will make things more difficult, so that's why it's helpful to know what distribution and version you are running
    2. Whether or not apt-get is the correct package manager. Apt-get really full name is "Aptitute" is ONE package manager. Different Linux distributions use different package managers, some of them use multiple ones. You may have read instructions on the web telling you to take these actions and they may be poorly fitted for your case. It does however appear that Aptitude is on your system, otherwise you'd have encountered a different type of error.

Last edited by rtmistler; 07-28-2015 at 02:21 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gpg: no valid OpenPGP data found prkhr4u Linux - Software 2 12-31-2013 09:55 PM
Transmitting data ...Scheduler: Event UID not valid! (gdb) bt No stack. aicaicai Linux - Newbie 0 04-24-2012 08:48 AM
550 relay not permitted Valid RCPT command must precede DATA chiyamhad Linux - Newbie 1 03-05-2008 10:54 AM
gpg: no valid OpenPGP data found in Debian etch Amba Giri Debian 1 12-15-2007 04:35 PM
thunderbird: "No valid armored OpenPGP data block found" xpucto Linux - Newbie 2 07-03-2007 07:52 AM


All times are GMT -5. The time now is 06:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration