LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-25-2005, 04:31 PM   #1
mcgoon
Member
 
Registered: Sep 2004
Location: Sydney, Australia
Distribution: Fedora Core 2
Posts: 42

Rep: Reputation: 15
no user permissions on windows NTFS partition


Just a little thing that's really bugging me so I'm hoping someone can please help me.

I run a dual boot with Windows 2000 and FC2. I recently decided it might be worth me mounting my Win NTFS partition so I can access the files on it.

Only problem is when I go to read the partition, the only one who has the priviledges to do so are is the SU. It works fine if I chmod +755 -R /mnt/NTFS.
However, when I restart my computer it resets to the SU root priviledges only.

So I figured OK and added the chmod line to my rc.local script. This solved the problem but has added about an extra minute on to the startup time - which in the grand scheme of things is not worth my bother. (I may as well just manually chmod when I need access!) Aghhh!

Is there anyway to do the chmod and for the changes to remain in affect? Am I just missing an option in my chmod command?

Any help would be GREATLY appreciated!!!
 
Old 01-25-2005, 04:37 PM   #2
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Add a umask option to your /etc/fstab, so that it becomes something along the lines of:
Code:
/dev/hda2       /windows        ntfs    ro,noauto,user,umask=0022       0       0
Cheers,

mj
 
Old 01-26-2005, 08:08 AM   #3
mcgoon
Member
 
Registered: Sep 2004
Location: Sydney, Australia
Distribution: Fedora Core 2
Posts: 42

Original Poster
Rep: Reputation: 15
Thanks, it worked beautifully.
I also added "mount /mnt/NTFS" to my icewm startup files so I wouldn't have to bother mounting it each time .
Nice, quick and easy!
Cheers!
 
Old 01-26-2005, 04:09 PM   #4
mjrich
Senior Member
 
Registered: Dec 2001
Location: New Zealand
Distribution: Debian
Posts: 1,046

Rep: Reputation: 45
Great to hear

To have the partition mounted automatically, you can probably just remove the "noauto" option from the NTFS line in /etc/fstab. This should cause it to be mounted along with your root partition at boot up.

Cheers,

mj
 
Old 01-28-2005, 04:26 AM   #5
mcgoon
Member
 
Registered: Sep 2004
Location: Sydney, Australia
Distribution: Fedora Core 2
Posts: 42

Original Poster
Rep: Reputation: 15
all is well and works perfectly now!
thankyou. you're a champion
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ntfs partition permissions trawler Linux - General 2 10-23-2005 06:27 PM
USB/ntfs drive and user permissions FC3noob Linux - Newbie 1 02-16-2005 11:37 AM
Can't change the read permissions on an NTFS partition as root? EOHooligan Linux - Newbie 4 01-09-2005 07:48 AM
Permissions for NTFS partition MikTheUser Slackware 5 07-08-2004 08:41 PM
Change permissions on NTFS partition to read for all users bax Linux - Newbie 6 05-13-2002 08:35 AM


All times are GMT -5. The time now is 04:25 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration