LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2004, 02:28 AM   #1
kam_kenneth
Member
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 50

Rep: Reputation: 15
No user access to ntfs disk?


Hi all.

I want to be able to view the contents of my mounted drive in /mnt/windows with users other than root. So far I have been denied access. I have tried to change the group ownership (ken in group windows) and still access denied. Is there anyway to fix this?
 
Old 05-04-2004, 02:46 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
Try mounting with the option "umask=0"
 
Old 05-04-2004, 03:11 AM   #3
Grymme
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
If you want a group to own the ntfs-disk then you need to pass a gid=xxx when you mount it.

I have done this in my /etc/fstab so it loads the ntfs-disk on startup. You simply put the gid=xxx among the comma-separated mountoptions in fstab on the line with the ntfs-device if this is what you want...

Of course you should have a nice number that corresponds to your group instead of xxx which you can look up in /etc/group

You might also want to pass auto and ro with the gid-option. Last time (pretty recent) I heard the ntfs drivers were buggy when it comes to writing but does fine reading. In the worst case you could mess up the whole ntfs-partition writing to it.
 
Old 05-04-2004, 05:08 AM   #4
kam_kenneth
Member
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 50

Original Poster
Rep: Reputation: 15
ok, i will try both of those options

i have no intention in trying to write to ntfs I heard thats the other way to format your harddrive
 
Old 05-04-2004, 07:52 AM   #5
kam_kenneth
Member
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 50

Original Poster
Rep: Reputation: 15
> <

i cant get it to work. This is the problem. When i mount the RO NTFS, i can't change the permissions. Is there a way to change this? I can't change it because its RO
 
Old 05-04-2004, 09:30 AM   #6
Grymme
Member
 
Registered: Apr 2004
Location: Sweden
Distribution: Slackware
Posts: 44

Rep: Reputation: 15
hm, add a umask=022 after the gid=xxx in the fstab

This should set the permissions to r and x

Last edited by Grymme; 05-04-2004 at 09:34 AM.
 
Old 05-05-2004, 02:50 AM   #7
kam_kenneth
Member
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 50

Original Poster
Rep: Reputation: 15
ok, i will try that
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NTFS user access in slack 10.2 fdahl_009 Slackware 4 10-15-2005 07:20 AM
Not Able to Access NTFS as normal user rob0t Slackware 6 09-21-2005 06:57 PM
(9.3) Firewire external NTFS disk access as root only 1kyle SUSE / openSUSE 1 09-01-2005 02:01 PM
NTFS access as user aje Slackware 5 12-03-2004 10:23 PM
Can't access ntfs driver as a user shibatatie Slackware 10 07-19-2004 09:22 AM


All times are GMT -5. The time now is 02:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration