LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 08-17-2012, 08:43 PM   #1
odin_ago
Member
 
Registered: Mar 2011
Posts: 41

Rep: Reputation: 0
No terminal beep in a new debian xfce installation


I have recently installed debian stable with xfce, and I get no beep in any terminal after echo $'\a'. alsamixer says shows that all kinds of sound are on, aplay plays wav files.
Code:
lsmod |grep pcspkr
says pcspkr is loaded
Code:
xset -q
says the bell is on
Code:
~/.config/Terminal/terminalrc
contains the line
Code:
MiscBell=TRUE
but I hear no bell in the standard xfce terminal, in xterm and in the "pure text" mode (after ctrl-alt-f1)
 
Old 08-17-2012, 09:19 PM   #2
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
Do you have usblp loaded? I've seen people report that (for some reason) gets the beep too. Also, do you have snd-hda-intel loaded? On my computer, unloading the pcspkr module doesn't actually do anything. Only loading the snd-hda-intel module gets me the beep.

Alex Brinister
 
Old 08-18-2012, 06:47 AM   #3
odin_ago
Member
 
Registered: Mar 2011
Posts: 41

Original Poster
Rep: Reputation: 0
usplp was not loaded, I've loaded it and this did not help. snd-hda-intel did not appear in
Code:
lsmod |grep snd-hda-intel
after
Code:
modprobe snd-hda-intel
, despite modprobe did not say that something is wrong. The beep did not appear.
 
Old 08-18-2012, 11:16 AM   #4
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
Do you have a "Beep" bar in alsamixer? I'll post a screenshot of mine.

Alex Brinister
Attached Images
File Type: png alsamixer.png (98.4 KB, 8 views)
 
Old 08-18-2012, 12:10 PM   #5
odin_ago
Member
 
Registered: Mar 2011
Posts: 41

Original Poster
Rep: Reputation: 0
Yes, I have it, and it is switched on (something like 50%)
 
Old 08-18-2012, 01:18 PM   #6
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
Here is something:

Quote:
n my Oneiric system I had to do the following to get XBell/XkbBell working again:
Load the module pcspkr (like you already did via /etc/modprobe.d/blacklist.conf)
Remove the package pulseaudio-module-x11 (that seems to absorb all XBell events)
Put options snd-hda-intel beep_mode=2 into /etc/modprobe.d/enable-beep.conf (you only need that case you own a system with an intel sound chip like my Latitude E6420). Unmute the speaker in alsamixer after that.

Some terminals (like konsole, see bug Bug 177861) ignore the bell character. A good way to test the system beep is with the xkbbell command.

After I did all that the java call Toolkit.getDefaultToolkit().beep() works just fine.
Alex Brinister
 
Old 08-18-2012, 04:22 PM   #7
odin_ago
Member
 
Registered: Mar 2011
Posts: 41

Original Poster
Rep: Reputation: 0
pcspkr was not blacklisted in /etc/modprobe.d/blacklist.conf .
package pulseaudio-module-x11 was not installed
after I have added the option beep_mode=2, snd_hda_intel refused to load, it said that it does not know this option.

I don't use konsole, but xkbbell produces no sound in xterm and xfce terminal.
 
Old 08-19-2012, 12:02 AM   #8
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
According to modinfo, snd-hda-intel does have this option:

Code:
[fluffypony@0xffeDAEMONPAWNY1969 ~]$ modinfo snd-hda-intel 
filename:       /usr/lib/modules/3.4.9-1-ARCH/kernel/sound/pci/hda/snd-hda-intel.ko.gz
description:    Intel HDA driver
license:        GPL
alias:          pci:v00001022d*sv*sd*bc04sc03i00*
alias:          pci:v00001002d*sv*sd*bc04sc03i00*
alias:          pci:v000015ADd00001977sv*sd*bc*sc*i*
alias:          pci:v000017F3d00003010sv*sd*bc*sc*i*
alias:          pci:v00001102d00000009sv*sd*bc*sc*i*
alias:          pci:v00006549d00001200sv*sd*bc*sc*i*
alias:          pci:v000010DEd*sv*sd*bc04sc03i00*
alias:          pci:v000010B9d00005461sv*sd*bc*sc*i*
alias:          pci:v00001039d00007502sv*sd*bc*sc*i*
alias:          pci:v00001106d00003288sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAB0sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAA8sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AAA0sv*sd*bc*sc*i*
alias:          pci:v00001002d00009902sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA48sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA40sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA38sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA30sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA28sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA20sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA18sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA10sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA08sv*sd*bc*sc*i*
alias:          pci:v00001002d0000AA00sv*sd*bc*sc*i*
alias:          pci:v00001002d0000970Fsv*sd*bc*sc*i*
alias:          pci:v00001002d0000960Fsv*sd*bc*sc*i*
alias:          pci:v00001002d00007919sv*sd*bc*sc*i*
alias:          pci:v00001002d0000793Bsv*sd*bc*sc*i*
alias:          pci:v00001022d0000780Dsv*sd*bc*sc*i*
alias:          pci:v00001002d00004383sv*sd*bc*sc*i*
alias:          pci:v00001002d0000437Bsv*sd*bc*sc*i*
alias:          pci:v00008086d*sv*sd*bc04sc03i00*
alias:          pci:v00008086d00003A6Esv*sd*bc*sc*i*
alias:          pci:v00008086d00003A3Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000293Fsv*sd*bc*sc*i*
alias:          pci:v00008086d0000293Esv*sd*bc*sc*i*
alias:          pci:v00008086d0000284Bsv*sd*bc*sc*i*
alias:          pci:v00008086d0000269Asv*sd*bc*sc*i*
alias:          pci:v00008086d000027D8sv*sd*bc*sc*i*
alias:          pci:v00008086d00002668sv*sd*bc*sc*i*
alias:          pci:v00008086d0000080Asv*sd*bc*sc*i*
alias:          pci:v00008086d0000811Bsv*sd*bc*sc*i*
alias:          pci:v00008086d00008C20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001E20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001D20sv*sd*bc*sc*i*
alias:          pci:v00008086d00001C20sv*sd*bc*sc*i*
depends:        snd-hda-codec,snd-pcm,snd,snd-page-alloc
intree:         Y
vermagic:       3.4.9-1-ARCH SMP preempt mod_unload modversions 
parm:           index:Index value for Intel HD audio interface. (array of int)
parm:           id:ID string for Intel HD audio interface. (array of charp)
parm:           enable:Enable Intel HD audio interface. (array of bool)
parm:           model:Use the given board model. (array of charp)
parm:           position_fix:DMA pointer read method.(0 = auto, 1 = LPIB, 2 = POSBUF, 3 = VIACOMBO, 4 = COMBO). (array of int)
parm:           bdl_pos_adj:BDL position adjustment offset. (array of int)
parm:           probe_mask:Bitmask to probe codecs (default = -1). (array of int)
parm:           probe_only:Only probing and no codec initialization. (array of int)
parm:           single_cmd:Use single command to communicate with codecs (for debugging only). (bool)
parm:           enable_msi:Enable Message Signaled Interrupt (MSI) (bint)
parm:           patch:Patch file for Intel HD audio interface. (array of charp)
parm:           beep_mode:Select HDA Beep registration mode (0=off, 1=on, 2=mute switch on/off) (default=1). (array of int)
parm:           power_save:Automatic power-saving timeout (in second, 0 = disable). (int)
parm:           power_save_controller:Reset controller in power save mode. (bool)
parm:           align_buffer_size:Force buffer and period sizes to be multiple of 128 bytes. (bint)
parm:           snoop:Enable/disable snooping (bool)
Is the beep even on in your kernel? Check this by issuing the following command:

Code:
zcat /proc/config.gz | grep BEEP
If it returns this:

Code:
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_BEEP_MODE=1
Then it's enabled. If the snd-hda-intel module does not have that option, then the module you are using is outdated. This is to be expected with the 2.6.32 series kernel Debian stable uses.

Alex Brinister
 
Old 08-19-2012, 05:52 PM   #9
odin_ago
Member
 
Registered: Mar 2011
Posts: 41

Original Poster
Rep: Reputation: 0
I don't have the file named config.gz in /proc/ .
And my module snd-hda-intel indeed has version 2.6.32-something, not 3.4.9-1-ARCH like yours. How do I update it? Some googling suggests me that it is in the package linux-image, but aptitude only suggests version 2.6.32-something, and says that it is already installed.
 
Old 08-20-2012, 12:04 AM   #10
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
Mine is 3.9.4-1-ARCH because a) I use Arch Linux and b) because Arch is a rolling release. This means that there are no definitive versions of the distro. All packages get updated when a new version comes out.

You are using an old kernel.

Quote:
If the snd-hda-intel module does not have that option, then the module you are using is outdated. This is to be expected with the 2.6.32 series kernel Debian stable uses.
The 2.6.32 series is really outdated. You should consider upgrading to Wheezy if you want the newer packages. Or use some other new distro like Ubuntu 12.04 or Fedora 17.

Alex Brinister
 
Old 08-20-2012, 05:18 AM   #11
odin_ago
Member
 
Registered: Mar 2011
Posts: 41

Original Poster
Rep: Reputation: 0
OK, then I ask all the forum participants again: how can I make the beep work if I stay in debian squeeze? I would like to do this because:
1. I have some experience in using debian as normal user (not as root), and
2. The computer I am speaking about is not very fast, so I am not sure that wheezy (which is also declared as less stable) will not be too slow.
 
Old 08-20-2012, 09:05 AM   #12
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
You could try to compile a new kernel. But if you're into apt handling all software, then this wouldn't be a good solution.

Alex Brinister
 
Old 08-20-2012, 09:39 AM   #13
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Just to let you know I have no system beep in the terminal using XFCE on Sid. That's on two separate systems a netbook and a desktop (both kernel's labelled 3.2.0-3 but 686 and AMD64 respectively). I've not carried out any troubleshooting though as I don't miss it -- personally I tend to blame Pulse Audio for this kind of thing until proven otherwise.
 
Old 08-20-2012, 10:09 AM   #14
abrinister
Member
 
Registered: Dec 2010
Location: /home
Distribution: RL: Arch x64 VM: Debian
Posts: 460

Rep: Reputation: 38
That's interesting, because I also have PulseAudio installed and I do get a system beep. I can turn it on and off in AlsaMixer. Here is my set up.

/etc/modprobe.d/modprobe.conf

Code:
blacklist usblp 
blacklist pcspkr

options snd-hda-intel enable_msi=1
options snd-hda-intel vendor=hp
In Arch, I load the alsa daemon during startup. This is set up in /etc/rc.conf (I don't know the equivilent for Debian).

** EDIT **

In Debian, this would be a SysV init script under /etc/rc2.d/

** /EDIT **

Also,

modules line in /etc/mkinitcpio.conf

Code:
MODULES="snd_hda_intel rts_pstor nfs xfs vfat ntfs uhci_hcd usbcore"
All of my PulseAudio and ALSA configuration is default (except a sample rate change from S16_LE to s32_LE in PulseAudio, but it worked before that change).

/etc/asound.conf

Code:
defaults.pcm.card 0
defaults.pcm.device 0
defaults.ctl.card 0

# Use PulseAudio by default
pcm.!default {
  type pulse
  fallback "sysdefault"
  hint {
    show on
    description "Default ALSA Output (currently PulseAudio Sound Server)"
  }
}

ctl.!default {
  type pulse
  fallback "sysdefault"
}
The lines I changed in /etc/pulse/daemon.conf

Code:
default-sample-rate = 192000

default-sample-format = s32le

flat-volumes = no
/etc/pulse/default.pa

Code:
#!/usr/bin/pulseaudio -nF
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify it
# under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software Foundation,
# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.

# This startup script is used only if PulseAudio is started per-user
# (i.e. not in system mode)

.nofail

### Load something into the sample cache
#load-sample-lazy x11-bell /usr/share/sounds/gtk-events/activate.wav
#load-sample-lazy pulse-hotplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-coldplug /usr/share/sounds/startup3.wav
#load-sample-lazy pulse-access /usr/share/sounds/generic.wav

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink
#load-module module-alsa-source device=hw:1,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect
.else
### Use the static hardware detection module (for systems that lack udev/hal support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
.nofail
load-module module-console-kit
.fail
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Load DBus protocol
.ifexists module-dbus-protocol.so
load-module module-dbus-protocol
.endif

# X11 modules should not be started from default.pa so that one daemon
# can be shared by multiple sessions.

### Load X11 bell module
#load-module module-x11-bell sample=bell-windowing-system

### Register ourselves in the X11 session manager
#load-module module-x11-xsmp

### Publish connection data in the X11 root window
#.ifexists module-x11-publish.so
#.nofail
#load-module module-x11-publish
#.fail
#.endif

load-module module-switch-on-port-available

### Make some devices default
#set-default-sink output
#set-default-source input
Alex Brinister

Last edited by abrinister; 08-20-2012 at 10:26 AM.
 
Old 08-20-2012, 10:15 AM   #15
273
Senior Member
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 3,508

Rep: Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800Reputation: 800
Alsamixer is practically empty on both my systems -- only containing one output control.
Both systems are as installed the only changes being enabling SPDIF out on the PC.
I think it's safe to say that for one reason or another I've never had everything working "properly" under Pulse Audio since it came with Ubuntu years ago.
 
  


Reply

Tags
debian, terminal


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Terminal Shutdown -h -P with a beep? Amdx2_x64 Linux - General 3 11-03-2010 01:59 PM
[SOLVED] Where's my beep? (GNOME Terminal) jsteel Linux - General 5 01-17-2010 05:04 PM
Debian goes Beep Beep? SuperDude123 Linux - Newbie 3 12-20-2009 03:49 AM
xFCE 4.4 Beta installation issue - Terminal Widget paulocr Linux - Software 0 05-10-2006 08:49 AM
Xfce installation for Debian 3.0 chian Debian 4 07-03-2004 06:42 AM


All times are GMT -5. The time now is 02:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration