LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-28-2011, 09:11 PM   #1
Suec7832
LQ Newbie
 
Registered: Aug 2011
Posts: 1

Rep: Reputation: Disabled
no support for locale: en_Us.itf8 Stuck found some post but still Stuck!!


Apparently this is a common problem with a simple solution if you know what your doing from the start.I found a few post and managed to correctly list my locales (locale -a). And now I am stuck totally.............I type in grep $HOME and nothing happened then I typed in /etc ja_JP.itf8 and then I type edit/etc/locale.gen .........so I tried to go back and retyped locale -a.................Now I am sitiing here staring at this computer trying to figure out what to do. I managed to install Ubuntu and was trying to switch to Xubuntu because I am using an older laptop.Please help I will be up for hours tonight because I am not even sure if I can shut this off with this window open.If you direct me to an older post please make sure it is line by line step bystep instructions....I am truly a monkey see monkey do but know nothing about computer languages I am trying to save an old laptop from the recycle bin.......Frustrated.....Thank You So much
When I say line by line I mean how do I restart the locale -a command (if necessary) correct the problem with type: and then exactly what I need to type. once again thank you

Last edited by Suec7832; 08-28-2011 at 09:35 PM. Reason: added info
 
Old 08-30-2011, 09:13 AM   #2
pigkouinos
LQ Newbie
 
Registered: May 2011
Posts: 15

Rep: Reputation: 10
To check if your system supports the locale you're looking for, let's say japanese, you enter this command:
locale -a | grep ja_JP.utf8

If it's not supported, enter this command to generate it:
sudo locale-gen ja_JP.utf8 (or any other locale you want)

Once you know it is supported and you want to change your system locale,

sudo update-locale LANG=en_US.UTF-8
(for us english system) OR...

update-locale LANG=ja_JP.UTF-8 LC_MESSAGES=POSIX
(japanese system, with english system messages)

Alternatively you could manually edit /etc/default/locale. It's the same thing.

Reboot
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
locale setting, problem with en_US.UTF-8 pru Linux - Software 4 04-18-2008 05:07 AM
Help needed with font installation on Debian 3.1 with locale all set to en_US.UTF-8 PhantmShado Linux - Software 1 02-20-2006 04:50 PM
no screens found : I'm stuck samael26 Debian 5 07-16-2005 02:22 PM
locale is en_US.UTF-8, but gnome turns out to chinese envirement donkey301 Debian 1 03-02-2005 11:50 AM
Stuck with CLI on post install Kyl3 Fedora - Installation 4 07-26-2004 02:20 PM


All times are GMT -5. The time now is 05:44 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration