LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2015, 03:36 AM   #16
tlan
LQ Newbie
 
Registered: Aug 2003
Location: Chicago, IL USA
Distribution: Debian 8 Jessie *gnome /kde. Ubuntu mate
Posts: 18

Rep: Reputation: 2

also check .trash in /

and delete the log files as root >> start over
 
Old 02-15-2015, 06:04 AM   #17
Head_on_a_Stick
Senior Member
 
Registered: Dec 2014
Location: London, England
Distribution: Arch & Debian
Posts: 1,183

Rep: Reputation: 283Reputation: 283Reputation: 283
Quote:
Originally Posted by rstuff View Post
I have something in my proc folder called kcore that is using 140.7 Gb.

-r-------- 1 root root 140737486262272 Feb 14 21:12 kcore
That's nothing:
Code:
empty@Debian ~ % ls -lh /proc/kcore 
-r-------- 1 root root 128T Feb 15 12:02 /proc/kcore
Mine's bigger than yours...
:P
 
Old 02-15-2015, 07:01 AM   #18
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
Code:
brian@slackdesk:~$ ls -lh /proc/kcore 
-r-------- 1 root root 128T Feb 15 13:00 /proc/kcore
It must be magic! How does it manage that on a 160 GB HDD???

Last edited by brianL; 02-15-2015 at 07:02 AM.
 
Old 02-15-2015, 07:59 AM   #19
GNU/Linux
Member
 
Registered: Sep 2012
Distribution: Slackware-14
Posts: 118

Rep: Reputation: Disabled
Your /usr and /var can't be seen in the output of df -h. You have mounted them on separate partitions, right?
Check output of
Code:
df -h
df -i
Do a filesystem check as EDDY1 suggested. If if your system partitions are mounted then you can force a check on reboot. In Terminal type the following. It will reboot your system immediately and will do a filesystem check.
Code:
sudo shutdown -rF now

Last edited by GNU/Linux; 02-15-2015 at 08:02 AM.
 
1 members found this post helpful.
Old 02-15-2015, 02:48 PM   #20
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
Results of df -h and df -i

r@r:~$ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 20G 20G 0 100% /
udev 10M 0 10M 0% /dev
tmpfs 377M 976K 376M 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 754M 308K 753M 1% /run/shm
/dev/sda2 121G 22G 93G 19% /home
tmpfs 754M 36K 754M 1% /tmp
none 4.0K 0 4.0K 0% /sys/fs/cgroup
r@r:~$ df -i
Filesystem Inodes IUsed IFree IUse% Mounted on
/dev/sda1 1281120 189886 1091234 15% /
udev 478723 397 478326 1% /dev
tmpfs 481979 456 481523 1% /run
tmpfs 481979 4 481975 1% /run/lock
tmpfs 481979 6 481973 1% /run/shm
/dev/sda2 8003584 14643 7988941 1% /home
tmpfs 481979 31 481948 1% /tmp
none 481979 2 481977 1% /sys/fs/cgroup
r@r:~$

It looks like home is on sda2. It confuses me when I go to file system on computer and I see a list of folders under computer and the first one is the home folder and then the third file down is the file system and it has the home folder in it. It seems like they should have listed the home folder under the filesystem with it being indented.
 
Old 02-15-2015, 03:14 PM   #21
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
After doing the sudo shutdown -rF now I did lose a couple dozen inodes but I am still at 100% on root. How do you check .trash in root? If I try to open the folder root in computer it tells me that I don't have permission. If I try sudo cd root from terminal it tells me invalid command.
Thank you
 
Old 02-15-2015, 03:15 PM   #22
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Try
Quote:
sudo fdisk -l
cat /etc/fstab
 
Old 02-15-2015, 04:01 PM   #23
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
No bad blocks.

r@r:~$ sudo badblocks -v /dev/sda1
Checking blocks 0 to 20479999
Checking for bad blocks (read-only test): done
Pass completed, 0 bad blocks found. (0/0/0 errors)
r@r:~$
 
Old 02-15-2015, 04:05 PM   #24
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
r@r:~$ sudo fdisk -l

Disk /dev/sda: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000c84b5

Device Boot Start End Blocks Id System
/dev/sda1 2048 40962047 20480000 83 Linux
/dev/sda2 40962048 296962047 128000000 83 Linux
/dev/sda3 600565760 625141759 12288000 83 Linux
r@r:~$

r@r:~$ cat /etc/fstab
# UNCONFIGURED FSTAB FOR BASE SYSTEM
proc /proc proc defaults 0 0
# /dev/sda1
UUID=88cd6423-3301-4e66-ab8f-434fd625341b / ext4 rw,errors=remount-ro 0 1
# /dev/sda2
UUID=e564b561-c72e-4985-bb60-70bb6994a6e2 /home ext4 rw,errors=remount-ro 0 0
# /dev/sda3
UUID=6d3cbf5b-7189-4c85-a0ba-2bac666515b1 ext4 rw,errors=remount-ro 0 0
r@r:~$
 
Old 02-16-2015, 12:31 AM   #25
GNU/Linux
Member
 
Registered: Sep 2012
Distribution: Slackware-14
Posts: 118

Rep: Reputation: Disabled
First thing first, when you post a reply Click on 'Go Advanced', then in the editor you'll see a #. Use that when you want to paste output of a command or a file etc.

The third entry in your /etc/fstab doesn't have a mount point. Do the following:
Code:
cat /etc/mtab
sudo lsblk -f
sudo blkid
Have you had any changes done to your system?

Last edited by GNU/Linux; 02-16-2015 at 12:41 AM.
 
Old 02-16-2015, 01:20 AM   #26
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
mtab, lsblk, and blkid results

r@r:~$ cat /etc/mtab
rootfs / rootfs rw 0 0
sysfs /sys sysfs rw,nosuid,nodev,noexec,relatime 0 0
proc /proc proc rw,nosuid,nodev,noexec,relatime 0 0
udev /dev devtmpfs rw,relatime,size=10240k,nr_inodes=478723,mode=755 0 0
devpts /dev/pts devpts rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000 0 0
tmpfs /run tmpfs rw,nosuid,noexec,relatime,size=385584k,mode=755 0 0
/dev/disk/by-uuid/88cd6423-3301-4e66-ab8f-434fd625341b / ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
tmpfs /run/lock tmpfs rw,nosuid,nodev,noexec,relatime,size=5120k 0 0
tmpfs /run/shm tmpfs rw,nosuid,nodev,noexec,relatime,size=771160k 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
/dev/sda2 /home ext4 rw,relatime,errors=remount-ro,data=ordered 0 0
tmpfs /tmp tmpfs rw,nosuid,nodev,relatime,size=771160k 0 0
binfmt_misc /proc/sys/fs/binfmt_misc binfmt_misc rw,nosuid,nodev,noexec,relatime 0 0
none /sys/fs/cgroup tmpfs rw,relatime,size=4k,mode=755 0 0
systemd /sys/fs/cgroup/systemd cgroup rw,nosuid,nodev,noexec,relatime,name=systemd 0 0

r@r:~$ sudo lsblk -f
[sudo] password for r:
NAME FSTYPE LABEL MOUNTPOINT
sda
├─sda1 ext4 /
├─sda2 ext4 /home
└─sda3 ext4 Swap
sr0

r@r:~$ sudo blkid
/dev/sda3: LABEL="Swap" UUID="6d3cbf5b-7189-4c85-a0ba-2bac666515b1" TYPE="ext4"
/dev/sda1: UUID="88cd6423-3301-4e66-ab8f-434fd625341b" TYPE="ext4"
/dev/sda2: UUID="e564b561-c72e-4985-bb60-70bb6994a6e2" TYPE="ext4"
r@r:~$

I did finally get the upgrade to work since opening this thread. I think doing the clean's that Eddy1 suggested may have enabled the upgrade to complete. Sorry I didn't mention it earlier. The last install I tried I think was for Zoneminder. It was a long time ago and I don't remember what the process was but I don't think it was in my repository at the time. I never did get Zoneminder to work. I have tried installing other software in the past which required other repositories. When I did the upgrade I had several repositories which were not found. I have to find out how to remove them. I suspect I have been missing the mount point since I setup the partitions. I still have an empty partition. Maybe I should be looking at a reinstall. I don't have a lot of data or customization to deal with.
Thank you for your help.
 
Old 02-16-2015, 02:29 AM   #27
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
r@r:~$ sudo swapon -s
[sudo] password for r:
Filename Type Size Used Priority
r@r:~$

I guess this means I don't have a swap file. I tried to reserve a swap partition at the end of the drive. I thought I had a partition between /home partition and the /swap partition to test a different distro.
 
Old 02-16-2015, 10:51 PM   #28
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
I missed a previous question. I did not mount /usr and /var on separate partitions. Was I suppose to?

I installed gparted and I didn't run out of space. I used gparted to delete and reallocate the swap file. Then I used swapon to make it a swap file.

r@r:~$ sudo blkid
/dev/sda3: LABEL="Swap" UUID="eef40dc8-1768-450c-bb02-a20a20072a14" TYPE="swap"
/dev/sda1: UUID="88cd6423-3301-4e66-ab8f-434fd625341b" TYPE="ext4"
/dev/sda2: UUID="e564b561-c72e-4985-bb60-70bb6994a6e2" TYPE="ext4"
r@r:~$

I can't find the /etc/fstab file to add the swap file. I have a /etc/fstab.d file that is empty. What do I do to make it permanent?
Thank you
 
Old 02-16-2015, 11:17 PM   #29
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Quote:
I installed gparted and I didn't run out of space. I used gparted to delete and reallocate the swap file. Then I used swapon to make it a swap file.
That explains why sda3 is reporting ext4. whenyou removed the partition & reformatted the UUID changed.
swap is just listed as swap,not as ext4 partition. You'll have to reformat sda3 as a swap partion, or remove it from /etc/fstab

Last edited by EDDY1; 02-16-2015 at 11:19 PM.
 
Old 02-16-2015, 11:58 PM   #30
rstuff
Member
 
Registered: Jul 2011
Posts: 117

Original Poster
Rep: Reputation: Disabled
Sda3 is showing as type=swap now.

r@r:~$ sudo blkid
/dev/sda3: LABEL="Swap" UUID="eef40dc8-1768-450c-bb02-a20a20072a14" TYPE="swap"
/dev/sda1: UUID="88cd6423-3301-4e66-ab8f-434fd625341b" TYPE="ext4"
/dev/sda2: UUID="e564b561-c72e-4985-bb60-70bb6994a6e2" TYPE="ext4"
r@r:~$

I can not find my fstab file. I have an empty fstab.d file.
Thank you
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No space left on Device Fra123X Linux From Scratch 8 09-30-2013 04:36 AM
LXer: Linux: No space left on device while df command shows lot of free space LXer Syndicated Linux News 0 08-26-2013 02:50 PM
[SOLVED] No space left on device TheIndependentAquarius Linux - Newbie 32 01-10-2011 11:14 AM
No space left on device even though it has free space? enine Linux - General 8 05-30-2007 04:22 PM
No space left on device clintdavis Linux - Software 2 05-04-2006 10:38 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 02:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration