LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-18-2008, 03:29 PM   #1
bignreel
LQ Newbie
 
Registered: Feb 2008
Posts: 5

Rep: Reputation: 0
Question No sound with new ubuntu 7.10 using SB Live EMU10k1 (rev07)


I just downloaded the latest Ubuntu 7.10 and now I have no sound. I don't know much about Ubuntu so please be as detailed as possible...(Thanks!)
I have the Creative Labs SB Live! EMU10k1 sound card and have never had any problems out of it.
This is only my second Ubuntu upgrade.
I use to run Windows on this computer before Ubuntu .
I already checked with others who posted similar threads and none of them look like they are having the same exact problem as I am.
I am getting no sound whatsoever.
Can anyone help with this?

Here is what I get when I look for my sound card. I think I am reading it correctly...
00:0b.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 07)
00:0b.1 Input device controller: Creative Labs SB Live! Game Port (rev 07)
00:0f.0 IDE interface: VIA Technologies, Inc. VIA VT6420 SATA RAID Controller (rev 80)
00:0f.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 81)
00:10.4 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 86)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8237 ISA bridge [KT600/K8T800/K8T890 South]
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 60)
00:13.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)

Thanks again!
 
Old 03-18-2008, 03:52 PM   #2
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
As root type alsaconf and press enter,then follow instructions,post what happens.
 
Old 03-19-2008, 01:40 PM   #3
bignreel
LQ Newbie
 
Registered: Feb 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks for your help. I have one more question,though...How do I get to "root" to type alsaconf? Remember that I don't know much about this kind of stuff. (I am totally in the dark). Thanks again for your help.
 
Old 03-19-2008, 02:34 PM   #4
dark1984
LQ Newbie
 
Registered: Feb 2008
Location: Quebec, Canada
Distribution: openSuSE / Fedora / Mandrake / Ubuntu / VectorLinux
Posts: 5

Rep: Reputation: 0
Go into a shell (konsole) and type --- su --- it will ask for root password. then u will be root.

or just --- sudo and_the_command_u_want ---
 
Old 03-20-2008, 12:34 PM   #5
bignreel
LQ Newbie
 
Registered: Feb 2008
Posts: 5

Original Poster
Rep: Reputation: 0
I couldn't get any of those ideas to work so I just reloaded Ubuntu from disc this time and my sound is working but now I can not adjust my screen.The screen looks as though I need to adjust my monitor settings but for some reason the buttons on my monitor are not responding. Is there a setting that I can change to make Ubuntu recognize my Compaq FS740 monitor? Or do I need to do something else? Thanks again.
 
Old 03-20-2008, 04:00 PM   #6
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
What is the problem?If you just want to change your screen resolution,you should go in System-Preferences-screen resolution and change it.And for buttons,if monitor works then should buttons too,but if they don't,then I think it's a monitor problem not Ubuntu's.Did monitor worked before you reinstalled Ubuntu or did you just restarted your pc?
Try this command in terminal xorg -configure and if it works enter details it ask you.
To become root(admin),open terminal,type su then press enter.Then enter root's password(you want see what you type)and also press enter.You may also try this command X -configure.

Last edited by alan_ri; 03-20-2008 at 04:02 PM.
 
Old 03-21-2008, 09:38 AM   #7
bignreel
LQ Newbie
 
Registered: Feb 2008
Posts: 5

Original Poster
Rep: Reputation: 0
I was using the Fiesty Fawn version of Ubuntu and my monitor worked fine then. but when I upgraded to Ubuntu 7.10 I started having these problems.
As for the monitor, it looks as though it is being squeezed (similar to an hour glass) in the middle of the window. In the past if I had this problem I just adjusted my monitor using the buttons on the monitor.
The sound quit working again. I restarted with the disk and I have sound, but when I restart without the disk I have no sound.
When I use konsole and type su, I get to the part when it asks for my password and it tells me "Authentication failure" when I type in my password.This is my own personal computer. I have a friend who uses Ubuntu (he is fairly new to Ubuntu also) who told me that my password should be the same as when I set up the os.
I copied and pasted this from my konsole.
What am I doing wrong?

Password:
su: Authentication failure
Sorry.
bignreel@bignreel-desktop:~$ sudo
usage: sudo -K | -L | -V | -h | -k | -l | -v
usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
{ -e file [...] | -i | -s | <command> }
bignreel@bignreel-desktop:~$ xorg -configure
bash: xorg: command not found
bignreel@bignreel-desktop:~$ x -configure
bash: x: command not found
bignreel@bignreel-desktop:~$ sudo x -configure -alsaconf
[sudo] password for bignreel:
sudo: x: command not found
bignreel@bignreel-desktop:~$ sudo x -configure
sudo: x: command not found
bignreel@bignreel-desktop:~$ sudo xorg -configure
sudo: xorg: command not found
bignreel@bignreel-desktop:~$ sudo -configure
sudo: please use single character options
sudo: illegal option `-configure'
usage: sudo -K | -L | -V | -h | -k | -l | -v
usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
{ -e file [...] | -i | -s | <command> }


Sorry to seem ignorant on the subject, but I really am...
 
Old 03-21-2008, 01:27 PM   #8
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
When you type su you must enter root password,not yours.It's a administrator password,which Ubuntu also asked you to enter during installation.Also you have entered x -configure but it should be X -configure.Try to reinstall Ubuntu and then remember root password.Also type one command at the time.
 
Old 03-22-2008, 10:30 AM   #9
bignreel
LQ Newbie
 
Registered: Feb 2008
Posts: 5

Original Poster
Rep: Reputation: 0
I re-installed Ubuntu and the only place during installation that it asked me for a password was when I set up my name, computer name, and my password. I didn't see any other mention of another password as you described...
I am still having (even with re-install) the no sound problem and the monitor "squeeze" problem.
I think it is not recognizing my monitor. I don't know where I saw it now, but while I was probing around in some of the installed system tools I found a place where it assigned a generic monitor in the settings. Can you tell me where I saw this? I tried to change the assigned monitor to another and when I restarted, it didn't like what I did. I re-loaded Ubuntu again and I am back to where I was before I attempted to change monitors...
 
Old 03-22-2008, 11:18 AM   #10
alan_ri
Senior Member
 
Registered: Dec 2007
Location: Croatia
Distribution: Debian GNU/Linux
Posts: 1,733
Blog Entries: 5

Rep: Reputation: 127Reputation: 127
I have used Ubuntu 7.10 not so long ago,but even if I didn't,I know that every Linux distro has a root user,so does yours.The installer,at some point,ask you,me and everybody to enter the root(administrator) password during installation and that is really important because if you are not root you can't fix,change or do almost anything on your system.
Oh,I just remembered something,the Ubuntu installer 7.10 is unique,as much as I know,so it doesn't ask you to enter the root password(if I remember correctly),so when you login,go to Users and groups and then find root user and give him new password,then try commands I already posted here.
 
Old 03-22-2008, 12:30 PM   #11
mrrangerman
Member
 
Registered: Oct 2007
Location: MI
Distribution: Debian Slackware
Posts: 528

Rep: Reputation: 50
Quote:
alan_ri

I have used Ubuntu 7.10 not so long ago,but even if I didn't,I know that every Linux distro has a root user,so does yours.
Just to let you know NO Ubuntu does not!! When Ubuntu is installed it sets up the user with sudo rights. If you want a root account you have to create/install it yourself.

bignreel

To run alsaconf to setup your sound, open a terminal window, type the command sudo alsaconf it will prompt you for your passwd give the passwd you use to log in.

After alsaconf runs you will want to run alsamixer just type the name, you don't need sudo with that command. Make sure the volume is turned up. To navigate use your arrow keys left or right, to unmute use the m key, to exit press the Esc key. To exit the terminal window just type exit.

Now for your monitor you will need to edit your xorg.conf file located in /etc/X11/ directory.

1. Find out the specs on your monitor the Vert, & Horz. write it down for reference.

2. Press Ctrl+Alt+F1 this will put you into tty1 log in, then give the command sudo killall gdm (you will be prompted for your passwd) this will kill your xserver.

3. Now type sudo dpkg-reconfigure xserver-xorg and follow the directions, when you get to the monitor part use the advance option, that way you can enter the proper settings for your monitor. After you are done you can type startx or just reboot which would be sudo init 6

Hope this helps

EDIT:
Quote:
alan_ri
Oh,I just remembered something,the Ubuntu installer 7.10 is unique,as much as I know,so it doesn't ask you to enter the root password(if I remember correctly),so when you login,go to Users and groups and then find root user and give him new password
Sorry maybe I should read a little further.

Last edited by mrrangerman; 03-22-2008 at 12:39 PM. Reason: add info
 
  


Reply

Tags
hardware, linux


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me report a bug in the Sound Blaster live emu10k1 driver PatrickMay16 General 8 01-10-2008 04:43 AM
Sound Blaster Live 5.1 (emu10k1) on Slackware 10 coolj478 Slackware 15 01-19-2005 01:12 PM
ALSA Sound Blaster Live! (emu10k1) surround 5.1 Kronoss Linux - Hardware 4 01-17-2005 12:04 PM
XMMS SoundBlaster Live! 5.1 emu10k1 no sound ThePenguin Linux - Newbie 9 09-22-2004 09:01 PM
Why does my sb live (emu10k1) sound better with oss than alsa? haimeltjnfg Linux - Hardware 2 08-29-2004 03:19 AM


All times are GMT -5. The time now is 12:58 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration