LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-20-2006, 08:34 PM   #1
devavictrix
Member
 
Registered: Jan 2006
Posts: 70

Rep: Reputation: Disabled
no sound when regular user


My sound used to work fine but I tried playing an mp3 the other day and it doesn't work.
I tried playing it when logged in as root and it works fine, its only when as user it wont play.

I dont know where to start in sorting it as it was fine in the past.

Has anyone any ideas?
 
Old 07-21-2006, 03:25 AM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
First of all, if the "distribution" you're having this problem with
happens to be WINDOWS! as your user profile suggests, you're on the
wrong forum. Btw, Windows is NOT a Linux distribution, by any stretch,
in fact I find it daring to call it an operating system. But I think
I told you that before.


Should you, however, be using Slackware that's a FAQ-thing ... by default
Slackware is very conservative, and very secure; things like sound, mounting
of CDs and the likes ARE potentially disruptive. If you want to change
the default you need to add yourself to the group audio; on the next login
you should be able to have noise.


Cheers,
Tink
 
Old 07-21-2006, 09:31 AM   #3
devavictrix
Member
 
Registered: Jan 2006
Posts: 70

Original Poster
Rep: Reputation: Disabled
I haven't got an audio group I dont think. Besides I never used to be in it even if it did exist.
 
Old 07-21-2006, 10:09 AM   #4
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,248
Blog Entries: 8

Rep: Reputation: 235Reputation: 235Reputation: 235
hello there, the most probable cause of your problem should be somehow connected to the access permissions of your /dev/dsp.

try modifying the permissions here. by group or anything. just note that if you're using udev, any permission changes made to /dev/dsp will be lost the moment you restart your computer.

so you should be more on doing config with udev.

now it's just an idea. i'm not sure if it will work. and i'm not even sure if you're using dsp.

hope this helps you at least
 
Old 07-21-2006, 11:32 AM   #5
RoughEdge
Member
 
Registered: Jan 2004
Location: Scotland
Distribution: Slackware 12
Posts: 67

Rep: Reputation: 15
I use slackware, not sure if it's the same, but to get my sound working as an ordinary user I used the following :

Code:
su
chmod 666 /dev/dsp*
chmod 666 /dev/mixer*
 
Old 07-21-2006, 04:21 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by RoughEdge
I use slackware, not sure if it's the same, but to get my sound working as an ordinary user I used the following :

Code:
su
chmod 666 /dev/dsp*
chmod 666 /dev/mixer*
That is bad practice.

It makes more sense to do add yourself to group audio,
and have audio be group-owner and g+rw.


Cheers,
Tink
 
Old 07-21-2006, 04:25 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Quote:
Originally Posted by rikpotts
I haven't got an audio group I dont think. Besides I never used to be in it even if it did exist.
I find it hard to believe that the group audio doesn't exist.
And I didn't suggest that you were part of it but told you
to make yourself part of it. Are you sure that you want to
get help, or are you just trolling?

And we still don't know which distribution you're using,
and windows still isn't a distribution.



Cheers,
Tink
 
Old 07-21-2006, 06:32 PM   #8
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
as Tinkster said adding yourself to those groups are considered an security risk. If adding your self to the audio did not work then try this.
Code:
chmod 655 /dev/cdrom
This should then give everyone rights to read and excute the cdrom for audio. Again this can be a security risk.
 
Old 07-21-2006, 06:34 PM   #9
jstephens84
Senior Member
 
Registered: Sep 2004
Location: Nashville
Distribution: Manjaro, RHEL, CentOS
Posts: 2,098

Rep: Reputation: 102Reputation: 102
Quote:
Originally Posted by Tinkster
That is bad practice.

It makes more sense to do add yourself to group audio,
and have audio be group-owner and g+rw.


Cheers,
Tink
I agree. Giving users write ability to something of that nature is not a good practice. That can allow the user more rights than he needs.
 
Old 07-22-2006, 08:39 AM   #10
devavictrix
Member
 
Registered: Jan 2006
Posts: 70

Original Poster
Rep: Reputation: Disabled
Audio group was there. I had a list of groups apparently on my system which was a load of crap. /etc/groups was very different. /dev/dsp was in the audio group so like you guys suggested I added my user to that group.

This got rid of the pop-up box which said my soundcard wasnt there when I tried to play something.

But my sound still didnt work so I reinstalled alsa-oss, added /usr/lib to ld.so.config and ran /sbin/ldconfig as root.

It worked!

Many Thanks for your help, how it all went belly up in the first place is a mystery... at least its working now.
 
Old 07-22-2006, 04:21 PM   #11
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Excellent ... and you changed the distro, too. Good on yah ;}


Cheers,
Tink
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Wine as regular user scouture Linux - Software 2 03-11-2005 10:49 PM
Moving from root to regular user KingOfDreams Linux - General 1 01-14-2005 05:46 AM
Can't Login As Regular User After Trying... drdroid Linux - General 8 02-08-2004 12:30 PM
Can't log in as regular user Fugazi Linux - Newbie 1 12-27-2003 05:07 PM
How do I login as a regular user? hitbob Linux - Newbie 2 10-04-2003 06:14 AM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration