LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-10-2008, 12:26 PM   #1
Il duce
LQ Newbie
 
Registered: Mar 2008
Location: /home/programsense
Distribution: Plenty no discrimination :-)
Posts: 5

Rep: Reputation: 0
No sound Ubuntu 8.04-DELL Precision 650


Hello,

I installed Ubuntu 8.04 on my Dell precision 650, everything works fine except the sound. I tried updating the system with sudo apt-get update
sudo apt-get upgrade as read on a search on google. I ran asoundconf list and i got a Audigy2 available. I've looked far and wide but found no results please help.
 
Old 07-10-2008, 03:51 PM   #2
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
Welcome to LQ!

Try going to Sytem>Preferences>Sound

This opens a dialog box and at the bottom is a window labled Device. Make sure your output sound card is the one listed. Try this first, as this is sometime incorrect, particularly if you have speaker for your internal modem.

Bob
 
Old 07-10-2008, 04:03 PM   #3
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
Alternative To Check

On Ubuntu/Kubuntu 7.10, I had to alter this file

/etc/modprobe.d/alsa-base

and add

options snd-hda-intel model=thinkpad-t61p

at the bottom. You need to find out what Ubuntu thinks your model is. I guessed at thinkpad-t61p and was lucky.
 
Old 07-10-2008, 04:50 PM   #4
Il duce
LQ Newbie
 
Registered: Mar 2008
Location: /home/programsense
Distribution: Plenty no discrimination :-)
Posts: 5

Original Poster
Rep: Reputation: 0
No luck

Hi guys thanks for your replies but no luck, i ran lspci -v to check for devices but im not really finding a sound card am i right?

fen@8:~$ lspci -v
00:00.0 Host bridge: Intel Corporation E7505 Memory Controller Hub (rev 03)
Subsystem: Dell Unknown device 012c
Flags: bus master, fast devsel, latency 0
Memory at e8000000 (32-bit, prefetchable) [size=128M]
Capabilities: <access denied>

00:01.0 PCI bridge: Intel Corporation E7505/E7205 PCI-to-AGP Bridge (rev 03) (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, fast devsel, latency 64
Memory at e0000000 (32-bit, prefetchable) [size=128M]
Bus: primary=00, secondary=01, subordinate=01, sec-latency=64
Memory behind bridge: fc000000-fdffffff
Prefetchable memory behind bridge: f0000000-f7ffffff
Capabilities: <access denied>

00:02.0 PCI bridge: Intel Corporation E7505 Hub Interface B PCI-to-PCI Bridge (rev 03) (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, fast devsel, latency 64
Bus: primary=00, secondary=02, subordinate=04, sec-latency=0
I/O behind bridge: 0000d000-0000efff
Memory behind bridge: fe300000-fe8fffff

00:1d.0 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #1 (rev 01) (prog-if 00 [UHCI])
Subsystem: Dell Unknown device 012c
Flags: bus master, medium devsel, latency 0, IRQ 16
I/O ports at ff80 [size=32]

00:1d.1 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #2 (rev 01) (prog-if 00 [UHCI])
Subsystem: Dell Unknown device 012c
Flags: bus master, medium devsel, latency 0, IRQ 17
I/O ports at ff60 [size=32]

00:1d.2 USB Controller: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) USB UHCI Controller #3 (rev 01) (prog-if 00 [UHCI])
Subsystem: Dell Unknown device 012c
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at ff40 [size=32]

00:1d.7 USB Controller: Intel Corporation 82801DB/DBM (ICH4/ICH4-M) USB2 EHCI Controller (rev 01) (prog-if 20 [EHCI])
Subsystem: Dell Unknown device 012c
Flags: bus master, medium devsel, latency 0, IRQ 19
Memory at fe900000 (32-bit, non-prefetchable) [size=1K]
Capabilities: <access denied>

00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 81) (prog-if 00 [Normal decode])
Flags: bus master, fast devsel, latency 0
Bus: primary=00, secondary=05, subordinate=05, sec-latency=32
I/O behind bridge: 0000c000-0000cfff
Memory behind bridge: fe100000-fe2fffff

00:1f.0 ISA bridge: Intel Corporation 82801DB/DBL (ICH4/ICH4-L) LPC Interface Bridge (rev 01)
Flags: bus master, medium devsel, latency 0

00:1f.1 IDE interface: Intel Corporation 82801DB (ICH4) IDE Controller (rev 01) (prog-if 8a [Master SecP PriP])
Subsystem: Dell Unknown device 012c
Flags: bus master, medium devsel, latency 0, IRQ 18
I/O ports at 01f0 [size=8]
I/O ports at 03f4 [size=1]
I/O ports at 0170 [size=8]
I/O ports at 0374 [size=1]
I/O ports at ffa0 [size=16]
Memory at 88000000 (32-bit, non-prefetchable) [size=1K]

00:1f.3 SMBus: Intel Corporation 82801DB/DBL/DBM (ICH4/ICH4-L/ICH4-M) SMBus Controller (rev 01)
Subsystem: Dell Unknown device 012c
Flags: medium devsel, IRQ 14
I/O ports at bc80 [size=32]

01:00.0 VGA compatible controller: nVidia Corporation NV30GL [Quadro FX 1000] (rev a2) (prog-if 00 [VGA controller])
Subsystem: nVidia Corporation Unknown device 0182
Flags: bus master, 66MHz, medium devsel, latency 248, IRQ 16
Memory at fc000000 (32-bit, non-prefetchable) [size=16M]
Memory at f0000000 (32-bit, prefetchable) [size=128M]
[virtual] Expansion ROM at fd000000 [disabled] [size=128K]
Capabilities: <access denied>

02:1c.0 PIC: Intel Corporation 82870P2 P64H2 I/OxAPIC (rev 04) (prog-if 20 [IO(X)-APIC])
Subsystem: Dell Unknown device 012c
Flags: bus master, 66MHz, fast devsel, latency 0
Memory at fe3ff000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>

02:1d.0 PCI bridge: Intel Corporation 82870P2 P64H2 Hub PCI Bridge (rev 04) (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, fast devsel, latency 64
Bus: primary=02, secondary=03, subordinate=03, sec-latency=64
I/O behind bridge: 0000e000-0000efff
Memory behind bridge: fe700000-fe8fffff
Capabilities: <access denied>

02:1e.0 PIC: Intel Corporation 82870P2 P64H2 I/OxAPIC (rev 04) (prog-if 20 [IO(X)-APIC])
Subsystem: Dell Unknown device 012c
Flags: bus master, 66MHz, fast devsel, latency 0
Memory at fe3fe000 (32-bit, non-prefetchable) [size=4K]
Capabilities: <access denied>

02:1f.0 PCI bridge: Intel Corporation 82870P2 P64H2 Hub PCI Bridge (rev 04) (prog-if 00 [Normal decode])
Flags: bus master, 66MHz, fast devsel, latency 64
Bus: primary=02, secondary=04, subordinate=04, sec-latency=64
I/O behind bridge: 0000d000-0000dfff
Memory behind bridge: fe500000-fe6fffff
Capabilities: <access denied>

03:0e.0 Ethernet controller: Intel Corporation 82545EM Gigabit Ethernet Controller (Copper) (rev 01)
Subsystem: Dell Unknown device 012c
Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 20
Memory at fe7e0000 (64-bit, non-prefetchable) [size=128K]
I/O ports at ecc0 [size=64]
Capabilities: <access denied>

04:0e.0 SCSI storage controller: LSI Logic / Symbios Logic 53c1030 PCI-X Fusion-MPT Dual Ultra320 SCSI (rev 07)
Subsystem: Dell Unknown device 012c
Flags: bus master, 66MHz, medium devsel, latency 72, IRQ 21
I/O ports at dc00 [size=256]
Memory at fe5f0000 (64-bit, non-prefetchable) [size=64K]
Memory at fe5e0000 (64-bit, non-prefetchable) [size=64K]
Expansion ROM at fe600000 [disabled] [size=1M]
Capabilities: <access denied>

05:0c.0 FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller (PHY/Link) (prog-if 10 [OHCI])
Subsystem: Dell Unknown device 012c
Flags: bus master, medium devsel, latency 64, IRQ 22
Memory at fe1ff800 (32-bit, non-prefetchable) [size=2K]
Memory at fe1f8000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>

05:0e.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
Subsystem: Creative Labs Unknown device 1003
Flags: bus master, medium devsel, latency 64, IRQ 23
I/O ports at ccc0 [size=64]
Capabilities: <access denied>

05:0e.2 FireWire (IEEE 1394): Creative Labs SB Audigy FireWire Port (rev 04) (prog-if 10 [OHCI])
Subsystem: Creative Labs SB Audigy FireWire Port
Flags: bus master, medium devsel, latency 64, IRQ 19
Memory at fe1ff000 (32-bit, non-prefetchable) [size=2K]
Memory at fe1f4000 (32-bit, non-prefetchable) [size=16K]
Capabilities: <access denied>
 
Old 07-10-2008, 06:24 PM   #5
BobNutfield
Senior Member
 
Registered: Dec 2005
Location: United Kingdom
Distribution: Fedora , Ubuntu, Slackware-Current
Posts: 1,477

Rep: Reputation: 51
This is what many believe is the definitive post for sound in Ubuntu. I believe you can message the poster from the link.

Your sound card is listed in your output:

Quote:
05:0e.0 Multimedia audio controller: Creative Labs SB Audigy (rev 04)
Subsystem: Creative Labs Unknown device 1003
Flags: bus master, medium devsel, latency 64, IRQ 23
I/O ports at ccc0 [size=64]
Capabilities: <access denied
So, the system is recognized the card, I am sure it is a config issue.
Also, open a terminal and type:

Quote:
group
Check the output and make sure your user name is a member of the audio group. If the command does not work, just look in etc/group file. It may be the pulse group that is shown, but make sure your user name is shown

Bob

Last edited by BobNutfield; 07-10-2008 at 06:32 PM.
 
Old 07-11-2008, 10:03 AM   #6
Il duce
LQ Newbie
 
Registered: Mar 2008
Location: /home/programsense
Distribution: Plenty no discrimination :-)
Posts: 5

Original Poster
Rep: Reputation: 0
Ok im on the directory pulse i've got 3 files in it:
client.conf
daemon.conf
default.pa
But these files apparently do not have specific users here is the text on client.conf

# $Id: client.conf.in 2030 2007-11-08 22:31:30Z lennart $
#
# This file is part of PulseAudio.
#
# PulseAudio is free software; you can redistribute it and/or modify
# it under the terms of the GNU Lesser General Public License as published by
# the Free Software Foundation; either version 2 of the License, or
# (at your option) any later version.
#
# PulseAudio is distributed in the hope that it will be useful, but
# WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
# General Public License for more details.
#
# You should have received a copy of the GNU Lesser General Public License
# along with PulseAudio; if not, write to the Free Software
# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
# USA.

## Configuration file for PulseAudio clients. See pulse-client.conf(5) for
## more information. Default values a commented out. Use either ; or # for
## commenting.

; default-sink =
; default-source =
; default-server =

; autospawn = no
; daemon-binary = /usr/bin/pulseaudio
; extra-arguments = --log-target=syslog --exit-idle-time=5

; cookie-file =

; disable-shm = no
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to get flash sound working on a Dell Precision Server (64 bit) conde Linux - Software 1 03-19-2008 11:36 AM
Problem with my sound cards plug configuration on Dell Precision M4300 moresun Linux - Hardware 0 08-06-2007 03:53 PM
Dell Precision 670? etcetera Linux - Hardware 11 03-20-2006 10:34 PM
Dell Precision Workstation 650 - Dual Xeon Processors jdep Linux - Newbie 2 04-08-2004 03:08 AM
My Dell Precision w/RH 8.0 turns itself off borbjo Linux - Hardware 1 01-25-2003 07:16 AM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration