LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-15-2009, 12:36 PM   #1
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Rep: Reputation: 15
no sound slackware 12.2


I've been searching these threads and tutorials on how to fix the sound for my linux but no luck. I wasted enough time. Can anyone tell me how I can get my sound to work? Do I have to install the driver for it? because I've noticed that most of you only had to type in some commands to get it.

I'm dual booting with Vista, so do I need to install drivers still?

Last edited by trnz$mr; 02-15-2009 at 12:47 PM. Reason: not enough details
 
Old 02-15-2009, 01:01 PM   #2
Pode
LQ Newbie
 
Registered: Oct 2008
Posts: 24

Rep: Reputation: 1
Try to add yourself to the audio group
Code:
su   (to become root)
(type in root password)
nano /etc/group
or you can use other text editor like kwrite then add yourself to audio line and there should be something like this
audio:x:17:root,yourusername
then logout and login then

if it is not working try to run alsaconf it will detect your card

Last edited by Pode; 02-15-2009 at 01:13 PM. Reason: not enough details
 
Old 02-15-2009, 01:30 PM   #3
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Still doesn't work.
I ran alsaconf and everything looked good except still no sound uummm...??
 
Old 02-15-2009, 02:16 PM   #4
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Run 'alsamixer' and make sure the channels are unmuted (press m)
 
Old 02-15-2009, 03:57 PM   #5
onebuck
Moderator
 
Registered: Jan 2005
Location: Midwest USA, Central Illinois
Distribution: SlackwareŽ
Posts: 12,712
Blog Entries: 27

Rep: Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055Reputation: 2055
Hi,
Quote:
Originally Posted by trnz$mr View Post
Still doesn't work.
I ran alsaconf and everything looked good except still no sound uummm...??
You should make certain to run 'alsamixer' to un-mute the desired function. Then you should do a 'alsactl store' to save the settings.

You should be sure to have your users in the following groups;

Code:
users floppy audio video cdrom plugdev
Whenever you add users be sure to assign the above groups.
 
Old 02-15-2009, 04:31 PM   #6
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
I've done a number of things to test my sound, even restarting the machine didn't help. This is the message prompt I got after using alsaconfISA
I have two choices:

"hda-intel Intel Corporation 82801G (ICH7 Family) High Definition Audio"
&
"legacy Probe legacy ISA (non-Pnp) chips"

I choose the first one and then it say's:

"configuring snd-hda-intel
Do you want to modify /etc/modprobe.d/sound
(and /etc/modprobe.conf if present)?"


I hit "yes" and then it says

"OK sound drive is configured
ALSA CONFIGUATOR
will prepare the card for playing now.
Now I'll run alsasound init script, then I'll use
a mixer to raise the default volumes.
You can change the volume later via a mixer
program such as alsamixer or gamix."


Then I hit "OK" and the shell-Konsole comes bake with this

"Now ALSA is ready to use.
For adjustment of volumes, use your favorite mixer."


But of course non of this works on my computer.

Are there any more susgestions?
 
Old 02-15-2009, 04:38 PM   #7
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Quote:
users floppy audio video cdrom plugdev
it says I have an extra operand 'audio'

Last edited by trnz$mr; 02-15-2009 at 04:40 PM. Reason: clarification
 
Old 02-15-2009, 04:39 PM   #8
mrclisdue
Senior Member
 
Registered: Dec 2005
Distribution: Slackware -current, 14.2
Posts: 1,081

Rep: Reputation: 190Reputation: 190
Did you run alsamixer as onebuck suggested?
For some reason, sometimes the sound is muted (for reference, I just did fresh installs of 12.2 on 3 boxes, and on one of them the sound was muted) - you have to choose each slider in alsamixer, and press 'm' to unmute it.

Then, as root, do alsactl store to keep the settings.

cheers,
 
Old 02-15-2009, 04:56 PM   #9
trnz$mr
Member
 
Registered: Oct 2008
Posts: 121

Original Poster
Rep: Reputation: 15
Yep I tried it and my internal and external microphones seem to be working fine because a high pitched buzz started to get pretty annoying, so I just turned the microphones down. I've been trying to test the sound by running an audio cd and also by hitting a test button in the sound systems settings directory.
At least I'm half way to getting my sound because the microphones work
 
Old 04-03-2009, 03:22 AM   #10
H_TeXMeX_H
LQ Guru
 
Registered: Oct 2005
Location: $RANDOM
Distribution: slackware64
Posts: 12,928
Blog Entries: 2

Rep: Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287Reputation: 1287
Does this happen to be an asus laptop ? Either way have a look here for possible solution:
http://www.linuxquestions.org/questi...2/#post3496597
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound problems in Slackware 11 with Sweex sound card RicardoB Linux - Hardware 0 04-30-2007 01:34 PM
Sound Skips After Slackware 11.0 upgrade AC97 sound card using the snd-via82xx driver meetscott Linux - Hardware 3 11-07-2006 11:55 PM
Replaced a Sound Card (ESS) and now no sound under Slackware LeniuNYC Linux - Hardware 1 03-14-2004 05:21 PM
AC97 int. sound slackware 9.0 no sound TheDanLayerOSI Linux - Hardware 1 06-13-2003 04:42 AM


All times are GMT -5. The time now is 12:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration