LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-30-2007, 10:26 AM   #1
chevalier
LQ Newbie
 
Registered: May 2007
Posts: 9

Rep: Reputation: 0
No sound on ASUS M2N-E motherboard under Ubuntu


I have installed Ubuntu (Feisty Fawn) on the above motherboard. It works fine. However I cannot get sound to work. I tested it with an Audio CD and got the following message

audiotestsrc wave=sine freq=512 !
audioconvert ! audioresample !
gconfaudiosink: Could not open resource for writing

Any thoughts please ?

chevalier
 
Old 10-31-2007, 05:38 AM   #2
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Rep: Reputation: 30
Open a console window and enter commands:

# lspci
<output1>
# lsmod | grep snd
<output2>

post output 1 and 2 here please.
 
Old 10-31-2007, 06:07 PM   #3
chevalier
LQ Newbie
 
Registered: May 2007
Posts: 9

Original Poster
Rep: Reputation: 0
ron@ron-desktop:~$ lspci
00:00.0 Memory controller: nVidia Corporation CK804 Memory Controller (rev a3)
00:01.0 ISA bridge: nVidia Corporation CK804 ISA Bridge (rev f3)
00:01.1 SMBus: nVidia Corporation CK804 SMBus (rev a2)
00:02.0 USB Controller: nVidia Corporation CK804 USB Controller (rev a2)
00:02.1 USB Controller: nVidia Corporation CK804 USB Controller (rev a3)
00:06.0 IDE interface: nVidia Corporation CK804 IDE (rev f2)
00:07.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:08.0 IDE interface: nVidia Corporation CK804 Serial ATA Controller (rev f3)
00:09.0 PCI bridge: nVidia Corporation CK804 PCI Bridge (rev f2)
00:0a.0 Bridge: nVidia Corporation CK804 Ethernet Controller (rev f3)
00:0b.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0c.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0d.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev f3)
00:0e.0 PCI bridge: nVidia Corporation CK804 PCIE Bridge (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] Miscellaneous Control
01:01.0 FireWire (IEEE 1394): VIA Technologies, Inc. IEEE 1394 Host Controller (rev c0)
05:00.0 VGA compatible controller: nVidia Corporation G72 [GeForce 7300 SE] (rev a1)

ron@ron-desktop:~$ lsmod | grep snd
snd_usb_audio 81024 1
snd_pcm_oss 44672 0
snd_mixer_oss 17664 1 snd_pcm_oss
snd_pcm 80388 2 snd_usb_audio,snd_pcm_oss
snd_page_alloc 11400 1 snd_pcm
snd_usb_lib 17920 1 snd_usb_audio
snd_hwdep 10244 1 snd_usb_audio
snd_seq_dummy 4740 0
snd_seq_oss 33152 0
snd_seq_midi 9600 0
snd_rawmidi 25728 2 snd_usb_lib,snd_seq_midi
snd_seq_midi_event 8448 2 snd_seq_oss,snd_seq_midi
snd_seq 53232 6 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer 24324 2 snd_pcm,snd_seq
snd_seq_device 9228 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd 54660 12 snd_usb_audio,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_hwdep,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer, snd_seq_device
soundcore 8800 1 snd
usbcore 138632 5 snd_usb_audio,snd_usb_lib,ehci_hcd,ohci_hcd

Thanks for that.
 
Old 11-01-2007, 03:43 AM   #4
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Rep: Reputation: 30
Its looks like your sound device is USB based, and recognised with drivers installed.

Have you checked the mixer settings to make sure nothing is muted and that volume and PCM inputs are not off.
 
Old 11-01-2007, 09:09 PM   #5
zerotwooneone
LQ Newbie
 
Registered: Apr 2007
Location: Nacogdoches
Distribution: Ubuntu, Slackware, Red Hat
Posts: 3

Rep: Reputation: 0
I am having the same trouble as above.
I have a fresh install of 7.10 and still no sound.
I have similar outputs as above (duh, same motherboard).
I also have checked the mixer settings as thoroughly as possible, working under the same assumption as keratos.
*edit*
I have also tried out the options suggested by linuxwizard on this thread http://ubuntuforums.org/showthread.php?t=550964

Last edited by zerotwooneone; 11-01-2007 at 09:51 PM.
 
Old 11-02-2007, 04:27 AM   #6
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Rep: Reputation: 30
It all seems to be okay in terms of linux recongnising the device and installing the appropriate modules (drivers). Strange!

Check BIOS settings for IRQ / Memory / IO conflicts, or better still try resetting the BIOS (remove battery, wait 5 mins, replace, reboot and reconfigure BIOS to "Safe Defaults", reboot and try.
 
Old 11-02-2007, 04:44 AM   #7
chevalier
LQ Newbie
 
Registered: May 2007
Posts: 9

Original Poster
Rep: Reputation: 0
No sound under Ubuntu.

Thank goodness I've found another person having the same problem. Thank Zerotwooneone ! I'll certainly try the tips in the link but it sounds (no pun intended) as though I won't have much success. Can I ask what packages you have installed ? I've got the alsamixer and Movie Player. I've opened the ALsamixer several timers and ensured that the volumn controls are unmuted. I've also tried using aplay from the command line. One recurring theme is that I keep getting messages to the effect that the system cannot open a resource for writing. Does this imply that something is missing or that permissions are not correctly set ?

yours - in silence

ron
 
Old 11-04-2007, 11:21 PM   #8
zerotwooneone
LQ Newbie
 
Registered: Apr 2007
Location: Nacogdoches
Distribution: Ubuntu, Slackware, Red Hat
Posts: 3

Rep: Reputation: 0
In answer to the question, I have an almost standard Desktop install. Very little else installed as of yet because I am settled with windows on this machine. Its mostly for gaming anyways. I do my work on an Ubuntu laptop.
We know that the card is being registered by the OS, but that it is being recognized as USB. This is not unusual as I believe they share the same bus. I know that my card will not default to the zero position no matter what I change given a lot of tests using trick in the earlier posts.
What I'd like to know is how to set my card up as the position zero audio device. I'd also like to know if there are any others who have the same chipset and maybe who have gotten them working. I'm curious if setting the card to position zero will even help the problem at all. Since it was suggested, I will try it.
In regards to resetting the BIOS, I dont quite feel like doing that right now, but I will update to the newest BIOS available 1002 (I think). Failing that, and given more free time, I will reset the BIOS.

Regards,
zerotwooneone

Last edited by zerotwooneone; 11-04-2007 at 11:30 PM.
 
Old 11-05-2007, 12:26 AM   #9
zerotwooneone
LQ Newbie
 
Registered: Apr 2007
Location: Nacogdoches
Distribution: Ubuntu, Slackware, Red Hat
Posts: 3

Rep: Reputation: 0
Allright. I have at least gotten the meagre results that others claim. And i know what I did. Of course in my fiddlings I was hardly scientific. I will list the three things I did to get *limited* sound in Ubuntu from least likely to most likely:
1) updated the BIOS from 0702 to 1002 (most recent beta at this time). I did not expect this to work, but I did not give this a thorough sound test before moving on.
2) changed one setting in bios under power-> apm -> and then some acronym. The description for this feature says that it makes the multimedia compatible for vista. This sounded like a possible window. Again, i checked sound, but not thoroughly before moving on.
3) The most likely solution is in Ubuntu, under system -> preferences -> sound. From there, change the drop menus to "ÚSB SOUND".
With this you will notice that some sounds will work. However this is not complete in that sounds emitted from firefox/flash and so forth will not be heard.
Let me know how this works out for individuals. I'd like to know if there is a better way.

Cheers,
zerotwooneone
 
Old 11-06-2007, 03:25 PM   #10
chevalier
LQ Newbie
 
Registered: May 2007
Posts: 9

Original Poster
Rep: Reputation: 0
Sound (partially) working

O.K. Progress at last. I set all the drop-downs on system -> preferences -> sound to USB. I can now place WAV files and the video of Nelson Mandela plays with sound. I can also play an audio CD . This is the only change I made as my BIOS settings were already set to the "enable setting for Vista" setting.

I think I'll retire to a darkened room and have a lie down now. Thanks for all the help. I will probably be back with some other problem later.

chevalier

Remember : "Outside of a dog a , a book is a man's best friend. Inside of a dog it's too dark to read." - Groucho Marx
 
  


Reply

Tags
asus, m2n, sound, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot get sound on Asus M2N MX using Fc6 64bit. looktowhere Linux - Hardware 15 10-14-2007 02:15 PM
Asus M2N-SLI Motherboard internet connection problem jem63 Linux - Hardware 1 06-24-2007 01:20 PM
Cannot play sound in Sabayon 3.26 on ASUS M2N-MX board linuxismanshobby Linux - Hardware 2 04-27-2007 02:49 AM
Asus M2N - Supported? Jorophose Linux - Hardware 1 02-17-2007 10:03 PM
No sound on Asus A7V600 motherboard breakolami Linux - Hardware 1 05-28-2004 10:22 AM


All times are GMT -5. The time now is 02:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration