LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-26-2014, 07:14 AM   #1
varunfloyd
LQ Newbie
 
Registered: Jan 2014
Location: India
Distribution: Slackware 14.1
Posts: 2

Rep: Reputation: Disabled
No Sound: Media Players give error even after installing Alien Restricted!


I have a Dell Inspiron N5437 with Win8.1. Got it to dual boot with Slackware 14.1 with full installation (kernel version 3.10.17).

Problem I now have: it is unable to play sound from any media file, when i try, it ends with an error like this:

Code:
bash-4.2# aplay audiofile.wav 
ALSA lib pcm_dmix.c:1022:(snd_pcm_dmix_open) unable to open slave
aplay: main:722: audio open error: No such file or directory.
from Audacious it says:
Quote:
ALSA error: No suitable mixer element found.
ALSA error: snd_mixer_find_selem failed.
ALSA error: snd_pcm_open failed: No such file or directory.
VLC Media Player and Kplayer play the file but there's no sound.

I must state that it does play all the system sounds such as- KDE startup, battery low etc. I can even see videos files being played smoothly but no sound from them.
This also applies to the Youtube videos in Firefox which play without any sound.

I've done the following in an attempt to fix it:

1. Followed steps from slackdocs:
http://docs.slackware.com/howtos:har..._snd-hda-intel

2. Installed Slackbuilds from alien restricted.

3. Ran alsamixer and alsaconf.
alsaconf gave:
Quote:
No supported PnP or PCI card found.
Would you like to probe legacy ISA sound cards/chips?
selected "yes", it gave:
Quote:
No legacy drivers available
4.Reinstalled alsa-lib, alsa-plugins, alsa-utils.

5. Searched around a lot. Got a few links but didn't work out, so almost
everything i could.

Here's output of
Code:
 bash-4.2# lsmod | grep snd
snd_hda_codec_realtek    34792  1 
snd_hda_codec_hdmi     29622  1 
snd_hda_intel          34861  4 
snd_hda_codec         143196  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               6388  1 snd_hda_codec
snd_pcm                76009  3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
snd_page_alloc          7098  2 snd_pcm,snd_hda_intel
snd_timer              18614  1 snd_pcm
snd                    58630  15 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore               5354  1 snd

Code:
 bash-4.2# lspci
00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 09)
00:03.0 Audio device: Intel Corporation Device 0a0c (rev 09)
00:14.0 USB controller: Intel Corporation Lynx Point-LP USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation Lynx Point-LP HECI #0 (rev 04)
00:1b.0 Audio device: Intel Corporation Lynx Point-LP HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 1 (rev e4)
00:1c.2 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 3 (rev e4)
00:1c.3 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation Lynx Point-LP PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation Lynx Point-LP USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Lynx Point-LP LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Lynx Point-LP SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Lynx Point-LP SMBus Controller (rev 04)
06:00.0 Network controller: Atheros Communications Inc. AR9565 Wireless Network Adapter (rev 01)
07:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 08)
08:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev ff)
aplay gave me:
Code:
bash-4.2# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC283 Analog [ALC283 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
also:
Code:
 bash-4.2# cat /proc/asound/modules
 0 snd_hda_intel
 1 snd_hda_intel
and
Code:
 bash-4.2# cat /proc/asound/card*/codec* | grep Codec
Codec: Intel Haswell HDMI
Codec: Realtek ALC283
My Laptop Specs(if it matters):
i5 4 Gen (Haswell)
4 GB RAM
nvidia gt 740M

I recently switched to Slackware from Ubuntu and found setting it up to be a bit overwhelming.
I've heard that once you choose Slackware, there's no going back, so i've been trying to solve it
for a couple of days rather than installing Ubuntu again.

Please consider that i'm a newbie and it'd be great if you'd help
Thanks in advance.
 
Old 02-27-2014, 03:02 AM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,098
Blog Entries: 3

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
Is this in the kde environment.? those programs look for default device. sure you did just fine from the docks. make sure auto mute is off. and make sure if using kde that in the kde settings manager multimedia that you have set it the play back device you want to use.
then in the kmix make sure you set up your mixer channels so they all show. I run multiple sound cards so I actually have set up my snd_cards manually in /etc/modprobe.d/ because of this issue with kde. But i will say it has got better with the latest's kde.

this is the one you added from slack docks
Quote:
options snd-hda-intel model=auto
here is the one I added because all my usb mixers kept taking default.

Quote:
# --- BEGIN: Generated by ALSACONF, do not edit. ---
# --- ALSACONF version 1.0.25 ---
alias char-major-116 snd
alias char-major-14 soundcore
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd slots=snd-hda-intel,snd-usb-audio
let me know check back later.

I use both

Last edited by Drakeo; 02-27-2014 at 03:12 AM.
 
Old 02-27-2014, 03:32 AM   #3
varunfloyd
LQ Newbie
 
Registered: Jan 2014
Location: India
Distribution: Slackware 14.1
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks for reply Drakeo.
I made sure i'd selected the right sound card after running
Quote:
alsamixer
pressed f6 to select sound card it showed:
Quote:
Sound Card
- default
0 HDA Intel MID
1 HDA Intel PCH
i seleted HDA Intel PCH (only the one in which it presented me various volume
levels to adjust), made sure nothing is muted (pressing m), increased all levels to full and exited. tried to play i get errors again.

I added those options in the file /etc/modprobe.d/ directory, restarted, now it gives a notification at startup
Quote:
Multimedia System
The audio playback device HDA Intel PCH (ALC283 Analog) does not work.
Falling back to HDA Intel PCH, ALC283 Analog (Default Audio Device).
no playback.

Last edited by varunfloyd; 02-27-2014 at 04:07 AM.
 
Old 02-27-2014, 09:18 AM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,098
Blog Entries: 3

Rep: Reputation: 325Reputation: 325Reputation: 325Reputation: 325
yes I seen kde do that over and over
just agree with it and go in to settings and reset default again and test them. then set it to aplications and devices. thats on the left of the multimeda phonon or what ever. log in to xfce4 set it's mixer up. you can always open a terminal and run alsamixer and do it from there.

The rest of the programs just read that except kde. you can also delete the /var/lib/alsa/asound.state and asound.state.lock and reboot it will generate a new one from your modprobe.d sound.conf and then kde will read that and yes tell you somthing is not working and just go along with it. then go to kde multimedia phonon settings and use gstreamer is what I use.
and test your default save it. log out of kde then log back in and you shouild here the music. now make sure you have the speakers plugged in right ???

When you chose a device in kde settings you move it to the top that tells it to set it to default.

I also one time removed the /var/lib/alsa/asound.state and asound.state.lock and ~/home/.kde/share/apps/kmix and rebooted but I made sure I had my /etc/modprobe.d/sound.conf right all I had to do was add the channels in kmix.

Last edited by Drakeo; 02-27-2014 at 09:39 AM. Reason: remeber/more stuff
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fedora 16, all media players have sound, but no video bfzhou Linux - Software 17 02-03-2012 10:56 PM
[SOLVED] Sound comes and goes in Flash, no media players work, system sounds generally DO work damgar Arch 2 07-03-2010 12:46 PM
[SOLVED] sound doesn't work in flashplayer and some media players neuplnost Linux - Software 8 12-29-2009 10:25 AM
Sound Issues with media players in Slackware Madlax22 Slackware 16 12-24-2009 08:33 PM
no sound in media players headshot Linux - Software 3 07-25-2003 06:12 PM


All times are GMT -5. The time now is 08:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration