LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2014, 02:28 PM   #1
Grimace78
LQ Newbie
 
Registered: Nov 2012
Location: Texas
Distribution: Ubuntu 13.10, Arch Linux, LFS (7.4) project started
Posts: 13

Rep: Reputation: Disabled
No sound in wine


I have no sound in wine for Steam (only wine app I run). I haveI have tried various alsa configurations, and nothing has worked so far. The error message:
Code:
err:ole:CoInitializeEx Attempt to change threading model of this apartment from multi-threaded to apartment threaded
/etc/modprobe.d/alsa-base.conf
Code:
# Set the default sound card
options snd slots=snd_hda_intel,sdn_hda_NVidia
options snd_hda_intel=0
options snd_hda_NVidia=1

options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
options snd-pcsp index=-2
/etc/asound.conf
Code:
 pcm.!default {
   type plug
   slave.pcm {
     @func getenv
     vars [ ALSAPCM ]
     default "hw:0,1"
   }
 }

defaults.pcm.rate_converter "samplerate_best"
Any help would be appreciated.
 
Old 03-01-2014, 03:19 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,986

Rep: Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447Reputation: 2447
not really what you want to hear but...
if you must use the Microsoft version of steam
then use a Microsoft OS that is supported like Win7
 
Old 03-01-2014, 04:18 PM   #3
Grimace78
LQ Newbie
 
Registered: Nov 2012
Location: Texas
Distribution: Ubuntu 13.10, Arch Linux, LFS (7.4) project started
Posts: 13

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by John VV View Post
not really what you want to hear but...
if you must use the Microsoft version of steam
then use a Microsoft OS that is supported like Win7
I had already decided to do that, but when I tried to get the windows installation disk to boot up, it wouldn't. I thought it had something to do with going with UEFI/GPT setup for arch, and absolutely did not want to go back to bios/mbr setup. I have a ton (1.5 TB) of data that I didn't want to take a chance on losing. I just did a search for windows 7 and apparently UEFI is not a problem. Maybe I had a bad disk; I would still much rather use wine instead of duel boot though. I just haven't been able to get it working with Arch Linux. And I really hate Microsoft.
 
Old 03-02-2014, 02:45 AM   #4
Grimace78
LQ Newbie
 
Registered: Nov 2012
Location: Texas
Distribution: Ubuntu 13.10, Arch Linux, LFS (7.4) project started
Posts: 13

Original Poster
Rep: Reputation: Disabled
[solved]

Sound is finally working.

1.Installed wine-multimedia package from AUR (specifically wine-1.7.13 ported to Arch), which has a fix to select pulse in winecfg. https://aur.archlinux.org/packages/wine-multimedia/

2.Once installed had to select pulse for sound in that wine-prefix.

3.Then in terminal (in debugging mode) inside that wine-prefix
Quote:
winetricks xact
winetricks vcrun2008
winetricks d3dx9_42
http://www.steamgamesonlinux.com/sky...der-scrolls-v/

4.Install Steam inside the same prefix.

Done.

Seems pretty straightforward now that it is done, and much clearer when done completely in the terminal.

Note: Steam (in the voice settings) still says it does not detect an audio device but it still works just fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Wine sound flyinggeorge Linux - Software 1 03-02-2012 04:30 PM
(Wine 0.9.20) No sound - incorrect sound card in winecfg Zaulden Linux - Games 1 09-03-2006 10:31 PM
no sound with wine ylts Linux - Software 1 03-08-2005 10:42 AM
wine sound playback speed, (slow motion sound) qwijibow Linux - Software 2 06-04-2004 10:39 PM
Wine : cannot have sound with any sound server vmicho Linux - Games 3 05-16-2004 07:44 AM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration