LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-31-2005, 05:00 PM   #1
pagady13
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Rep: Reputation: 0
no sound in ubuntu


Hi, first of all I wold like to apologize for my English, ...I'm learning. I use Ubuntu (5.04)
and I have no sound. I used to have sound in Suse 9.3. It looks like Ubuntu recognizes my sound card which is built in my motherboard, but there is silence. My motherboard is GA- GPNXP DUO. Ubuntu identifies the sound card as 82801FB/FBM/FR/FW/FRW(ICH6 Family)Hygh Definition Audio Controler. I get the following error messages related to sound:
-when I try to open “recording level monitor” = cannot connect to the sound , please run esd at a command prompt
-if I type esd and press enter I get = no such file or directory
-if I try to open “volume control” = no control volume elements and/or devices found
I appreciate any help, because I don't think I cannot sort it out by myself!
 
Old 08-31-2005, 05:53 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
As root from a teminal type lspci then press enter.
Copy and paste what it says for multimedia
 
Old 08-31-2005, 06:05 PM   #3
pagady13
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Original Poster
Rep: Reputation: 0
This is the result:
0000:00:00.0 Host bridge: Intel Corp. 915G/P/GV Processor to I/O Controller (rev 04)
0000:00:01.0 PCI bridge: Intel Corp. 915G/P/GV PCI Express Root Port (rev 04)
0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
0000:00:1c.0 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
0000:00:1c.3 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d3)
0000:00:1f.0 ISA bridge: Intel Corp. 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
0000:00:1f.2 IDE interface: Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 3e50
0000:03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
0000:04:05.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Gigabit Ethernet 10/100/1000Base-T Adapter (rev 13)
0000:04:07.0 FireWire (IEEE 1394): Texas Instruments TSB82AA2 IEEE-1394b Link Layer Controller (rev 01)
 
Old 08-31-2005, 06:27 PM   #4
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
the module your sound card uses is SND_INTEL8X0, i think. Ubuntu should have no problem recognizing that. Have you tried running esd as root?
 
Old 08-31-2005, 06:40 PM   #5
pagady13
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I've just tried, but I get the same result:
root@ubuntu:/home/george # esd
/dev/dsp: No such file or directory
 
Old 08-31-2005, 06:52 PM   #6
Ay-Karamba!
Member
 
Registered: Aug 2005
Location: Sydney
Distribution: Ubuntu, FC4
Posts: 43

Rep: Reputation: 15
I had the same problem with my laptop, and I found out I just need to openup alsamixer, and go to "external" option, press m to unmute (it is muted by default). I'm running FC4 though, dunno if this works with ubuntu
 
Old 08-31-2005, 07:10 PM   #7
pagady13
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I do not think I have alsamixer instaled.I thought you cannot have both, esd and alsamixer installed(maybe I'm wrong). Anyway look what's happening:
root@ubuntu:/home/george # alsamixer

alsamixer: function snd_ctl_open failed for default: No such file or directory
root@ubuntu:/home/george #
 
Old 08-31-2005, 07:34 PM   #8
bosewicht
Senior Member
 
Registered: Aug 2003
Location: Honolulu, HI
Distribution: Arch
Posts: 1,380

Rep: Reputation: 47
I think you would just need alsa-lib alsa-utils
Type
lspci
in a cmd prompt and post the output
 
Old 09-01-2005, 12:33 AM   #9
pagady13
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Original Poster
Rep: Reputation: 0
Here it is:
george@ubuntu:~$ lspci
0000:00:00.0 Host bridge: Intel Corp. 915G/P/GV Processor to I/O Controller (rev 04)
0000:00:01.0 PCI bridge: Intel Corp. 915G/P/GV PCI Express Root Port (rev 04)
0000:00:1b.0 0403: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) High Definition Audio Controller (rev 03)
0000:00:1c.0 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 1 (rev 03)
0000:00:1c.3 PCI bridge: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) PCI Express Port 4 (rev 03)
0000:00:1d.0 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #1 (rev 03)
0000:00:1d.1 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #2 (rev 03)
0000:00:1d.2 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #3 (rev 03)
0000:00:1d.3 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB UHCI #4 (rev 03)
0000:00:1d.7 USB Controller: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) USB2 EHCI Controller (rev 03)
0000:00:1e.0 PCI bridge: Intel Corp. 82801 PCI Bridge (rev d3)
0000:00:1f.0 ISA bridge: Intel Corp. 82801FB/FR (ICH6/ICH6R) LPC Interface Bridge (rev 03)
0000:00:1f.2 IDE interface: Intel Corp. 82801FR/FRW (ICH6R/ICH6RW) SATA Controller (rev 03)
0000:00:1f.3 SMBus: Intel Corp. 82801FB/FBM/FR/FW/FRW (ICH6 Family) SMBus Controller (rev 03)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc: Unknown device 3e50
0000:03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5751 Gigabit Ethernet PCI Express (rev 01)
0000:04:05.0 Ethernet controller: Marvell Technology Group Ltd. Yukon Gigabit Ethernet 10/100/1000Base-T Adapter (rev 13)
0000:04:07.0 FireWire (IEEE 1394): Texas Instruments TSB82AA2 IEEE-1394b Link Layer Controller (rev 01)
george@ubuntu:~$
 
Old 09-01-2005, 11:41 AM   #10
pagady13
LQ Newbie
 
Registered: Aug 2005
Posts: 8

Original Poster
Rep: Reputation: 0
I used Synaptic and:
-alsa-utils is installed
-I could not finde alsa-lib; what I found was libesd-alsa0;
-I installed libesd-alsa0 (and automatically libesd0 was deleted);
There is no difference yet.No sond.
Please Help!!!
 
Old 09-09-2005, 12:52 PM   #11
EwanG
Member
 
Registered: Sep 2003
Location: San Antonio, TX
Distribution: Debian
Posts: 81

Rep: Reputation: 15
I believe in Ubuntu you have to use sudo to run a "root" command. If so, then have you tried:

sudo modprobe snd_intel8x0m

and then run a mixer program to turn the sound up (as most systems mute the card by default)?
 
Old 10-06-2005, 12:50 PM   #12
treebeardjrm
LQ Newbie
 
Registered: Oct 2005
Posts: 1

Rep: Reputation: 0
Kernel 2.6.12

The Intel High Definition Audio controller didn't get kernel support until 2.6.12. Make sure that you're running at least 2.6.12, and have support for 'Intel High Definition Audio' in your kernel. It's easy to find out if you do have kernel support: go to /boot, then read the file that begins with config-<kernel version>. You can type 'uname -r' at a shell prompt to find out what kernel version you're running. You might also be able to look at your kernel configuration in /proc.

If you're sure that you're running kernel 2.6.12 or newer, and that Intel HDA is supported, then make sure that the proper module is loaded:

snd_hda_intel

Do this with the following shell commands:

lsmod | grep intel

If the module isn't loaded, load it, and consider putting it in /etc/modules so it loads on startup next time.

If the module is loaded, check your mixer settings to make sure that nothing is muted.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu Breezy No Sound on Audigy Sound Card rjcmi Ubuntu 14 03-10-2009 11:19 PM
Realtek Sound and Ubuntu Linux - No Sound meindl007 Linux - Hardware 22 10-05-2005 02:16 PM
No Sound on Ubuntu 5.04 ag2uki Ubuntu 4 06-20-2005 02:35 PM
No sound on ubuntu kellenh Ubuntu 5 06-11-2005 01:01 AM
No Sound in Ubuntu zeroz52 Linux - Newbie 2 02-27-2005 12:01 AM


All times are GMT -5. The time now is 02:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration