LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-28-2003, 05:04 AM   #1
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Rep: Reputation: 45
No Sound from audio CD's with mandrake 9.0


HOPEFULLY THIS THREAD WILL COMBINE THE 2/3 THAT HAVE BEEN GOING ON, AND PREVENT ANY CONFUSION!

As per the title, I (and at least 1 other person) can't play audio cd's with any of the app's in mandrake 9.0

My system was built by MEDION, it's using a pentium 4 (at 2 gig), with 256meg of pc2100 ddr ram. The hdd is 40 gig, partitioned up to run the mandrake 9 and wind0w$ XP. The soundcard is a Creative soundblaster 5.1 digital, though the mandy install see's it as a SB Live!, and loads up the emu10k1 module. The mainboard also has an onboard AC97 sound device which has previously caused me on end of stress trying to configure it, and as a result, it turned off at the BIOS (though I'm going to treble check that when I've posted this!)

It has a DVD drive that the mandrake install calls CDROM (a.k.a. /dev/hdb) and a cdrw that mandy calls CDROM2 (a.k.a. /dev/scd0).

What happens:-

If I put a disc in "CDROM" then with kscd, it show a disc in the drive, the number of tracks (not the track titles) and when I "press play" it seems to be running. With grip it shows me the track times and titles etc and appears to be playing. With XMMS I get nothing. All this happens with no sound.

If I put a disc in "CDROM2" it doesn't show up at all, with either kscd or grip, and still nothing with XMMS. The only thing is, that if I use the front panel buttons of "CDROM2" i.e. the cdrw, then it will play the disc, with the volume control on the front of the speakers working which I understand means that the CDROM2/cdrw is cable connected to the soundcard.

Now, I appreciate that it could be that I am too stupid to understand how to operate the applications, afterall, I am only a recently migrated wind0w$ drone - though IMO, the documentation, as usual, is written for "IT people" by "IT people", and doesn't seem to take into account newbie types who do not come from an IT background.


So, the question is, "how do I get my system to play audio cd's?"


regards

John
 
Old 02-28-2003, 05:13 AM   #2
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
Connect the audio cable that presently is connected to the CDRW to the CDROM. Then when KSCD is running, it should be the CDROM output that you hear. Check mixer levels, too - Start - Multimedia - Sound -Kmix.
 
Old 02-28-2003, 10:58 AM   #3
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
The mixer levels, I have checked a number of times, and anything that appears that it might effect sound is turned up to about 4/5ths.

Also, regarding changing the cabling to the CDROM (DVD) instead of the CDROM2 (cdrw), if I can play DVD's under wind0w$ and get the audio, what is different about my mandrake install that would require me to change the cable over ???

In fact, I'm just going to check to see if I can play an audio cd from the DVD drive under wind0w$.

regards

John

edit> yes, the answer is that I can play an audio cd using the DVD drive under windows. Hence what difference should it make whether the audio lead from drive to card is from the DVD or cdrw?

Last edited by bigjohn; 02-28-2003 at 11:09 AM.
 
Old 02-28-2003, 11:24 AM   #4
carlywarly
Member
 
Registered: Feb 2003
Location: Sunny Southport, again.
Distribution: PCLinuxOS 0.93 and 0.92, Vector sometimes
Posts: 825

Rep: Reputation: 30
I'm a little confused, now. I thought you wanted to know how to use KSCD or similar to play an audio CD in Linux from your CDROM drive. To do that, you need an audio cable from the player to the sound card. In Windows, the sound can be channelled through the ide cable so an audio cable is not always necessary.

Edit PS - if you want to use your CDRW to play audio CDs, just go into KSCD, settings, CDROM Device and choose /dev/scd0 instead of /dev/cdrom

Last edited by carlywarly; 02-28-2003 at 11:28 AM.
 
Old 02-28-2003, 02:50 PM   #5
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
I cannot agree more John; Documentation is truly written by and for the same level of experienced person(s). I really don't like that, and think that's one of the greatest reasons these type of forums exist. We give it the human touch it needs, break things down and eventually (hopefully) develop an understanding of what the docs are trying to say for the user.

I will also suggest something. You may still be getting your onboard audio starting up. Let's see your modules.conf so we can maybe have you edit a line or 2 in there so your SB card will be the one that is being used rather than your AC97 card.

Cool
 
Old 03-01-2003, 07:43 AM   #6
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
Ha Ha !!!

I have got the KSCD playing (What's the story) Morning Glory ? by Oasis.

I have used CarlyWarly's suggestion, to tell "it" where/how to look. All I can say, is that this is what happens when you have got a moron like me trying to drive an application (instead of a truck). I can only say that maybe I expect too much from mandrake. Also, I just can't believe my stupidity, though in truth it's probably because I have still got too much wind0w$ dross stuck in my head.

Perhaps I should do like I do when trying to fix my bike, and look for the small things first.

regards

John

p.s. I suppose, at least I'm "big" enough to admit when the answers in front of me, and I'm too stupid to see it!
 
Old 03-01-2003, 09:39 AM   #7
PlanetNEO
Member
 
Registered: Dec 2002
Location: Memphis, TN
Distribution: Mandrake 9.0
Posts: 47

Rep: Reputation: 15
Don't be too hard on yourself, dude. It's a different environment and takes time to get used to. I'm continually amazed at the stupid things I do in Linux, things that are pretty basic to PC's regardless of the OS. Never considered myself a techo-tard, but transitioning can make you feel that way sometimes. Idiot things like trying to browse a music CD, checking to make sure the NIC is seated right in the slot before trying to recompile the kernel. I know better. But for some reason it's like I have to relearn basic stuff.

Not sure why it happens, either.
 
Old 03-01-2003, 12:33 PM   #8
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Re: Ha Ha !!!

Quote:
Originally posted by bigjohn
I have got the KSCD playing (What's the story) Morning Glory ? by Oasis.

I have used CarlyWarly's suggestion, to tell "it" where/how to look. All I can say, is that this is what happens when you have got a moron like me trying to drive an application (instead of a truck). I can only say that maybe I expect too much from mandrake. Also, I just can't believe my stupidity, though in truth it's probably because I have still got too much wind0w$ dross stuck in my head.

Perhaps I should do like I do when trying to fix my bike, and look for the small things first.

regards

John

p.s. I suppose, at least I'm "big" enough to admit when the answers in front of me, and I'm too stupid to see it!
(repeat) Woohoo!

Nice job CarlyWarly

John, when troubleshooting it's gonna always seem like that. Once you find the answer, you think to yourself "I should have done that first" but, in the end, none of us ever do

Have Fun

Cool
 
Old 03-01-2003, 03:11 PM   #9
twan
Member
 
Registered: Feb 2003
Location: Brasschaat, Antwerpen - Belgium
Distribution: Gentoo
Posts: 52

Rep: Reputation: 15
can't you have 2 audio cables from both cdroms ? (dvd and writer). i believe i can do that
 
Old 03-02-2003, 01:48 AM   #10
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Yes, though it may depend on your sound card, and more importantly whether you have 2 audio cables or not

Cool
 
Old 03-02-2003, 02:23 AM   #11
Texicle
Member
 
Registered: Oct 2002
Location: Northern Ontario, Canada
Distribution: Slackware 10.0
Posts: 789

Rep: Reputation: 30
I have a similar problem in Slack 8.1. However, it used to work just fine. I upgraded my X from 4.2.0 to 4.2.1 and now I don't get any sound. My audio cable is connected from CD-ROM to card, all my modules are correct, my modules.conf is correct, my speakers are hooked up, volume up, powered on, my /dev/dsp and /dev/mixer are both chmod'ed to 777 just to be sure (I'll change that later), and according to kmix and gnome's audio mixer, nothing is muted and I've jacked the volumes all the way up. In XMMS, I made sure that my volume was cranked up too. No sound. It displays tracks, plays them, but no sound. It's very weird. When I was in xfree86 4.2.0 everything worked perfectly. Any ideas?
 
Old 03-02-2003, 05:07 AM   #12
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
Whooooossssssshhhhhhhh!

That's the noise of Tex's post going over my head - lets face it, I found changing the default device from "CDROM" to /dev/scd0 a complicated issue.

Sorry Tex, not a scooby!

regards

John


P.S. PlanetNEO, Techno - Tard, excellent, what a good phrase. Worthy of filing in the old memory
 
Old 03-02-2003, 05:18 AM   #13
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 68
Quote:
Originally posted by Texicle
I have a similar problem in Slack 8.1. However, it used to work just fine. I upgraded my X from 4.2.0 to 4.2.1 and now I don't get any sound. My audio cable is connected from CD-ROM to card, all my modules are correct, my modules.conf is correct, my speakers are hooked up, volume up, powered on, my /dev/dsp and /dev/mixer are both chmod'ed to 777 just to be sure (I'll change that later), and according to kmix and gnome's audio mixer, nothing is muted and I've jacked the volumes all the way up. In XMMS, I made sure that my volume was cranked up too. No sound. It displays tracks, plays them, but no sound. It's very weird. When I was in xfree86 4.2.0 everything worked perfectly. Any ideas?
And the ONLY thing you changed when upgrading X was X itself?

Really sounds odd... no... very odd to me. You may want to try using workbone or some other command line cdplayer to see if that's the issue (X).

Good Luck troubleshooting that one

Cool
 
Old 03-02-2003, 09:30 AM   #14
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
This audio business is starting to be a pain in the arse.

Splendid, I can use KSCD. But I was trying to get grip sorted, and now it won't even start. I have tried removing and re-installing it but to no avail. If I try and start it in konsole I just get error Unable to initialise [CDROM2]

Also, does anyone know where I can find an idiot's guide to using XMMS, because for the life of me, I can't load a playlist.

regards

John
 
Old 03-02-2003, 10:04 AM   #15
bigjohn
Senior Member
 
Registered: Jun 2002
Location: UK .
Distribution: *buntu (usually Kubuntu)
Posts: 2,682
Blog Entries: 9

Original Poster
Rep: Reputation: 45
update 3032897467 in the no audio cd saga!

I just popped into root and managed to start grip, then I told it to look at /dev/scd0. I had to close it and re open it and the changes where effected. I had to uncheck a few boxes, but it played.

So back into my home account, and tried to start it, it just said the error unable to initialise cdrom2 again, just to check it, I su'd and it started ok and played a track.

So how do I configure it from a konsole so it looks at /dev/scd0 as it has got to be something to do with not liking the CDROM2 nonclamenture ?

regards

John

p.s. I still haven't got any further loading a playlist with XMMS

Last edited by bigjohn; 03-02-2003 at 10:06 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
SuSE 9.0 no sound from audio cd's corso64 Linux - Distributions 2 09-15-2004 07:19 AM
Sony DRU530A....No sound from audio cd's on linux arctic123 Linux - Hardware 1 09-04-2004 09:07 PM
No sound from audio CD's with Fedora Core 1 Lanorien Fedora - Installation 1 04-01-2004 04:34 PM
Audio cd's don't play in Gnome- mandrake 10 ZenPirate Mandriva 2 03-24-2004 03:11 PM
No sound from Audio CD's xilent Linux - Newbie 8 02-20-2003 07:10 PM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration