LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-26-2009, 02:37 PM   #1
itayze
LQ Newbie
 
Registered: Mar 2009
Posts: 1

Rep: Reputation: 0
No sound even after installing alsa


Hi everyone , I've installed linux because i wanted to exprience and maybe learn a bit more programming.
Today i spent a couple of long and a bit desprating hours trying to get the sound working ....

I have Hd high audio controller (O/B soundcard , its Realtek I believe ) , OpenSuse (11.0 ) recognizes it but there just isn't any sound - i've seen alsamixer and it's not on mute ("alsaconf" isn't working for some reason ) .

I don't know what to do ,maybe I got the installtion wrong , any tips , explantion , I really want to learn how to use Linux but I need my music !

and if you can take a couple more minutes so your explantion will be clear and detailed it will be very usefull :-)
 
Old 03-26-2009, 03:44 PM   #2
Earl Parker II
Member
 
Registered: Jan 2002
Location: Shelby, NC, US
Distribution: Slackware 12.2
Posts: 127

Rep: Reputation: 17
Below are some generic ideas- you make need to modify things to work with OpenSuse:

First, I'd open a console, su to root, then enter 'lspci'. Make sure your soundcard is present in the list.

Next, go to your /etc/rc.d directory (or it's System V equivalent) and make sure that rc.alsa is executable. If not, enter 'chmod 755 /path/to/rc.alsa' to make it so, then enter '/path/to/rc.alsa start'.

Assuming the above goes well, enter 'alsamixer'. Use the tab key to select 'View: [Playback]'. Use the arrow keys to select, then the 'Page UP' key to maximize (at least for the moment) Master, Master M and PCM. Make sure that Master, Master M and PCM are enabled (use the 'M' key to toggle them from off (MM) to on (00)). When you're done, hit the 'Esc' key, then enter 'alsactl store' to save your settings.

The above assumes the speakers are on and the lead is plugged into the correct port on your sound card.

See if you have sound. If the above is clear as mud, or doesn't work, get back to us.

Last edited by Earl Parker II; 03-26-2009 at 03:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound after installing Mandriva 2008, problem with ALSA Iltbreg Mandriva 25 06-20-2008 09:48 AM
No sound after installing ALSA Vitalie Ciubotaru Linux From Scratch 7 03-15-2006 10:28 AM
Error installing alsa sound driver lyar1031 Linux - Newbie 1 01-26-2006 08:17 PM
firefox lost sound after installing alsa kidicarus Linux - Software 3 12-30-2004 09:48 PM
installing alsa sound drivers nakedjohn Slackware 6 07-19-2003 01:45 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration