LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-31-2009, 11:56 AM   #1
wolibern
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Rep: Reputation: 0
Question No sound at all in Ubuntu 9.10


No sound is my latent problem for weeks (at ubuntu 9.10).


The driver I installed successfully (wolfgang@wolfgang-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
wolfgang@wolfgang-desktop:~$ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
02:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT] (rev a1)
wolfgang@wolfgang-desktop:~$) It worked once but after reboot of the os there was no sound any more.

"Sound Preferences" shows on output only "Dummy output stereo")

In the manual I was told to edit the modules to have loaded the sound at boot time: "Copy and paste this to the bottom of your /etc/modules.conf or /etc/modprobe.conf file" Well I didn`t find any of this files. So I just created them and tried to copy it into the directory "etc". But the system denied to paste to those directory. Anyway it wouldn't have worked because I guess there is some other file competent to load the sound. I'm stuck now and would like to get some info of how to get rid of all of this restrictions. For the time beiing at least. And I would need to know what file in "etc" loads the sound. For any help I'm very grateful.
 
Old 12-31-2009, 04:45 PM   #2
javanaut
LQ Newbie
 
Registered: Jun 2006
Posts: 7

Rep: Reputation: 1
Have you tried just plain "module" as a file name? (My case, I am using Ubuntu 8.10 on a 9-10yo laptop).
 
Old 01-01-2010, 08:38 AM   #3
wolibern
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks. I have a file named modules but I can't edit it: "You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again."
 
Old 01-01-2010, 08:57 AM   #4
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hello,

If you need to edit that file and any other files that need root permissions when logged in as a regular user, then put sudo in front of your command. The system will ask you for your user password and then grant you access if you are in the sudoers list.

Example:
Code:
sudo nano /etc/modules
Kind regards,

Eric
 
Old 01-13-2010, 10:12 AM   #5
wolibern
LQ Newbie
 
Registered: Dec 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Thank you! I made it - that is I could edit all that files I was to in the manual... but the sound still is dead. As I do all this experimentally probably I'm gonna install some other distribution of Linux. The new MANDRIVA 2010 seems to be fine...
 
Old 01-13-2010, 10:46 AM   #6
svinoba
LQ Newbie
 
Registered: Nov 2007
Location: Bengaluru, India
Distribution: Debian, Fedora, Slackware
Posts: 29

Rep: Reputation: 17
Hi,
1. Are you a member of 'audio' group?
2. Strange it may sound but I have read, tried and succeded by doing "chmod -R 777 /dev/snd".
3. You may also try alsamixer and see if anything is muted.
 
  


Reply

Tags
alc, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu recognises SB Live! 24 Sound card, but still no sound...! Headlock Linux - Hardware 1 03-11-2009 03:24 AM
Ubuntu Breezy No Sound on Audigy Sound Card rjcmi Ubuntu 14 03-10-2009 11:19 PM
no Sound in ubuntu inbuilt sound blaster 24bit G1795X motherboard fanaticx Linux - Hardware 19 09-13-2008 06:58 AM
Ubuntu Studio - No sound in applications, but at the system level i can hear sound boyd98 Linux - General 2 06-21-2008 11:40 AM
Sound problems with ubuntu 4.1 and a realtek sound card linux-novice Linux - Newbie 1 02-18-2006 11:44 PM


All times are GMT -5. The time now is 01:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration