LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No sound at all in Ubuntu 9.10 (http://www.linuxquestions.org/questions/linux-newbie-8/no-sound-at-all-in-ubuntu-9-10-a-779101/)

wolibern 12-31-2009 12:56 PM

No sound at all in Ubuntu 9.10
 
No sound is my latent problem for weeks (at ubuntu 9.10).


The driver I installed successfully (wolfgang@wolfgang-desktop:~$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: NVidia [HDA NVidia], device 0: ALC662 rev1 Analog [ALC662 rev1 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 rev1 Digital [ALC662 rev1 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
wolfgang@wolfgang-desktop:~$ lspci
00:00.0 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a1)
00:01.0 ISA bridge: nVidia Corporation MCP61 LPC Bridge (rev a2)
00:01.1 SMBus: nVidia Corporation MCP61 SMBus (rev a2)
00:01.2 RAM memory: nVidia Corporation MCP61 Memory Controller (rev a2)
00:02.0 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:02.1 USB Controller: nVidia Corporation MCP61 USB Controller (rev a3)
00:04.0 PCI bridge: nVidia Corporation MCP61 PCI bridge (rev a1)
00:05.0 Audio device: nVidia Corporation MCP61 High Definition Audio (rev a2)
00:06.0 IDE interface: nVidia Corporation MCP61 IDE (rev a2)
00:07.0 Bridge: nVidia Corporation MCP61 Ethernet (rev a2)
00:08.0 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:08.1 IDE interface: nVidia Corporation MCP61 SATA Controller (rev a2)
00:09.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0b.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:0c.0 PCI bridge: nVidia Corporation MCP61 PCI Express bridge (rev a2)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] HyperTransport Configuration
00:18.1 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Address Map
00:18.2 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] DRAM Controller
00:18.3 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Miscellaneous Control
00:18.4 Host bridge: Advanced Micro Devices [AMD] K10 [Opteron, Athlon64, Sempron] Link Control
02:00.0 VGA compatible controller: nVidia Corporation G84 [GeForce 8600 GT] (rev a1)
wolfgang@wolfgang-desktop:~$) It worked once but after reboot of the os there was no sound any more.

"Sound Preferences" shows on output only "Dummy output stereo")

In the manual I was told to edit the modules to have loaded the sound at boot time: "Copy and paste this to the bottom of your /etc/modules.conf or /etc/modprobe.conf file" Well I didn`t find any of this files. So I just created them and tried to copy it into the directory "etc". But the system denied to paste to those directory. Anyway it wouldn't have worked because I guess there is some other file competent to load the sound. I'm stuck now and would like to get some info of how to get rid of all of this restrictions. For the time beiing at least. And I would need to know what file in "etc" loads the sound. For any help I'm very grateful.

javanaut 12-31-2009 05:45 PM

Have you tried just plain "module" as a file name? (My case, I am using Ubuntu 8.10 on a 9-10yo laptop).

wolibern 01-01-2010 09:38 AM

Thanks. I have a file named modules but I can't edit it: "You do not have the permissions necessary to save the file. Please check that you typed the location correctly and try again."

EricTRA 01-01-2010 09:57 AM

Hello,

If you need to edit that file and any other files that need root permissions when logged in as a regular user, then put sudo in front of your command. The system will ask you for your user password and then grant you access if you are in the sudoers list.

Example:
Code:

sudo nano /etc/modules
Kind regards,

Eric

wolibern 01-13-2010 11:12 AM

Thank you! I made it - that is I could edit all that files I was to in the manual... but the sound still is dead. As I do all this experimentally probably I'm gonna install some other distribution of Linux. The new MANDRIVA 2010 seems to be fine...

svinoba 01-13-2010 11:46 AM

Hi,
1. Are you a member of 'audio' group?
2. Strange it may sound but I have read, tried and succeded by doing "chmod -R 777 /dev/snd".
3. You may also try alsamixer and see if anything is muted.


All times are GMT -5. The time now is 06:17 PM.