LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-14-2014, 01:03 PM   #1
TheMaskedMarvel
LQ Newbie
 
Registered: Jul 2014
Location: Grand Island, NY
Distribution: EarOS, Linux Mint 17, SuperX,
Posts: 5

Rep: Reputation: Disabled
Cool No Root File System. Please Correct This From The Partitioning Menu


I have a blank hard drive and am trying to install Linux Mint/Cinnamon 64bit, Version 17. I click "Install" and receive the error message "No Root File System. Please Correct This From The Partitioning Menu". Trying to find an answer for this issue has only resulted in ludicrous suggestions without any real instructions, as if nobody has ever had this issue. Please provide precise instructions on how to make a drive "root" / so I can install this OS. Thanks.

Last edited by TheMaskedMarvel; 07-14-2014 at 01:42 PM.
 
Old 07-14-2014, 03:04 PM   #2
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,260

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
At what stage in the installation does this happen? Have you already chosen the drive you want to use, or set up a partitioning layout?
 
Old 07-14-2014, 09:14 PM   #3
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,405

Rep: Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207
Generally the installer follows what it wants but asks you along the way.

At some point it should have set up your local hard drive. Did it do that and did you agree to some area being mounted by /root? Did you manually edit it to do some other task.

In some cases blank disks may fool the installer. You may have to create partitions and then reboot to the installer. (rare)
 
Old 07-14-2014, 10:14 PM   #4
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 6,872

Rep: Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249Reputation: 1249
There are several options in the Installation Type window. If you have selected "Something Else" as an option you would be required to select the partition to install to. The main window will show a list of partitions. You select one by clicking it with the mouse, then click Change just below the window and an Edit partiton window will open. There is a Mount point option and an entry box to the right with a down arrow. Click it and select / by mouse clicking and select OK.

You can see this in the tutorial below which also explains the installing. This specific tutorial explains using GPT partitioning also. If you don't use GPT, ignore that part but it does show how to edit partitions.

http://www.tecmint.com/install-linux-mint-17/
 
Old 07-17-2014, 12:52 PM   #5
TheMaskedMarvel
LQ Newbie
 
Registered: Jul 2014
Location: Grand Island, NY
Distribution: EarOS, Linux Mint 17, SuperX,
Posts: 5

Original Poster
Rep: Reputation: Disabled
Followed the instructions exactly for creating root, efi, swap and home and applied the settings. I then selected "Install Linux Mint". I get as far as selecting a network connection and then get a blank workspace with no partitions or hard drives to select. At that point clicking "Install" will simply return the error "No Root File System, Please Correct This From The Partitioning Menu". I have tried creating different ISO disks of the same version and still nothing.
 
Old 07-17-2014, 07:51 PM   #6
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,848

Rep: Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823
Did you (also) follow the guide for steps 17-22 ?. You have to do that for each partition - most importantly assign the mount point.
 
Old 07-17-2014, 10:31 PM   #7
EDDY1
LQ Addict
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 6,838

Rep: Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649Reputation: 649
Then you forgot to mark 1 of the partitions as bootable.
 
Old 07-18-2014, 06:20 PM   #8
TheMaskedMarvel
LQ Newbie
 
Registered: Jul 2014
Location: Grand Island, NY
Distribution: EarOS, Linux Mint 17, SuperX,
Posts: 5

Original Poster
Rep: Reputation: Disabled
The last screen I see before getting the error message "no root file system found" is "Preparing to Install Linux Mint". I never see the page "Installation Type". I will try it again in about a week when I return from vacation. Thanks for everyone's help and suggestions.
 
Old 07-18-2014, 06:23 PM   #9
TheMaskedMarvel
LQ Newbie
 
Registered: Jul 2014
Location: Grand Island, NY
Distribution: EarOS, Linux Mint 17, SuperX,
Posts: 5

Original Poster
Rep: Reputation: Disabled
I was able to install the disk image on another computer and didn't have to go through all of the preliminary steps to set up "device partitions" and "flags".
 
Old 07-18-2014, 06:35 PM   #10
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
i've seen a similar error before, usually it means you forgot to assign a partition a mount point of / (which is the 'root' filesystem
 
Old 07-18-2014, 06:47 PM   #11
suicidaleggroll
LQ Guru
 
Registered: Nov 2010
Location: Colorado
Distribution: OpenSUSE, CentOS
Posts: 5,260

Rep: Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948Reputation: 1948
Quote:
Originally Posted by TheMaskedMarvel View Post
I was able to install the disk image on another computer and didn't have to go through all of the preliminary steps to set up "device partitions" and "flags".
You should never have to do any of that on Mint, it's optional.
 
Old 07-18-2014, 06:59 PM   #12
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,200

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
Quote:
Originally Posted by suicidaleggroll View Post
You should never have to do any of that on Mint, it's optional.
that depends on the distribution, but yes, quite a few modern distributions do have a default partition setup that is used unless you explicitly tell the installer otherwise, ubuntu (and I guess mint) are two of them.
 
Old 07-18-2014, 09:57 PM   #13
jefro
Moderator
 
Registered: Mar 2008
Posts: 15,405

Rep: Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207Reputation: 2207
Could it be that you have multiple drives? Could it be that the /boot area is too far up in the drive?
 
Old 07-19-2014, 01:30 AM   #14
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 14,848

Rep: Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823Reputation: 1823
Well I don't know what's happening - I just deleted all the partitions on a laptop (my definition of "empty", but it does have a partition table).
Mint17 defaulted to "Erase disk and instal Mint" - and it did successfully.
 
Old 07-19-2014, 04:28 AM   #15
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Wheezy/Jessie/Sid, Linux Mint DE
Posts: 4,493

Rep: Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635Reputation: 635
The Mint installer asks you to assign a root partition after you changed the partitions. So when you see the partitions listed, right-click on the one you want to use for the root fs and choose "mount as /".

It is something I usually forget when installing Mint and it puzzled me as well. It is also a bit strange policy to ask this taking into account the user type Mint focuses at. I am not sure it is also asked when you leave the partition scheme as proposed by Mint. I changed it because Mint put the swap as first partition. I don't like that, I want sda1 to be /.

Another issue I had with Mint 17 not long ago was that Mint would not boot after installing from DVD. It ran OK as live distro, it installed OK without any error message. But large parts of the root fs were not installed. I received the same error message as the OP. After installing from USB the problem was solved. I blamed the DVD, although I was amazed that it is possible to run and install perfectly whithout any sign of reading errors, while apparently some files were damaged.

jlinkels
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
after expanding filesystem, system reports correct filesize but only root can write jonas_berlin Linux - General 6 01-15-2012 03:36 PM
No root file system is defined. Please correct this from the partitioning menu Stuck109 Linux - Newbie 11 04-29-2011 02:23 PM
Root File System Partitioning / Filesystems Simon Barkwell Linux - General 2 02-13-2010 08:13 PM
New system won't allow root after installation - using correct password and "root" kn2y Linux - Newbie 6 11-07-2008 08:52 PM
System time correct for root, wrong for normal user? dx0r515t Slackware 2 07-21-2006 06:30 PM


All times are GMT -5. The time now is 06:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration