LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 06-13-2001, 04:53 AM   #1
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Rep: Reputation: 0
Unhappy


Hi,

When in click on the cdrom or floppy icon on the desktop (Mandrake 8) I get an error "can't open local file /mnt/cdrom (or floppy)" You do not have the proper rights to access..."

even as root I have this problem. What's wrong?
 
Old 06-13-2001, 07:15 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Have you checked your permission settings? What about fstab, what do you have for your cdrom and floppy?
Post it here and we can see what's going on.
 
Old 06-13-2001, 02:40 PM   #3
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
permissions are read and write for the user.
the cdrom is nameless, no brand.
floppy is 1.44".

the exact error is: unable to enter file:/mnt/cdrom
You do not have access rights to this location.

and

the exact error is: unable to enter file:/mnt/floppy
You do not have access rights to this location.
 
Old 06-13-2001, 02:48 PM   #4
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
there's more

concerning fstab i get as root:

bash: /etc/fstab: Permission denied

go figure, then who has permission?
 
Old 06-13-2001, 03:14 PM   #5
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
If for some reason you can't access things via a normmal login, try starting up in single-user mode by typing "linux single" or "single" at the boot prompt. Also, there are some fine distinctions between logging in as root and "su"-ing to root. If you're becoming root via su, try logging in directly as root.
 
Old 06-13-2001, 08:25 PM   #6
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
Re: there's more

Quote:
Originally posted by happy hippo
concerning fstab i get as root:

bash: /etc/fstab: Permission denied

go figure, then who has permission?
Hmm, as I re-read that, I'm wondering: were you trying to run /etc/fstab as a command? It isn't an executable, its a config file. If you wan't to view it, type cat /etc/fstab. If you want to edit it, do vi /etc/fstab, but if you just typed /etc/fstab, you would get an error.
 
Old 06-14-2001, 12:48 PM   #7
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
here's my fstab:

/dev/hda8 / ext2 defaults 1 1
/dev/hda6 /boot ext2 defaults 1 2
none /dev/pts devpts mode=0620 0 0
/mnt/cdrom /mnt/cdrom supermount fs=iso9660,dev=/dev/cdrom 0 0
/mnt/floppy /mnt/floppy supermount fs=vfat,dev=/dev/fd0 0 0
/dev/hda5 /mnt/windows vfat user,exec,umask=0,codepage=850,iocharset=iso8859-1 0 0
none /proc proc defaults 0 0
/dev/hda7 /usr ext2 defaults 1 2
/dev/hda9 swap swap defaults 0 0
 
Old 06-14-2001, 02:12 PM   #8
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
what happens if you try to chmod the the access to your /mnt/cdrom to change the access, or what are your read-write access to this at this point for /mnt/cdrom?
Same goes for floppy. try a:
Code:
# chmod 777 /mnt/cdrom
same for /mnt/floppy.

this should at least test it and see if you still get permission denied.

As i re-read your original posting, you said you are clicking the icons on the desktop, what happens if you try to mount them from the terminal or command line?
 
Old 06-16-2001, 05:49 AM   #9
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
mounting cdrom and floppy in the command line gives a blank commandline as reply but the error message stays as i click the icons.
same goes for chmod, and the fstab doesn't change.
 
Old 06-17-2001, 12:49 AM   #10
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
It could be that you need to edit your fstab file and include ' user ' in your floppy and cdrom lines.

Like this:

/mnt/cdrom /mnt/cdrom supermount user,fs=iso9660,dev=/dev/cdrom 0 0
/mnt/floppy /mnt/floppy supermount user,fs=vfat,dev=/dev/fd0 0 0
 
Old 06-18-2001, 09:04 AM   #11
RGS
LQ Newbie
 
Registered: Jun 2001
Posts: 1

Rep: Reputation: 0

I've have a similar problem. I previously used 7.1
with no problems. On upgrading to 7.2 I've rec'd
access denied messages, etc. My copy was purchased
from Macmillian Sofware so I contacted Technical
Support. Please see reply below. I haven't tried it yet.

(Oh, and my Linux installation was made on a separate
ext2 partition on the C: drive.)


.----------------< NOTE >-----------------.
| |
| All correspondance with the support |
| team must go over web interface |
| |
`--< PLEASE DO NOT REPLY TO THIS EMAIL >--'

Hello,

Concerning your installation :

You should not install linux on your c: drive, you should rather resize your windows partition and let linyux create its own partitions.
We encounter some trouble with the supermount option.

you will have to disable it :

As root in a shell, type :

supermount -i disable
reboot
then you'll have to mount manually your devices :
for instance :
mount /dev/cdrom
umount /dev/cdrom

If you have a cd-writer :

Edit this file : /etc/fstab
locate your cd-writer's line (may be cdrom2)
change /dev/cdrom2 to /dev/scd0
save your changes.


Best regards,

The technical support team.




 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
permission for /mnt/cdrom bruse Mandriva 4 03-25-2005 12:17 PM
Formatting a floppy permission problem Oh Cisco Debian 17 08-18-2004 02:59 AM
permission to cdrom for users joshua Linux - Newbie 2 03-11-2004 03:27 PM
Floppy permission denied eagle8762 Linux - Distributions 2 07-18-2003 11:50 AM
Floppy disk access permission Stephanie Linux - General 1 10-10-2001 02:55 PM


All times are GMT -5. The time now is 07:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration