LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-27-2006, 06:23 PM   #1
HawkLawin
LQ Newbie
 
Registered: May 2006
Location: NorCal
Posts: 12

Rep: Reputation: 0
No network connection, no ip address on eth0


I have installed the Back Track 1.0 Final in my HDD. But I don't seem to be able to connect to my router/dhcp. First, I don't see eth0 when I type ifconfig. So I typed ifconfig eth0 up and I was able to see it now but no ip address. Can anyone help me?

TIA
 
Old 05-27-2006, 09:31 PM   #2
sdexp
Member
 
Registered: Sep 2003
Location: USA
Distribution: Ubuntu Linux
Posts: 103

Rep: Reputation: 15
You should make sure your network was set up, and that the needed packages are available. I see that your problem is not specific, so doing this is probably the best solution.
 
Old 05-28-2006, 01:04 AM   #3
HawkLawin
LQ Newbie
 
Registered: May 2006
Location: NorCal
Posts: 12

Original Poster
Rep: Reputation: 0
Hi, thanks for the reply. My network is setup properly. I have a dual boot system and when I boot on XP, everything is ok, I can browse the internet, ping my router or connect to my router, no problem. But when I boot to Back Track, I don't have the connection at all. My layer 1 is ok, I can see the orange light on my NIC on.

Quote:
Originally Posted by sdexp
You should make sure your network was set up, and that the needed packages are available. I see that your problem is not specific, so doing this is probably the best solution.
 
Old 05-28-2006, 12:47 PM   #4
pansarevaibhav
Member
 
Registered: Oct 2005
Location: mumbai
Posts: 34

Rep: Reputation: 15
hi,
ur ip is set in /etc/network-script/ifcfg-et0 file , check there , if it is dhcp check whether u set ur pc to dhcp enable?
thanks
 
Old 05-28-2006, 01:14 PM   #5
Panagiotis_IOA
Member
 
Registered: Jan 2006
Location: Hellas, Europe
Distribution: Slackware 12
Posts: 238

Rep: Reputation: 32
If eth0 is not running then you need to type:

Code:
ifconfig eth0 up
If you just don't have the IP address and the IP has to be taken automatically from the ISP then, in Slackware for example, you have to run the script rc.inet1 This is located under /etc/rc.d and should run when the system loads.

If you want to give a certain IP to your Ethernet then you need to ype:

Code:
ifconfig eth0 xxx.xxx.xxx.xxx
 
Old 05-28-2006, 11:01 PM   #6
pokemaster
Member
 
Registered: Apr 2005
Location: Massachusetts, USA
Distribution: debian,ubuntu,slackware
Posts: 110

Rep: Reputation: 17
I'm guessing your network uses dhcp -- since you have a router and XP 'just works'. try this:
Code:
ifconfig eth0 up
dhcpcd eth0
if that doesn't give you anything,
Code:
dhclient eth0
 
Old 06-02-2006, 10:10 PM   #7
saveme
LQ Newbie
 
Registered: May 2006
Location: boardman ohio
Distribution: debian sarge
Posts: 16

Rep: Reputation: 0
eth0

thanks the dhclient worked for me. I have debian sarge. Now all i have to do is config apt thru base-config. hopefilly

Last edited by saveme; 06-02-2006 at 10:16 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 is up but no network connection? yednotek Linux - Newbie 4 04-01-2006 04:21 PM
Wireless network on eth1 diabled Ethernet eth0 and eth0 never comes back tadatoshi Linux - Wireless Networking 4 09-23-2004 06:57 PM
My eth0 won't get an IP address on my LAN poeta_boy Linux - Networking 4 01-29-2004 04:00 PM
Should i use the eth0 ip address of my internet ip address when applying iptables ForumKid Linux - Security 2 01-03-2002 09:54 AM


All times are GMT -5. The time now is 10:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration