LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-13-2009, 05:56 PM   #1
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Rep: Reputation: 15
No network connection after Debian install


Hello,

Iīve installed Debian 5.0 with xfce and the problem is that the system wonīt connect to the network (Internet), i.e. webbrowsers wonīt display any pages and I canīt "apt-get" anything from web depositories.

My network card is Realtek RTL8139/810x Family Fast Ethernet NIC
My connection is wired - broadband (automatic IP) - using router

The outputs of ifconfig commands are posted here

How can I get the network connection working?

Last edited by navy80; 04-13-2009 at 06:21 PM.
 
Old 04-14-2009, 12:10 AM   #2
Robhogg
Member
 
Registered: Sep 2004
Location: Old York, North Yorks.
Distribution: Debian 7 (mainly)
Posts: 653

Rep: Reputation: 85
Looking at those screenshots, the problem doesn't look like it lies in the network card or low-level networking - you have an IP address, default gateway is set, and you have DNS resolution (otherwise ping www.google.co.uk would not work).

Looking at the IP address, though (in the 10.*.*.* range - home routers tend to use 192.168.*.* on their internal interfaces), I'm wondering: are you on a corporate or university network? Do you need to set a proxy address in your browser?
 
Old 04-14-2009, 12:28 AM   #3
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
First thing I would do is fix your netmask, yes what you have will work, but it's just not proper, and could cause issues

Your Current Config (with an 8 bit netmask)
Code:
IP Address:  10.1.1.4
Netmask :    255.0.0.0
Gateway:     10.1.1.1
Broadcast:   10.255.255.255
You should really subnet that class A address (with a 24 bit netmask) like so.

Code:
IP Address:  10.1.1.4
Netmask :    255.255.255.0
Gateway:     10.1.1.1
Broadcast:   10.1.1.255
I still think it would be a good idea if you tried disabling IP6 support as I suggested earlier..
http://www.debian-administration.org/articles/409

Could you post the output of the following commands ?
(I'm going to list a few just so we don't have to go back and forth)


cat /etc/resolv.conf

lspci | grep -i eth

cat /var/log/dmesg | grep -i eth0

lsmod | grep 81





ref
 
Old 04-14-2009, 02:25 AM   #4
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
oeps, disable ipv6 was already suggested.

Last edited by repo; 04-14-2009 at 02:37 AM. Reason: made wrong suggestion
 
Old 04-14-2009, 05:18 AM   #5
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Robhogg View Post
Looking at those screenshots, the problem doesn't look like it lies in the network card or low-level networking - you have an IP address, default gateway is set, and you have DNS resolution (otherwise ping www.google.co.uk would not work).

Looking at the IP address, though (in the 10.*.*.* range - home routers tend to use 192.168.*.* on their internal interfaces), I'm wondering: are you on a corporate or university network? Do you need to set a proxy address in your browser?
Good morning from Brazil,
I use a router that I share with other five residents of our building. Windows get the setting automatically and I donīt need to set a proxy address.
 
Old 04-14-2009, 05:22 AM   #6
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
I use a router that I share with other five residents of our building. Windows get the setting automatically and I donīt need to set a proxy address.
Then set your box to uset DHCP, so you recieve the IP's from the router.
Also, did you disabled ipv6 ?
 
Old 04-14-2009, 07:01 AM   #7
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Original Poster
Rep: Reputation: 15
SUCCESS! JOB DONE!

The network started to work after I disabled the IP6.

Many thanks to Repo and farslayer!

Best regards from Iceweasel!
 
Old 04-14-2009, 07:29 AM   #8
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Original Poster
Rep: Reputation: 15
I can access the Internet via the browser, but I still can't apt-get update successfully, it just keeps diplaying "connecting...".

My sources.list is as follows:

Code:
# deb cdrom:[Debian GNU/Linux 5.0.0 _Lenny_ - Official i386 xfce+lxde-CD Binary$

#deb cdrom:[Debian GNU/Linux 5.0.0 _Lenny_ - Official i386 xfce+lxde-CD Binary-$

deb http://ftp.us.debian.org/debian/ lenny main
#deb-src http://ftp.us.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main
#deb-src http://security.debian.org/ lenny/updates main

deb http://volatile.debian.org/debian-volatile lenny/volatile main
#deb-src http://volatile.debian.org/debian-volatile lenny/volatile main
 
Old 04-14-2009, 08:22 AM   #9
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Can you browse to the site in your sources list using Iceweasel ?
http://ftp.us.debian.org/debian/

I wonder if the issue could be the way the router handles forwarding DNS.. What is the output of:
cat /etc/resolv.conf

If it's 10.1.1.1, try editing the DNS on your local machine and entering the IP addresses of your ISP's DNS server instead.. I see a couple threads stating that some routers just don't forward properly causing internet connectivity issues.
 
Old 04-14-2009, 11:53 AM   #10
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by farslayer View Post
Can you browse to the site in your sources list using Iceweasel ?
http://ftp.us.debian.org/debian/

I wonder if the issue could be the way the router handles forwarding DNS.. What is the output of:
cat /etc/resolv.conf

If it's 10.1.1.1, try editing the DNS on your local machine and entering the IP addresses of your ISP's DNS server instead.. I see a couple threads stating that some routers just don't forward properly causing internet connectivity issues.
I can browse to the site using Iceweasel, not a problem.

The output of cat /etc/resolv.conf is 10.1.1.1 so it looks you're right (again). Can you help me with the steps I need to make now - I'm a newbie to this part of Linux.
 
Old 04-14-2009, 12:15 PM   #11
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
open a terminal window and su - to root

su -

Edit the /etc/resolv.conf file
nano /etc/resolv.conf

nameserver 10.1.1.1

change the IP address to the IP address of your ISP's DNS Server replacing the IP address of your router.

CTRL + O to save the Changes
CTRL + X to exit the editor.

aptitude update
aptitude install nscd
/etc/init.d/nscd restart


If that works, and you can now update then we need to look at making that change to your DNS server setting permanent.
 
Old 04-14-2009, 01:20 PM   #12
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by farslayer View Post
open a terminal window and su - to root

su -

Edit the /etc/resolv.conf file
nano /etc/resolv.conf

nameserver 10.1.1.1

change the IP address to the IP address of your ISP's DNS Server replacing the IP address of your router.

CTRL + O to save the Changes
CTRL + X to exit the editor.

aptitude update
aptitude install nscd
/etc/init.d/nscd restart


If that works, and you can now update then we need to look at making that change to your DNS server setting permanent.

GREAT SUCCESS!! It worked!

Can you help me making settings permanent please.
 
Old 04-14-2009, 03:04 PM   #13
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,232
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
OPTION 1
Edit your /etc/dhcp3/dhclient.conf file and add a line to prepend the dns server info. .


Code:
#send host-name "andare.fugue.com";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
prepend domain-name-servers 192.168.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
	domain-name, domain-search, host-name,
	netbios-name-servers, netbios-scope, interface-mtu,
	rfc3442-classless-static-routes;
Basically you are telling the client to ignore the DNS Server values offered by the DHCP server and use the value you specify instead.

OPTION 2
Alternately you could fix the values handed out by your DHCP server, if you manage the router.


OPTION 3
Another option would be to configure a static IP address for the Interface, and not worry about what DHCP is offering.

to do this you would edit your /etc/network/interfaces file

Code:
auto eth0
iface eth0 inet static
address 10.1.1.200
netmask 255.0.0.0
gateway 10.1.1.1
network 10.0.0.0
broadcast 10.255.255.255
And of course your /etc/resolv.conf would contain what it currently does.


I still don't like the 8 bit mask, but if you are not the one that manages the router, I guess there's not much we can do about it.
 
Old 04-14-2009, 04:24 PM   #14
navy80
Member
 
Registered: Apr 2009
Location: Salvador, Brazil
Distribution: Ubuntu 9.10
Posts: 38

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by farslayer View Post
OPTION 1
Edit your /etc/dhcp3/dhclient.conf file and add a line to prepend the dns server info. .


Code:
#send host-name "andare.fugue.com";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
prepend domain-name-servers 192.168.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
	domain-name, domain-search, host-name,
	netbios-name-servers, netbios-scope, interface-mtu,
	rfc3442-classless-static-routes;
Basically you are telling the client to ignore the DNS Server values offered by the DHCP server and use the value you specify instead.

OPTION 2
Alternately you could fix the values handed out by your DHCP server, if you manage the router.


OPTION 3
Another option would be to configure a static IP address for the Interface, and not worry about what DHCP is offering.

to do this you would edit your /etc/network/interfaces file

Code:
auto eth0
iface eth0 inet static
address 10.1.1.200
netmask 255.0.0.0
gateway 10.1.1.1
network 10.0.0.0
broadcast 10.255.255.255
And of course your /etc/resolv.conf would contain what it currently does.


I still don't like the 8 bit mask, but if you are not the one that manages the router, I guess there's not much we can do about it.
UPS! The system wonīt boot now...

What happened is: I did the step #1. After that I restarted the system, however apt-get update did not work.

So I did the step #3 (took away the content of /etc/network/interfaces and put in what you suggested).

Then, I restarted, but the system wonīt boot now. It stops on the line "Starting NFS common utilities: statd".

PS - regards from Windows.
 
Old 04-14-2009, 04:27 PM   #15
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,516

Rep: Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896Reputation: 896
Quote:
Then, I restarted, but the system wonīt boot now. It stops on the line "Starting NFS common utilities: statd".
try to press CTRL_C
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian etch network connection issue HCLPfan Linux - Software 25 05-12-2009 07:46 PM
Problem with network connection in debian cola Debian 2 04-09-2009 12:51 PM
Network: Debian and Realtek ethernet connection problem ferentix Linux - Newbie 2 10-05-2007 01:17 PM
No Network Connection With Debian al042077 Linux - Networking 2 06-26-2005 12:39 AM
Debian losing network connection thijser Debian 3 05-14-2005 05:03 PM


All times are GMT -5. The time now is 01:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration