LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-08-2006, 02:38 PM   #1
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Rep: Reputation: 135Reputation: 135
No more display when graphic drivers installed


Hi, I'm quite new to Linux, and have a major problem : If I install the Drivers for my graphic card (Ge Force FX 5700LE), and let the x.conf file be modified by the installer, my display goes black, and even after reboot, the moment the dm service starts, I get nothing. If I leave the drivers selected automatically at the installation, I get display, but the maximal resolution I can use is 1280x1024, whilst my screen is made for 1600x1200 (I select the right screen at the installation). If I put the resolution the Dell 2001FP (connected via DVI) is made for, I get an image exceeding the sreen, and that scrolls when I touch the border. I also don't have any 3D, thus not 1 game works (even with cedega).

To save my installation, i'd need the path to access the x.conf file please...

Thanks in advance
 
Old 03-08-2006, 04:20 PM   #2
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,547

Rep: Reputation: 212Reputation: 212Reputation: 212
The path to the graphics configuration files is:

/etc/X11/xorg.conf
 
Old 03-09-2006, 07:06 AM   #3
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Original Poster
Rep: Reputation: 135Reputation: 135
Thanks kilgoretrout, I managed to get my display back up again, with no openGL direct rendering, and no 3D acceleration (source : cedega), as it was before, running the generic drivers that came with mandriva 2006. I found out that if I do modprobe nvidia, I get this :
FATAL : error inserting nvidia (/lib/modules/2.6.12-12mdk/kernel/drivers/video/nvidia.ko) : Invalid module format.
If I understand this right, the nvidia kernel module cannot be loaded, and that'd explain why I don't get any display. Could anyone help me by telling me how to make the kernel module right?
 
Old 03-09-2006, 03:18 PM   #4
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,547

Rep: Reputation: 212Reputation: 212Reputation: 212
That error message is almost always an indication that the kernel source you installed doesn't match the the kernel you are running. The kernel will refuse to load a module compiled against some other kernel source. Open a console and run:

$ rpm -qa | grep kernel

and post the output here. The above will list all the rpms installed with the word "kernel" in the package name. Unless you are familiar with the naming conventions, getting the right kernel source installed can be tricky.
 
Old 03-10-2006, 10:32 AM   #5
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Original Poster
Rep: Reputation: 135Reputation: 135
Ok, I entered the command in the konsole and the output is :
-kernel-source-2.6-2.6.12-12mdk
-kernel-2.6.12-2mdk

I also did some research in my file system, and found out that the nvidia nvidia file modprobe was trying to load had a different extension than the modules around (I suppose they're modules) : it ended only with *.ko, whilst the others ended with *.ko.gz. I tried renaming the file and then runnning modprobe, it was still looking for the nvidia.ko file, which didn't exist, since it had been renamed to nvidia.ko.gz.
May this be the source of the problem?
 
Old 03-10-2006, 10:43 AM   #6
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi serafean, if modprobe nvidia fails, this means that in fact you dind't build the kernel module. The most likely problem is that you have a mismatch on the current kernel you are running and the kernel sources you have installed.

Quote:
Originally Posted by serafean
Ok, I entered the command in the konsole and the output is :
-kernel-source-2.6-2.6.12-12mdk
-kernel-2.6.12-2mdk
From your last post you have the kernel sources of 2.6.12-12mdk. Now you have to know your current kernel, type

Code:
uname -r
if you are running a different kernel, then install the correct kernel source that matches your kernel.

Once you have this corrected, try to build again the kernel module nvidia.
 
Old 03-10-2006, 03:16 PM   #7
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Original Poster
Rep: Reputation: 135Reputation: 135
Thanks for the advice, I did as you said and got this
Quote:
2.6.12-12mdk
It seems to me, correct me if I'm mistaken, that the kernel source name and the kernel name are the same.
And how can I build the kernel module?
 
Old 03-10-2006, 03:47 PM   #8
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi serafean, you can find many tutorials on the web on how to install Nvidia drivers, in short you have to follow these steps:

1. Download the latest nvidia driver 1.0-8178 http://www.nvidia.com/object/unix.html
2. Open a console and change to root
Code:
su 
Paswword: (type root password)
3. Type:
Code:
init 3
4. Go to the directory where you saved the nvidia driver and type:
Code:
sh NVIDIA-Linux-x86-1.0-8178-pckg1.run
5. Follow the instructions, you have to accept the license agreement, the installer will try to download the driver, most of the times will fail, don't panic just continue. At this moment it will build the kernel module. If it ends with a warning that couldn't build the module, you can post the content of the file /var/log/nvidia-installer.log
6. If the installations finished without other warning you have available the nvidia kernel module, in order to use it you have to load it, type:
Code:
modprobe nvidia
if you end in a prompt when you hit enter, it means that the module was loaded.
7. Finally, edit the file /etc/X11/xorg.conf, you can use the command:
Code:
xorgconfig
You have to select the driver "nvidia" when asked, you can also choose the resolution you want. Check carefully the specs of your monitor.
8. Type:
Code:
startx
9. If you want to know if you have 3D acceleration enabled, type in a console:
Code:
glxinfo

Last edited by victorh; 03-10-2006 at 03:49 PM.
 
Old 03-11-2006, 08:21 AM   #9
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Original Poster
Rep: Reputation: 135Reputation: 135
Thanks, now I have an nvidia module that works by the prompt, but still no 3D. If I enter glxinfo, I get this :
Code:
Xlib : connection to "0.O" refused by server
Xlib : no protocol specified

Error : Unable to open display(null)
And I still can't give my screen the right resolution (1600*1200) else I have a scrolling desktop... Is this still related to the graphic drivers or is it another problem?
 
Old 03-11-2006, 10:37 AM   #10
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Original Poster
Rep: Reputation: 135Reputation: 135
I got the idea that rebooting might help, but instead, I now get :
Code:
name of display: :0.0
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x21 24 tc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
0x22 24 dc  1  0  0 c  .  .  0  0  0  0  0  0  0  0  0  0  0  0 0 None
to be sincere, I must say I don't understand any of it, and will be very thankful for any translation into a normal language, possibly a solution to the problem.
 
Old 03-11-2006, 03:19 PM   #11
victorh
Member
 
Registered: Jul 2005
Location: La Paz, Bolivia
Distribution: Debian Sarge - Sid, Slackware, Gentoo, openSuse, Fedora, Ubuntu, Mandriva
Posts: 241

Rep: Reputation: 30
Hi serafean, it seems that you don't have the module loaded yet, or you have some problem with the installation.

Did you follow all the steps while installing?, Did you notice something wrong?

What happened when you type "modprobe nvidia"?

Use the command lsmod to list all the modules loaded in your system, login in a console as root and type:

Code:
# lsmod | grep nvidia
You should see a line with the module nvida.

If you have installed successfully the module, you have to add a line in the file /etc/modules, with the module name:
Code:
nvidia
This will load the module at boot time.

Finally, when you reboot your system, you should see a banner with the logo of Nvidia. Another sign that you have the driver installed.
 
Old 03-12-2006, 08:37 AM   #12
kilgoretrout
Senior Member
 
Registered: Oct 2003
Posts: 2,547

Rep: Reputation: 212Reputation: 212Reputation: 212
I think your nvidia module is probably loaded. This is the key:

Quote:
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't find RGB GLX visual
Look in your xorg.conf file in the "Module" section and for a line like:

Load "glx" # 3D layer

If it exists, sometimes you have to give the full path to libglx.so instead of just "glx". You can find that by running:

$ slocate libglx.so
/usr/X11R6/lib/modules/extensions/libglx.so
/usr/X11R6/lib/modules/extensions/libglx.so.1.0.7676

Try inserting whatever path to libglx.so is revealed by your search in quotes in the above xorg.conf line.

If that doesn't work, post back. The results of your rpm query and uname don't appear to match to me, i.e. the rpm -qa command shows a mismatched kernel and kernel source while the uname command indicates a match. I still think there might be a kernel source mismatch problem.
 
Old 03-17-2006, 08:30 AM   #13
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 952
Blog Entries: 14

Original Poster
Rep: Reputation: 135Reputation: 135
Victorh, I haven't noticed anything wrong during the installation, but when I modprobe nvidia, I get this :
Code:
# modprobe nvidia
insmod /lib/modules/2.6.12-12mdk/kernel/drivers/video/nvidia.ko
FATAL: Error inserting nvidia (/lib/modules/2.6.12-12mdk/kernel/drivers/video/nvidia.ko): Invalid module format
This had dissapeared for some time, but it's back again. Here's what lsmode does :
Code:
# lsmod|grep nvidia
#
I also added "nvidia" to the modules file, and it's done nothing except mess up the computer so that it used 100% of the CPU non-stop, and still looking for something on the disk.

kilgoretrout, I added the complete path to libglx.so, but it has done absolutely nothing.
Seeing your scepticism about my kernels, I'd like to ask if there iss any way of proving that mismatch, apart from the commands I've already tried.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
linux mandrake, i can't go to the graphic display bezae Mandriva 3 10-20-2004 01:16 AM
Installed NVIDIA drivers - now display seems blurry Bluesuperman Slackware 6 10-06-2004 07:18 PM
Slow graphic display Beju Linux - Newbie 2 12-26-2003 04:43 PM
Display Problem exiting X with Nvidia drivers installed basemodel Slackware 4 10-25-2003 10:48 AM
AAA!! I installed nVidia drivers on Red Hat 8 and it can't init display! orange400 Linux - General 19 03-20-2003 01:08 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 07:58 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration