LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-17-2004, 09:58 PM   #1
techhost
LQ Newbie
 
Registered: Mar 2004
Posts: 20

Rep: Reputation: 0
no kde at boot


how do i change my boot options? i want to boot in text mode rather into X i am useing redhat 9
 
Old 05-17-2004, 10:57 PM   #2
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
change the default runlevel in /etc/inittab from 5 to 3. cheers
 
Old 05-18-2004, 07:27 AM   #3
techhost
LQ Newbie
 
Registered: Mar 2004
Posts: 20

Original Poster
Rep: Reputation: 0
ok great thats what i needed. now if i start kde from a command line and then i want to exit it how would i do that?

carey
 
Old 05-18-2004, 07:33 AM   #4
sbogus
Member
 
Registered: May 2004
Location: Germany, Munich
Distribution: SuSE Pro Releases 7.3, 9.0, CentOS 4.0, Kubuntu 6.0x
Posts: 103

Rep: Reputation: 15
Hi techhost,

this is very simple - just rightclick on the desktop and choose "Logout <username>" from the context menu. The click on the Ok button in the small dialog box and you're off your KDE.

Kind regards,
sbogus
 
Old 05-18-2004, 07:16 PM   #5
techhost
LQ Newbie
 
Registered: Mar 2004
Posts: 20

Original Poster
Rep: Reputation: 0
and this will drop me back to text mode?
 
Old 05-18-2004, 07:46 PM   #6
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
Yes. So will ctrl+alt+backspace or opening a terminal window and typing "telinit 3" (but don't do that,it'll log you out too.

You'd only stay in GUI if you have a desktop manager running like KDM, GDM, or XDM, which you don't.
 
Old 05-18-2004, 09:46 PM   #7
techhost
LQ Newbie
 
Registered: Mar 2004
Posts: 20

Original Poster
Rep: Reputation: 0
cool thanks alot
 
Old 06-16-2004, 07:41 PM   #8
ahimsel08
LQ Newbie
 
Registered: Jun 2004
Posts: 28

Rep: Reputation: 15
hey, when i use

startx i boot into my gnome desktop.. how do i boot into KDE?
 
Old 06-16-2004, 08:37 PM   #9
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
try "startkde"
 
Old 06-17-2004, 01:43 AM   #10
ahimsel08
LQ Newbie
 
Registered: Jun 2004
Posts: 28

Rep: Reputation: 15
ouch. errors:
on input 'startkde'
output:

rm: cannot remove '.' or '..'
rm: cannot remove '.' or '..'
xsetroot: unable to open display ''
xrdb: cannot open display ''
xset: unable to open display " "
startkde: Starting up...
kspalsh: cannot connect to X server
kdeinit: Aborting $DISPLAY is not set
Warning: connect() faild: no such file or directory
Error: Cannot contact kdeinit!
unix_connect: cant connect to server (unix:/tmp/mcop-root/WinXP-RH9-0c0e-40d0984c)
startkde: running shutdown scripts
startkde: done

hash>



umm... what to do?

and yeah i'm sure i installed KDE when i installed the OS
 
Old 06-17-2004, 02:48 AM   #11
mrcheeks
Senior Member
 
Registered: Mar 2004
Location: far enough
Distribution: OS X 10.6.7
Posts: 1,690

Rep: Reputation: 51
command : which kde
answer : locationofkde
kde launch : startx /kdelocation/startkde --:0

which startkde instead of which kde

Last edited by mrcheeks; 06-17-2004 at 02:50 AM.
 
Old 06-17-2004, 02:48 AM   #12
dalek
Senior Member
 
Registered: Jul 2003
Location: Mississippi USA
Distribution: Gentoo
Posts: 2,058
Blog Entries: 2

Rep: Reputation: 79
ahimsel08, type in this:

Code:
ls -l /usr
It should have one in there called kde. If it does not, you don't have KDE installed yet. It appears that you don't but that should help make sure. Like this:

Code:
drwxr-xr-x    3 root  root     72 Mar 22 10:38 kde
Oh, that is <lower case L>s - <lower case L><space> /usr. They look like the number one somethimes. Newbies, I was one at one time, get that confused and it won't work.

Later

 
Old 06-17-2004, 08:21 AM   #13
vectordrake
Senior Member
 
Registered: Nov 2003
Location: NB,Canada
Distribution: Something alpha or beta, binary or source...
Posts: 2,280
Blog Entries: 4

Rep: Reputation: 47
That command may execute if its in your .xinitrc file. See if you have one in your home directory (ls -a). Edit it by adding "exec startkde" and save. That may work.
 
Old 06-17-2004, 01:54 PM   #14
ahimsel08
LQ Newbie
 
Registered: Jun 2004
Posts: 28

Rep: Reputation: 15
nope, no kde when doing that command
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't get it to boot into KDE Illidan SUSE / openSUSE 2 08-16-2005 01:42 AM
Getting KDE to boot rather than X and... Z33K Linux - Newbie 5 11-22-2004 03:59 PM
Cannot get KDE to boot up (MDK10.0) kaykills Linux - Newbie 2 09-16-2004 07:56 PM
KDE at boot KoKi Slackware 3 03-11-2004 11:55 AM
[REDHAT KDE] Disable KDE boot? Apache down after 10min losing monitor signal bjwesselink Linux - Software 2 08-11-2003 01:52 PM


All times are GMT -5. The time now is 10:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration