LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 06-30-2011, 08:26 AM   #1
linuxandtsm
Member
 
Registered: May 2011
Posts: 191

Rep: Reputation: Disabled
No Java runtime environment (JRE) error


Hi all,

I am trying to install a .bin file for that it requires IBMJava2-AMD64-142-JRE-1.4.2-13.8.x86_64.rpm to be installed. I have installed this rpm but when i try to install .bin file, it complains that no JRE found. How to solve this. Thanks in advance!




Code:
[root@linx1 admin]# ./5.4.1.1-TIV-TSMORA-LinuxX64.bin
 
          Initializing Wizard........
          Verifying JVM........
 
 No Java Runtime Environment (JRE) was found on this system.

 
[root@linx1 admin]# rpm -qa |grep IBM
IBMJava2-AMD64-142-JRE-1.4.2-13.8
 
[root@linx1 ~]# find / -iname java -print 2>/dev/null
/opt/IBMJava2-amd64-142/jre/bin/java

[root@linx1 ~]# find / -iname jre -print 2>/dev/null
/opt/IBMJava2-amd64-142/docs/jre
/opt/IBMJava2-amd64-142/jre
 
Old 06-30-2011, 08:55 AM   #2
narkaulov
LQ Newbie
 
Registered: May 2008
Location: Helsingborg, Sweden
Distribution: slamd64 (Slackware), Fedora Core, Arch Linux
Posts: 3

Rep: Reputation: 0
Sounds like you need to add the path to the JRE to your $PATH variable. You can do this by adding something along the lines of the following to your .bashrc file.
PATH=$PATH:/path/to/jre

You will need to log out and back in after making the change.
 
Old 06-30-2011, 09:06 AM   #3
linuxandtsm
Member
 
Registered: May 2011
Posts: 191

Original Poster
Rep: Reputation: Disabled
Hi narkaulov,

I set the path but still have the same problem.

[root@linx1 admin]# PATH=$PATH:/opt/IBMJava2-amd64-142/jre
[root@linx1 admin]# export PATH

[root@linx1 admin]# echo $PATH
/usr/kerberos/sbin:/usr/kerberos/bin:/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/root/bin:/opt/:/opt/IBMJava2-amd64-142/jre
[root@linx1 admin]# ./5.4.1.1-TIV-TSMORA-LinuxX64.bin

Initializing Wizard........
Verifying JVM........

No Java Runtime Environment (JRE) was found on this system.
 
Old 06-30-2011, 10:07 AM   #4
linuxandtsm
Member
 
Registered: May 2011
Posts: 191

Original Poster
Rep: Reputation: Disabled
Solved by setting path as below

PATH=/opt/IBMJava2-amd64-142/jre/bin:$PATH
export PATH

thanks!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Java Woes: A Java Runtime Environment (JRE) or Java Development Kit (JDK) must be available ... chytraeus Slackware 10 11-27-2010 10:04 AM
Java Runtime Environment (JRE) 5.0 Update 16 cccc Debian 1 11-06-2008 09:58 AM
LXer: How to Install Java Runtime Environment (JRE) in Ubuntu LXer Syndicated Linux News 0 04-20-2007 12:33 AM
Intalling JRE (Java Runtime Environment) in Ubuntu depam Linux - Software 3 02-09-2006 01:09 PM
Removal of Java Runtime Environment (JRE) scottpioso Linux - Software 5 06-03-2003 06:44 AM


All times are GMT -5. The time now is 05:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration