LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-21-2007, 12:34 PM   #1
matuk_444
Member
 
Registered: Aug 2005
Posts: 133

Rep: Reputation: 15
No internet with Sabayon Linux


Hi,

I installed Sabayon 3.3 as a fresh install as it is not possible to upgrade. I booted into it fine for the first time and did a load of admin. I logged into it now and on start up I received the error message

FATAL: cannot load /System.map File not found

So something similar. I went in and found that although I could read CDs I now no longer had internet.

What is going on?

Mat
 
Old 03-23-2007, 03:09 AM   #2
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
Quote:
and did a load of admin.
Sound like problem was there...

Quote:
FATAL: cannot load /System.map File not found

So something similar
We need the exact message including / and :

system.map is a kernel thing

either you reinstall and do the admin step by step until you break it,
or we go down the line
- check nic card driver
(see command lsmod and lspci)
- check iptables / firewall

you can look in man pages of iptables and the flush command that would disable the firewall and see if the connection is there. Then re-enable firewall

also see route -n and check /etc/resolv.conf

try also ping -c3 www.somting.com
try to ping a known host xxx.xx.xx.xx in digital notation

AM no gentoo user so cannot help much
but report all that and am sure sbdy will help
 
Old 04-02-2007, 01:41 PM   #3
qedqubit
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
greetingz !
I also have no internet with sabayon linux !
i've installed it on my FreeBSD athlon and a friends Toshiba laptop
both will ping to google, but neither will display google !
anybody know what going on ?
 
Old 04-03-2007, 01:24 AM   #4
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
if you can ping then it means
you do not have dns servers registered in /etc/resolv.conf

http://www.die.net/doc/linux/man/man...lv.conf.5.html

just add something of the like
nameserver xxx.xx.xx.xx
nameserver xxx.xx.yy.xx

where xxx.xx.xx.xx is the DNS server of your ISP
(or any DNS for that matter)
 
Old 04-22-2007, 07:47 PM   #5
qedqubit
LQ Newbie
 
Registered: Apr 2007
Posts: 2

Rep: Reputation: 0
thnx !
ive tried about 4 dns numbers, 2 directly out the router onto the net, and 2 via the vpn through the FreeBSD systems of a friend of mine who does networx for a cablecompany, he looked for about 10 minutes & couldn't find what's wrong, and the toshiba laptop i tried was somewhere else, installed from another sabyon dvd.
Too bad sabayon directs questions to gentoo or this place, if it is a sabayon problem, and not my fault.A great system might break on such a small -but important- detail.
any sabayon devvers out here ?
THNX in advance for helping noob-newbies like me it greatly appreciated !
 
Old 04-22-2007, 07:56 PM   #6
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Well, Sabayon is nothing more than a precompiled Gentoo so it's hardly surprising those people should direct you to Gentoo forums. As for the DNS numbers you tried, you did try those of your ISP? I know it's a stupid question, I just want to make sure.

That being said, I recently installed Gentoo (it's been ten days and I'm still working on it) and I ran into similar issues. There appears to be a bug around that prevents dhcp to function correctly. In my case, the workaround was to issues this command:

dhcpcd eth0

I had to do that every time I rebooted until the issue somehow got solved after emerging some updates and additional software.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
loss of internet with sabayon linux matuk_444 Linux - Newbie 6 03-07-2007 05:12 PM
LXer: Review: Sabayon Linux LXer Syndicated Linux News 0 02-09-2007 07:54 AM
Sabayon Linux !!!! Darksurf Linux - Distributions 10 12-17-2006 07:37 PM
Cant set up Dialup Internet on Sabayon 3.1! sabayon_linux Linux - General 2 10-30-2006 12:47 AM
Sabayon linux conanm4 Linux - Distributions 5 09-01-2006 09:00 AM


All times are GMT -5. The time now is 11:59 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration