LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2008, 03:38 AM   #1
goroku
LQ Newbie
 
Registered: May 2008
Posts: 4

Rep: Reputation: 0
Question No internet after changing countries


I moved from europe to Japan and find that my suse 10.3 does not connect to the internet here when I plug in the dsl cable.

I suppose there is something that needs to tbe changed in the setting? I am not very good at such things, could someone please tell me where to look for a description of the necessary procedure???

Thanks
 
Old 05-04-2008, 04:17 AM   #2
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
If you can, first check if the router/modem really connects to an/your ISP's services; if it doesn't (because it's your old one from Europe), get another one in a local store or have someone tell you what settings to - maybe you're still trying to log in using your old settings for the European ISP, which is bound to fail (it's like trying to call a local phone number without using the country code when you're abroad). And one more thing: Don't(!) try to re-connect to your old ISP, either, or you might be able to log in - but using long distance phone lines at minimal speeds and maximum expenses!

As soon as the router/modem is connected and things still don't work: Does the router or modem provide an IP for your system? If not, you need to activate the "DHCP server" side of that router/modem and switch to "Get IP using DHCP" (or "automatically") on your system (I've used quotes because I don't know how this information will be presented on the systems you're using).

To find out if your system has an IP or not, open a terminal, be root (from the terminal, using "su" - don't log into the system as root) and type "ifconfig". If you don't get another IP than 127.0.0.1 (for a device called "lo"), you're not connected. I find this way easier than using dozens of clicks through various tools. But then, those tools are bound to be there - it's your choice.

M.
 
Old 05-04-2008, 07:46 PM   #3
goroku
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you MoonMind

Quote:
Originally Posted by MoonMind View Post
If you can, first check if the router/modem really connects to an/your ISP's services; if it doesn't (because it's your old one from Europe), get another one in a local store or have someone tell you what settings to - maybe you're still trying to log in using your old settings for the European ISP, which is bound to fail (it's like trying to call a local phone number without using the country code when you're abroad). And one more thing: Don't(!) try to re-connect to your old ISP, either, or you might be able to log in - but using long distance phone lines at minimal speeds and maximum expenses!

As soon as the router/modem is connected and things still don't work: Does the router or modem provide an IP for your system? If not, you need to activate the "DHCP server" side of that router/modem and switch to "Get IP using DHCP" (or "automatically") on your system (I've used quotes because I don't know how this information will be presented on the systems you're using).

To find out if your system has an IP or not, open a terminal, be root (from the terminal, using "su" - don't log into the system as root) and type "ifconfig". If you don't get another IP than 127.0.0.1 (for a device called "lo"), you're not connected. I find this way easier than using dozens of clicks through various tools. But then, those tools are bound to be there - it's your choice.

M.
First, let me mention, that I am also using XP on this same computer, and as you can read this, it is working without a problem, without any changes in the setup. So this part works.... and the speed must be normal, as I watch, or download the BBC TV...

I did as you described in your suggestion, and got as a two part answer, first that the ethernet seems to be still on the european IP, while the second one is called a loop and has indeed that 127. IP...

Where do I go from here, please??
Why does it automatically work on MS and not on Suse, would that not indicate that my computer Setup for Suse needs changing?
Switching on the router/modem to automatic might be a bit of a problem? Will this change anything for the other users? (We plug in three computers at different times. This is a family home) A
Thanks again....
 
Old 05-04-2008, 09:15 PM   #4
padlamoij
Member
 
Registered: Oct 2002
Location: East Point, GA
Posts: 188

Rep: Reputation: 30
I think you should just keep using windows. I think that linux is going to require you to learn a little about your computer and put some time into searching the internet for answers. Your problem is probably with PPP. But I really think you should just go back to using windows.

oh ya, PLEASE stop using please all the time. I know that where ever you went to school they taught you that please was a polite thing to say in english. In the USA when you are asking someone for help it is seen as being pushing and rude. Just a tip in the future.

Last edited by padlamoij; 05-04-2008 at 09:17 PM.
 
Old 05-05-2008, 05:59 PM   #5
goroku
LQ Newbie
 
Registered: May 2008
Posts: 4

Original Poster
Rep: Reputation: 0
Thank you...

Wow, thank you so much for your help. Oh, I suppose I should not say thank you either?

Really great support, very impressive!

Could you kindly stop doing what you consider helping other people, PLEASE?
 
Old 05-08-2008, 03:45 AM   #6
MoonMind
Member
 
Registered: May 2005
Location: Switzerland
Distribution: Ubuntu
Posts: 448

Rep: Reputation: 38
goroku

Sorry for not replying earlier (workload...). The fact that the IP (not 127.0.0.1, the other one) seems to be the old one points at the very fact that you've had it set manually (possible because you needed to). Switch to automatic setting ("DHCP") and try again.

However, I'd be glad if someone with SuSE on his/her own box could help here - I don't know if we're talking GNOME or KDE here (or something else entirely), and I don't want to confuse things by blindly pointing into some random direction. The tools used with different window managers are, well, different.

Or could you tell me which wm you use, please? I'm more familiar with GNOME, but I also use KDE...

M.

P.S. If you're asking simple things that could be find in on-board documentation, some people might frown upon that. We've all had to go throught that ourselves! Learning's recommendable, and on the long run, it's the only way to go. But let's get you online first - learning's some much easier with the net available
 
Old 05-08-2008, 03:55 AM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671Reputation: 671
There is a DSL configuration wizard in YaST2. Also look in the SuSE-reference pdf manual in the /docu directory of the DVD install disk. Chapter 20.4.5 covers this wizard.
 
Old 05-17-2008, 07:32 PM   #8
Upageya
Member
 
Registered: Sep 2007
Posts: 30

Rep: Reputation: 15
Friends, a few weeks ago I posted a rather straight forward question in this forum:
A notebook with xp professional und Suse 10.3 connected perfectly well in Europe, when connected with a dsl-cable to the internet. Here in Tokyo, the xp still works fine, without any changes, the Suse 10.3 does not work at all.
I got many answers from people trying to help and have spent around twenty to thirty hours trying them all, but….none worked.
As the problem to me seems pretty straight forward, I was surprised by the result. If I have to waste that much time on such a little thing (as xp clearly shows) I might as well keep on using xp and simply re-install it every few months from my cd, if I find it too slow, or too contaminated by the use in the internet….
Thanks for trying,
a disappointed Linux friend (not the first one, from what I read here!)
 
  


Reply

Tags
internetconnection


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Blocking Countries via pf firewall Schiz0 Linux - Networking 4 10-15-2007 06:27 AM
How to block countries from server? payjoe Linux - Security 10 10-10-2007 11:04 AM
LXer: Human Rights OSS Provides Uncensored Internet to Countries like China LXer Syndicated Linux News 0 12-02-2006 12:33 AM
geocoder for countries other than US and Canada MikeyCarter Linux - Software 1 07-07-2005 07:54 AM
Exporting Linux to other countries from US elzmaddy Linux - General 7 05-26-2003 12:36 AM


All times are GMT -5. The time now is 03:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration