LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 03-22-2010, 10:02 AM   #1
fedora_fonzie
LQ Newbie
 
Registered: Jun 2009
Location: Netherlands
Distribution: Fedora
Posts: 11

Rep: Reputation: 0
No headphone control in alsamixer


Hi there,

I'm running fedora 12 on my Asus Z92VA laptop. Everything is running fine, except for the fact that I have no audio on my headphone. When I use the command "alsamixer -c0", there is no listing for the headphone.

When I use the command "cat /proc/asound/card0/codec#* | grep Codec" I get the following output:

Codec: Realtek ALC880
Codec: Conexant ID 2bfa

I have searched several forums, but found no sollution to my problem. Does anyone have any ideas?

Thanks in advance,
Anton
 
Old 03-22-2010, 02:57 PM   #2
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
We need more information:

What sort of "headphone" are you connecting? There are many types.

For example

- USB?
- "Standard" audio-jack-socket?
- Bluetooth?

Without this information, we cannot help you further.

Please supply it.
 
Old 03-22-2010, 03:07 PM   #3
fedora_fonzie
LQ Newbie
 
Registered: Jun 2009
Location: Netherlands
Distribution: Fedora
Posts: 11

Original Poster
Rep: Reputation: 0
Hi Tredegar, thanks for the reply.
I'm just using a Standard audio-jack-socket. I also tried to plug it into other sockets (like the microphone), but no sound. When I plugin the jack in the socket for the headset the sound from the speakers goes to mute.

regards,
Anton
 
Old 03-22-2010, 05:00 PM   #4
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
Quote:
I'm just using a Standard audio-jack-socket.
OK
Quote:
I also tried to plug it into other sockets (like the microphone), but no sound.
Well, if you plug your headphones into the "microphone" socket, nothing is likely to happen, because the "microphone" socket is an INput, not an OUTput.

Quote:
When I plugin the jack in the socket for the headset the sound from the speakers goes to mute.
That is as it should be: If you are listening on headphones, you do not need the speakers working as well. They should be turned off.

Try R-clicking your speaker icon. Adjust the mixer. Try adjusting "Master channel".

You have not told us what window manager you are running (Gnome, KDE3, KDE4, something else....) It makes a big difference

Do your headphones need a battery?
Is it charged?
Is it turned on?
 
Old 03-23-2010, 01:36 AM   #5
fedora_fonzie
LQ Newbie
 
Registered: Jun 2009
Location: Netherlands
Distribution: Fedora
Posts: 11

Original Poster
Rep: Reputation: 0
I'm using gnome and my headphone doesn't need batteries. I have tried other headphones as well (also with a standard audio jack), but the same problem occurs. As I mentioned in my first post I used the command "alsamixer -c0". It gave me output with several "equalizers" where I can adjust the sound volume by using the arrow-keys up and down. But there is no listing for the headphone. Here is a picture of the output.
And before you might wonder, I can also adjust the volume on my headphone, but on other headphones where this is not possible I have the same problem.
I have used a headphone with a microphone as well (for Skype) and the microphone works just fine (but not the headphone). Using Windows XP on the same machine, the headphone works perfect.
Thanks tredegar so far for your time and interest.

Last edited by fedora_fonzie; 09-17-2010 at 09:09 AM.
 
Old 03-23-2010, 03:22 AM   #6
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
You are right, it's not seeing your Headphone.

See:
http://linux.derkeiler.com/Mailing-L.../msg00061.html
Quote:
Some users with specific hda-intel cards have
reported problems with sound card detection in the 2.6.25 series of linux kernels.
See:
http://linux.derkeiler.com/Mailing-L.../msg00001.html

So maybe you need to pass some options to the snd_hda_intel module
Eg
Add the line

options snd_hda_intel model=asus

to your /etc/modprobe.conf

and then rmmod and modprobe to reinstall the module, or just reboot.

Alternatively, maybe try a different (older, or newer) kernel from your distro's package manager.
 
Old 03-23-2010, 05:10 AM   #7
fedora_fonzie
LQ Newbie
 
Registered: Jun 2009
Location: Netherlands
Distribution: Fedora
Posts: 11

Original Poster
Rep: Reputation: 0
I'm using Fedora 12 and there is no file called /etc/modprobe.conf. There is a directory /etc/modprobe.d/ which has the following content:
anaconda.conf
blacklist.conf
blacklist-visor.conf
dist-alsa.conf
dist.conf
dist-oss.conf

Would you know how to proceed from here?
 
Old 03-23-2010, 05:39 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,012

Rep: Reputation: 367Reputation: 367Reputation: 367Reputation: 367
I haven't used fedora, and this sort of thing is distro-specific.

Do any of those files have anything about options in them?

I have a file /etc/modprobe.d/options It is owned by root:root and perms are 644
You could try creating that file and putting the module options line from post #6 in it.

But rather than "just geussing" it would be better to find out how F12 manages module options. I have searched around, but cannot find it. Maybe make a post to the LQ Fedora forum "How to set kernel module options in Fedora 12?"
 
Old 03-23-2010, 06:11 AM   #9
fedora_fonzie
LQ Newbie
 
Registered: Jun 2009
Location: Netherlands
Distribution: Fedora
Posts: 11

Original Poster
Rep: Reputation: 0
Quote:
I have a file /etc/modprobe.d/options It is owned by root:root and perms are 644
You could try creating that file and putting the module options line from post #6 in it.
I tried it, but doesn't help. I will post something Fedora related as you suggested.
Thanks!

edit: I posted a follow-up thread on LQ here

Last edited by fedora_fonzie; 09-17-2010 at 09:14 AM. Reason: typo's
 
Old 10-30-2010, 03:52 PM   #10
pwabrahams
Member
 
Registered: Nov 2005
Location: Deerfield MA
Distribution: OpenSuSE, Kubuntu
Posts: 272

Rep: Reputation: 41
Same problem, kubuntu 10.10

Several people have encountered this problem. In my case I'm running Kubuntu 10.10. Before the latest update, the headphone jack worked; now it doesn't. I have an Asis K60 laptop; apparently the problem is machine-specific. I too see the headphone greyed out in alsamixer.
 
Old 11-01-2010, 08:17 PM   #11
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Mageia, Mint
Posts: 7,747

Rep: Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461Reputation: 1461
At this point, I'd try a different headphone, not because I suspect your headphones are bad, but because it's a very easy test and sometimes trouble-shooting easy is more efficient that trouble-shooting most-likely.
 
Old 11-01-2010, 11:25 PM   #12
pwabrahams
Member
 
Registered: Nov 2005
Location: Deerfield MA
Distribution: OpenSuSE, Kubuntu
Posts: 272

Rep: Reputation: 41
Headphones greyed out in alsamixer

The fact that the headphones are greyed out in alsamixer is a very strong indication that this really is a software problem. (Plus, they work in Windows.)
 
  


Reply

Tags
alsamixer, fedora, headphone, realtek


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] ubuntu headphone serafimg Linux - Laptop and Netbook 15 01-24-2012 10:14 PM
tc traffic control tc traffic control Linux QoS control tool(noob help) inv|s|ble Linux - General 1 07-26-2007 11:12 AM
Can't control headphone volume (alsa 1.0.14rc3) krisyok Linux - Newbie 2 04-26-2007 09:59 AM
Strange: Can only control volume using headphone slider deancicca Linux - Laptop and Netbook 11 08-07-2006 08:57 AM
no sound --headphone Sherulinux Linux - Newbie 7 08-10-2005 03:39 PM


All times are GMT -5. The time now is 09:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration