LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Newbie (http://www.linuxquestions.org/questions/linux-newbie-8/)
-   -   No headphone control in alsamixer (http://www.linuxquestions.org/questions/linux-newbie-8/no-headphone-control-in-alsamixer-797063/)

fedora_fonzie 03-22-2010 10:02 AM

No headphone control in alsamixer
 
Hi there,

I'm running fedora 12 on my Asus Z92VA laptop. Everything is running fine, except for the fact that I have no audio on my headphone. When I use the command "alsamixer -c0", there is no listing for the headphone.

When I use the command "cat /proc/asound/card0/codec#* | grep Codec" I get the following output:

Codec: Realtek ALC880
Codec: Conexant ID 2bfa

I have searched several forums, but found no sollution to my problem. Does anyone have any ideas?

Thanks in advance,
Anton

tredegar 03-22-2010 02:57 PM

We need more information:

What sort of "headphone" are you connecting? There are many types.

For example

- USB?
- "Standard" audio-jack-socket?
- Bluetooth?

Without this information, we cannot help you further.

Please supply it.

fedora_fonzie 03-22-2010 03:07 PM

Hi Tredegar, thanks for the reply.
I'm just using a Standard audio-jack-socket. I also tried to plug it into other sockets (like the microphone), but no sound. When I plugin the jack in the socket for the headset the sound from the speakers goes to mute.

regards,
Anton

tredegar 03-22-2010 05:00 PM

Quote:

I'm just using a Standard audio-jack-socket.
OK
Quote:

I also tried to plug it into other sockets (like the microphone), but no sound.
Well, if you plug your headphones into the "microphone" socket, nothing is likely to happen, because the "microphone" socket is an INput, not an OUTput.

Quote:

When I plugin the jack in the socket for the headset the sound from the speakers goes to mute.
That is as it should be: If you are listening on headphones, you do not need the speakers working as well. They should be turned off.

Try R-clicking your speaker icon. Adjust the mixer. Try adjusting "Master channel".

You have not told us what window manager you are running (Gnome, KDE3, KDE4, something else....) It makes a big difference :(

Do your headphones need a battery?
Is it charged?
Is it turned on?

fedora_fonzie 03-23-2010 01:36 AM

I'm using gnome and my headphone doesn't need batteries. I have tried other headphones as well (also with a standard audio jack), but the same problem occurs. As I mentioned in my first post I used the command "alsamixer -c0". It gave me output with several "equalizers" where I can adjust the sound volume by using the arrow-keys up and down. But there is no listing for the headphone. Here is a picture of the output.
And before you might wonder, I can also adjust the volume on my headphone, but on other headphones where this is not possible I have the same problem.
I have used a headphone with a microphone as well (for Skype) and the microphone works just fine (but not the headphone). Using Windows XP on the same machine, the headphone works perfect.
Thanks tredegar so far for your time and interest.

tredegar 03-23-2010 03:22 AM

You are right, it's not seeing your Headphone.

See:
http://linux.derkeiler.com/Mailing-L.../msg00061.html
Quote:

Some users with specific hda-intel cards have
reported problems with sound card detection in the 2.6.25 series of linux kernels.
See:
http://linux.derkeiler.com/Mailing-L.../msg00001.html

So maybe you need to pass some options to the snd_hda_intel module
Eg
Add the line

options snd_hda_intel model=asus

to your /etc/modprobe.conf

and then rmmod and modprobe to reinstall the module, or just reboot.

Alternatively, maybe try a different (older, or newer) kernel from your distro's package manager.

fedora_fonzie 03-23-2010 05:10 AM

I'm using Fedora 12 and there is no file called /etc/modprobe.conf. There is a directory /etc/modprobe.d/ which has the following content:
anaconda.conf
blacklist.conf
blacklist-visor.conf
dist-alsa.conf
dist.conf
dist-oss.conf

Would you know how to proceed from here?

tredegar 03-23-2010 05:39 AM

I haven't used fedora, and this sort of thing is distro-specific.

Do any of those files have anything about options in them?

I have a file /etc/modprobe.d/options It is owned by root:root and perms are 644
You could try creating that file and putting the module options line from post #6 in it.

But rather than "just geussing" it would be better to find out how F12 manages module options. I have searched around, but cannot find it. Maybe make a post to the LQ Fedora forum "How to set kernel module options in Fedora 12?"

fedora_fonzie 03-23-2010 06:11 AM

Quote:

I have a file /etc/modprobe.d/options It is owned by root:root and perms are 644
You could try creating that file and putting the module options line from post #6 in it.
I tried it, but doesn't help. I will post something Fedora related as you suggested.
Thanks!

edit: I posted a follow-up thread on LQ here

pwabrahams 10-30-2010 03:52 PM

Same problem, kubuntu 10.10
 
Several people have encountered this problem. In my case I'm running Kubuntu 10.10. Before the latest update, the headphone jack worked; now it doesn't. I have an Asis K60 laptop; apparently the problem is machine-specific. I too see the headphone greyed out in alsamixer.

frankbell 11-01-2010 08:17 PM

At this point, I'd try a different headphone, not because I suspect your headphones are bad, but because it's a very easy test and sometimes trouble-shooting easy is more efficient that trouble-shooting most-likely.

pwabrahams 11-01-2010 11:25 PM

Headphones greyed out in alsamixer
 
The fact that the headphones are greyed out in alsamixer is a very strong indication that this really is a software problem. (Plus, they work in Windows.)


All times are GMT -5. The time now is 09:35 PM.