LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-18-2006, 08:55 PM   #1
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Rep: Reputation: 15
no graphics with nvidia driver


I did it again! Last year I downloaded the nvidia program to build my own driver and it worked fine. Last week I installed a new monitor and it would only come up in text mode (init 3). After several hours of messing around with it I reloaded the OS (Mandriva 2006). I downloaded the latest nvidia program, installed the kernel source code and built a new nvidia 3D driver. When I typed 'init 5' nothing happened. Rebooting brought me up in text mode again. I removed the nvidia driver and downloaded the old version and tried building a driver with it, same problem. I have 'nvidia' in the modprobe.preload and xorg.conf files, also Load = dri & GLCore are not in the xorg.conf file, but glx is there. My new monitor is also listed in the conf files. This all worked for a year until I reloaded the OS. Anybody have and idea of how to get the driver to work? Stephen
 
Old 09-19-2006, 03:37 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
The question is if it's nvidia driver of the monitor settings (which are closely connected, but different things). Please use your current nvidia driver, then (after failed reboot, in text mode) look into /etc/Xorg.0.log, search for errors. If you don't understand them fully, please post the lines you think may be important. Or, if the file is not too long, just post the whole file.
 
Old 09-20-2006, 09:56 AM   #3
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Original Poster
Rep: Reputation: 15
no graphics with nvidia driver.

Mara;
Here are the lines from my /etc/var/log/Xorg.0.log that didn't look right to me.

First in the beginning it states;

BUILD OPERATING SYSTEM: Linux 2.6.3-35mdk-i686-up-4GB i686 [ELF]
CURRENT OPERATING SYSTEM: Linux localhost 2.6.12.12mdk #1 Fri Sep 9 18:15:22 CEST 2005 i686
BUILD DATE 07 SEPTEMBER 2006

I don't know if that means anything but I don't know were the linux 2.6.3-35mdk came from.

The next lines are what I think the problem is from;

(WW) NVIDIA(0): No modes were requested; the default mode
(WW) NVIDIA(0): "nvidia-auto-select" will be used as the
(WW) NVIDIA(0): requested mode.


(WW) NVIDIA(0): Mode "nvidia-auto-select" is larger then virtual
(WW) NVIDIA(0): size 1280 x 960; discarding mode.
(EE) NVIDIA(0): Failure to construct a valid mode list: no modes
(EE) NVIDIA(0): remaining.
(EE) NVIDIA(0): ***Aborting***


(EE) Screen(s) found, but none have a usable configuration.
Fatal server error
no screen found


That's the warnings and errors in the log. What they mean to me is something isn't right, but I don't know what it is. Does this help you to understand the problem? How do I fix it?
Stephen
 
Old 09-21-2006, 10:03 AM   #4
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 871
Blog Entries: 9

Rep: Reputation: 103Reputation: 103
Hi,
It would seem your nvidia driver doesn't see the screen resolutions (modes).

I'd suggest you trying to add the following lines to your xorg.conf file; in the "Device" section :
Code:
 Option          "MetaModes" 1280x1024,NULL; 1024x768,NULL; 800x600,NULL; 640x480,NULL"
Replacing the numbers by the resolutions of your screen.

Explanation as to what this does can be found here : http://download.nvidia.com/XFree86/L...ppendix-d.html
(just search "MetaModes")

Last edited by serafean; 09-21-2006 at 10:04 AM.
 
Old 09-21-2006, 01:19 PM   #5
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Original Poster
Rep: Reputation: 15
no graphics with nvidia driver.

Serafean;

Something new in the log. Still no graphics.

New lines in log as follows;

(II) LoadModule: "nvivia"
(WW) Warning, couldn't open module nvivia
(II) UnloadModule: "nvivia"
(EE) Failed to load module "nvivia" (module does not exist, 0)


(EE) No devices detected.

Fatal server error:
no screens found


I cannot find anywhere that nvidia is misspelled. All the logs up to now spelled it correct. There are still no graphics, but with this problem I can see why.

Stephen
 
Old 09-21-2006, 01:40 PM   #6
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 871
Blog Entries: 9

Rep: Reputation: 103Reputation: 103
Wow, that's a BIG surprise; nvivia.

Sorry to say that I don't know where Mandriva or xorg store this configuration option; the only idea I have is to add "nvidia" to the /etc/modules file and see if it does something.

Good luck
 
Old 09-21-2006, 04:15 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Is there a chance that you have modified the nvidia's module name in xorg.conf when adding modeline? It's quite close.
Look for something like
Code:
Section "Device"
        Identifier      (longer description here)
        Driver          "nvidia"
EndSection
Do you have nvidia or nviva here?
 
Old 09-21-2006, 08:22 PM   #8
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Original Poster
Rep: Reputation: 15
Mara;
That was the first thing I checked, it was spelled correct. I re-installed Mandriva and made sure I told the install to put the monitor info in the conf file. This time when I looked at my xorg.conf all the data that Serafean told me to put in was there. I tried selecting a generic monitor and that didn't help either. At least the re-install got rid of the misspelling problem. I have everything re-installed and still have the same problem.
Stephen
 
Old 09-22-2006, 03:15 PM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Please look into your xorg.conf again and search for two lines: HorizSync and VertRefresh. Please post the values you have.
 
Old 09-23-2006, 06:28 PM   #10
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Original Poster
Rep: Reputation: 15
no graphics with nvidia driver

Mara;
Here is the info from my xorg.conf file;

HorizSync 30-82
VertRefresh 56-76

Do you think this may have something to do with my problem?
Stephen
 
Old 09-25-2006, 02:09 AM   #11
NeoMagic
LQ Newbie
 
Registered: Jun 2006
Posts: 16

Rep: Reputation: 0
hi,

I would like to share some tweak to get X on madriva 2006.
since i have seen a lots of posts relating to X crash on nvidia using mandriva.

in /etc/X11/xorg.conf , change "Virtual 800 600" line 'screen' section to
Modes 800x600. Thats all. if u have nvidia drivers installed, also change from 'nv' to 'nvidia'.

I found this help after a lot of googling.

Neo.
 
Old 09-26-2006, 07:29 PM   #12
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Original Poster
Rep: Reputation: 15
no graphics with nvidia driver

NeoMagic;

I replaced all the Virtual "xxxx" with Mode "xxxx" in the /etc/X11/xorg.conf. It looks like this is the closest I've come to getting Nvidia to work. Now I can get the Nvidia splashscreen then it goes black and I come up in text mode. I also noticed that the /etc/X11/xorg.conf had 4 SubSections with a Virtual level and a depth level in each before I changed the virtual to mode. After I changed it there was only 1 SubSection and no depth. After changing the Mode back to Virtual the nvidia back to nv it would not come up in graphic mode. I had to replace the xorg.conf file with an old backup copy to get back into graphic mode. But I think we're on the right track.

Stephen
 
Old 09-27-2006, 01:27 PM   #13
NeoMagic
LQ Newbie
 
Registered: Jun 2006
Posts: 16

Rep: Reputation: 0
my xorg.conf

nice to hear that u r close to success. Iam listing my xorg.conf . Hope this may help further. Observe the Modes .. line at end clearly.

************

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Mon May 15 13:23:42 PDT 2006

# File generated by XFdrake.
# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "ServerLayout"
Identifier "layout1"
Screen "screen1" 0 0
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

Section "Files"

# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "ServerFlags"

#DontZap # disable <Crtl><Alt><BS> (server abort)
# allows the server to start up even if the mouse does not work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
Option "allowmouseopenfail"
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
Option "ZAxisMapping" "6 7"
EndSection

Section "Monitor"

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
ModeLine "768x576" 50.0 768 832 846 1000 576 590 595 630
ModeLine "768x576" 63.1 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
Driver "nvidia"
VendorName "nVidia"
BoardName "NVIDIA GeForce2 Integrated (generic)"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
Option "DPMS"
SubSection "Display"
Depth 8
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600"
EndSubSection
EndSection
 
Old 09-27-2006, 03:54 PM   #14
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
I suspect your monitor settings. You have
Code:
HorizSync 31.5 - 57.0
VertRefresh 50.0 - 70.0
It's very small range, so it couldn't find proper modes inside. The correct values depend on the monitor, they're different for LCD and CRT. It looks you have CRT. In such case, you should have much broader ranges. For example, I have
Code:
HorizSync       30-96
VertRefresh     50-160
You should be able to find the corrct values in your monitor's manual. If you can't find them (or the manual, but modes are googlable with monitor model), you can just guess, with monitor produced no more than 5 years ago it shouldn't result in problems.
 
Old 10-22-2006, 09:11 AM   #15
sneckert
Member
 
Registered: Dec 2004
Distribution: PCLinuxOS 2011 - LXDE
Posts: 54

Original Poster
Rep: Reputation: 15
no graphics with nvidia driver

Mara, NeoMagic, serafean;

I'd like to thank you all for trying to help me with my nvidia problem. I would also like to let you all, and any one else that has this problem, know what to do. By accident when I removed the kernal-source file it said that it would remove the dkms file also. I checked and found that there are several dkms files and in order to build a nvidia driver module you have to have the dkms-nvidia file. By default the basic dkms is installed with the kernal-source file. This causes an error in the nvidia driver and it will not work. If you load the dkmw-nvidia file the urpmi program asks you which kernal-source file you what. Select the right source file and install. Problem solved.

Thank you again.
Stephen
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
nVidia Geforce Graphics Driver Help Toods Slackware - Installation 3 12-12-2005 07:08 AM
nVidia Graphics Driver BarfBag Suse/Novell 8 10-13-2005 08:41 AM
no graphics with nvidia driver sneckert Mandriva 5 07-03-2005 07:56 PM
nVIDIA graphics driver problems. DesyphER Linux - Software 10 03-27-2005 09:19 AM
nVIDIA Graphics Driver MDK10.1 DaBlade Linux - Hardware 24 11-15-2004 05:36 AM


All times are GMT -5. The time now is 09:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration