LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 01-02-2002, 12:23 PM   #1
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Rep: Reputation: 30
No Floppy in Mandrake 8.1


Is it me or a hardware problem?

Here are the Floppy lines in the boot-up screen

Floppy drive(s): fd0 is 1.44M
floppy0: Floppy io-port 0x03f0 in use
ide-floppy driver 0.97

When I click on the Floppy icon on the desktop, I get an error message that says "Could not mount device. The reported error was: mount: /dev/fd0: unknown device

Another thing is I don't have a CD-ROM icon on the desktop and have to mount it as root. I couldn't get the Floppy to work even as root.

During the install, Mandrake made a boot disk and a Replay disk so I don't understand why I can't access floppies.
 
Old 01-02-2002, 12:53 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
this might sound stupid, but did you insert a floppy then try to mount it ?? have you tried from the command line to mount it and if so what errors did you get ?? what does your fstab look like ??
 
Old 01-02-2002, 01:29 PM   #3
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by trickykid
this might sound stupid, but did you insert a floppy then try to mount it ?? have you tried from the command line to mount it and if so what errors did you get ?? what does your fstab look like ??
Yeah, I had a floppy inserted.

I got the same error (or similar) when trying to do it from the command line. (either as root or user)

I'm in Windows right now because my modem won't work with Linux so I'll have to look at fstab later. Where do I find it? I've only had this installed for about a week, so I'm still not familiar with where stuff is.

Thanks


 
Old 01-03-2002, 12:05 AM   #4
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by trickykid
what does your fstab look like ??
Here it is. I've separated the lines to make it easier to read.

/dev/hda8 / ext2 defaults 1 1

none /dev/pts devpts mode=0620 0 0

none /dev/shm tmpfs defaults 0 0

/mnt/cdrom /mnt/cdrom supermount dev=/dev/hdc,fs=auto,exec,ro,--,user,iocharset=iso8859-1,umask=0,codepage=850,noauto 0 0

/dev/scd0 /mnt/cdrom2 auto user,iocharset=iso8859-1,umask=0,exec,codepage=850,ro,noauto 0 0

/dev/fd0 /mnt/floppy auto user,iocharset=iso8859-1,umask=0,sync,exec,codepage=850,noauto 0 0

/dev/hda1 /mnt/win_c vfat iocharset=iso8859-1,umask=0,codepage=850 0 0

/dev/hda5 /mnt/win_d vfat iocharset=iso8859-1,umask=0,codepage=850 0 0

/dev/hda6 /mnt/win_e vfat iocharset=iso8859-1,umask=0,codepage=850 0 0

/dev/hda7 /mnt/win_f vfat iocharset=iso8859-1,umask=0,codepage=850 0 0

/dev/hda10 /mnt/win_g vfat iocharset=iso8859-1,umask=0,codepage=850 0 0

none /proc proc defaults 0 0

/dev/hda9 swap swap defaults 0 0

Last edited by 9nine9; 01-03-2002 at 12:07 AM.
 
Old 01-03-2002, 12:14 AM   #5
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
and you did try mounting a floppy with this:
Code:
mount -t filesystem-type /dev/fd0 /mnt/floppy
 
Old 01-03-2002, 04:30 PM   #6
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by trickykid
and you did try mounting a floppy with this:
Code:
mount -t filesystem-type /dev/fd0 /mnt/floppy
Yes. I tried it first as user and got a message that said only root
can do this, even though user has permission according to the floppy
icon's properties. So anyway, I did su root and tried it again and I
get this error message: "mount: /dev/fd0: unknown device"

I tried it using
mount -t vfat /dev/fd0 /mnt/floppy
and also using
mount -t auto /dev/fd0 /mnt/floppy
 
Old 01-03-2002, 06:36 PM   #7
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
and you do have fd0 in your /dev directory... this is strange.. it should work with the commands you gave... according to your fstab file.
 
Old 01-04-2002, 03:39 PM   #8
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by trickykid
and you do have fd0 in your /dev directory... this is strange.. it should work with the commands you gave... according to your fstab file.
Yep, fd0 is in the /dev directory and the funny thing is, when Mandrake installed, I didn't have any problem making a boot disk and an installation replay disk. If the install program recognized the floppy, why doesn't the main OS?
 
Old 01-04-2002, 06:24 PM   #9
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Try editing the entry for your floppy in /etc/fstab so it looks like this,
Code:
/dev/fd0       /mnt/floppy      vfat   ,user,rw,noauto   0   0

Last edited by Aussie; 01-04-2002 at 06:26 PM.
 
Old 01-04-2002, 06:53 PM   #10
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Aussie
Try editing the entry for your floppy in /etc/fstab so it looks like this,
Code:
/dev/fd0       /mnt/floppy      vfat   ,user,rw,noauto   0   0
Thanks, I'll give it a try and let you know. I'm assuming here that I can just edit it in a regular text editor, right?
 
Old 01-04-2002, 07:00 PM   #11
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
Quote:
Originally posted by 9nine9


Thanks, I'll give it a try and let you know. I'm assuming here that I can just edit it in a regular text editor, right?
Thats right but you'll need to be root to save the new file, open a terminal, su to root and do "mcedit /etc/fstab".
 
Old 01-04-2002, 10:29 PM   #12
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Aussie


Thats right but you'll need to be root to save the new file, open a terminal, su to root and do "mcedit /etc/fstab".
Yeah, I just found out while I was offline that I can't save it as user. Ok, so when I do mcedit /etc/fstab, where does the file open and do I need to know some special command to save it when I'm done editing? I'm still too fresh of a newbie to know what to expect here. Does it get edited right in the terminal, or does the terminal open another program (mcedit?) with fstab as the file to edit?

Speaking of which, is there some good help on terminal commands in Linux and if so, where is it located?

Thanks.
 
Old 01-05-2002, 12:04 AM   #13
Aussie
Senior Member
 
Registered: Sep 2001
Location: Brisvegas, Antipodes
Distribution: Slackware
Posts: 4,590

Rep: Reputation: 56
"mcedit /etc/fstab" will open fstab in the midnight commander editor in the terminal. After you edit the file you save it with <F2><Enter>. Do "mc" in the terminal to have a look at midnight commander, its a handy console based file browser/manager/editor.
 
Old 01-06-2002, 04:20 PM   #14
9nine9
Member
 
Registered: Nov 2001
Distribution: Debian, Fedora, Kubuntu, Puppy
Posts: 166

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by Aussie
"mcedit /etc/fstab" will open fstab in the midnight commander editor in the terminal. After you edit the file you save it with <F2><Enter>. Do "mc" in the terminal to have a look at midnight commander, its a handy console based file browser/manager/editor.
OK, I did the deed but I still can't mount the floppy. I'm getting the same error message: /dev/fd0: unknown

I checked the property sheets for fd0 and 0 and here's what they say. Does this look right to you?

Properties for fd0:

Type: Block Device
Location: /dev
Size: O B (0)
Points to: floppy/0

Properties for 0:

Type: Block Device
Location: /dev/floppy
Size: O B (0)

Also, in the Control Center, in the area where the drives are, on the tab for removable drives, my cdrom and cdrw are there but there is no floppy drive. Shouldn't it be there with the other removable drives?

Thanks,
 
Old 01-11-2002, 02:13 PM   #15
jdogg2001
LQ Newbie
 
Registered: Jan 2002
Distribution: Mandrake 8.1
Posts: 2

Rep: Reputation: 0
Lightbulb You have to pass a kernel option

I had the same problem. To fix it, just pass "nobiospnp" option to the kernel. If you boot with lilo, open /etc/lilo.conf, find the kernel you want to boot, and add the above option to the end of the line that says append="..., ..., ..., nobiospnp".
That should fix it. Hope it works. Later.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mandrake installation without floppy ?!! bitonious Linux - Laptop and Netbook 1 10-22-2005 05:14 AM
boot floppy for mandrake 10 santasballz Linux - Newbie 1 12-06-2004 08:18 PM
Mandrake 10 problems with CD and floppy abjensen Mandriva 9 03-27-2004 12:35 AM
floppy problems in mandrake 9.0?? len Linux - Newbie 4 07-10-2003 05:20 PM
use cdrom and floppy in Mandrake 8 happy hippo Linux - Newbie 0 08-22-2001 01:09 PM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration