LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 11-15-2009, 04:53 PM   #1
chevyiron420
LQ Newbie
 
Registered: Nov 2009
Posts: 21

Rep: Reputation: 0
no floppy after ubunto 9.04 install


I have installed ubuntu 9.04 after a new hard drive installation and now dont seem to have my floppy. Can someone help me get it working?
 
Old 11-15-2009, 05:44 PM   #2
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Rep: Reputation: 38
What do you get from:

lsmod |grep floppy
 
Old 11-15-2009, 06:53 PM   #3
chevyiron420
LQ Newbie
 
Registered: Nov 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by DaveQB View Post
What do you get from:

lsmod |grep floppy
I sorry im so stupid but im not sure what you want me to do. I think you want me to go to termanal, right? also what is the charecter just to the left of the g in grep? do you want me to type this line in termanal?
 
Old 11-15-2009, 07:18 PM   #4
MrCode
Member
 
Registered: Aug 2009
Location: Oregon, USA
Distribution: Arch
Posts: 864
Blog Entries: 31

Rep: Reputation: 148Reputation: 148
Quote:
Originally Posted by chevyiron420 View Post
I sorry im so stupid but im not sure what you want me to do. I think you want me to go to termanal, right? also what is the charecter just to the left of the g in grep? do you want me to type this line in termanal?
Yes, you want to open a terminal (via Applications->Accessories->Terminal) and type this in. The character next to grep is what's called a "pipe". It's used to "combine" commands. The "lsmod" command is used to list the modules (Linux equivalent of drivers, basically) installed. The "grep" command is typically used to narrow down the output from a command to what you type afterwards.

Trust me, you're not stupid, you're just new...just about everyone who's new to Linux will think this is pretty foreign at first. I was no exception when I started out, and I'm still learning .

Last edited by MrCode; 11-15-2009 at 07:25 PM.
 
Old 11-15-2009, 07:18 PM   #5
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Rep: Reputation: 38
No, not being stupid at all. I assumed some knowledge there that I shouldn't have.

So yes, a terminal is where this goes. You can simply copy and paste if you are unsure of that "pipe" symbol.
I am unsure if Ubuntu 9.04 has a GUI to list kernel modules, but I am leaning towards the case it doesn't.

So I think its "Applications > Terminal"

But not sure, I haven't used Gnome for any period of time.

You may need to prepend sudo to that command, making it:

Code:
sudo lsmod | grep floppy
 
Old 11-15-2009, 07:59 PM   #6
chevyiron420
LQ Newbie
 
Registered: Nov 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Well i tryed to cut and paste cause i cant seem to make that pipe symbol with my keyboard. anyway it pasted it there in termanal but when it asks for my password it wont take the carecters. I type in the password but it doesnt show on the screen.
 
Old 11-15-2009, 08:07 PM   #7
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Rep: Reputation: 38
That's correct behaviour. It won't echo the password to the terminal so people looking over your shoulder can't see it.

Just type it in and press ENTER.
 
Old 11-15-2009, 08:43 PM   #8
chevyiron420
LQ Newbie
 
Registered: Nov 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Ok, well i cut and pasted it and it seemed to take this time but still no joy. I dont see the floppy anywhare. I restarted the computor twice.
 
Old 11-15-2009, 08:52 PM   #9
smeezekitty
Senior Member
 
Registered: Sep 2009
Location: Washington U.S.
Distribution: M$ Windows / Debian / Ubuntu / DSL / many others
Posts: 2,241

Rep: Reputation: 194Reputation: 194
ok lets try this again...
type
Code:
lsmod | floppy
the | symbol is right under backspace on most keyboards.
then you will have to type in your password on the stupid prompt.
then copy what you see on the terminal and post it here
 
Old 11-15-2009, 09:09 PM   #10
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Rep: Reputation: 38
Yes as smeezekitty states

You may in fact get no output at all, which is a problem.

If you get nothing [you can verify it found nothing by running
Code:
if [ ! `echo $?` -eq 0 ] ; then echo error ; fi
as the very next command to the one we are trying to get you to run.] then we need to do some more commands, namely:

Code:
modprobe floppy

Last edited by DaveQB; 11-15-2009 at 09:10 PM. Reason: more verbose
 
Old 11-15-2009, 09:53 PM   #11
chevyiron420
LQ Newbie
 
Registered: Nov 2009
Posts: 21

Original Poster
Rep: Reputation: 0
Guy's im not getting anywhare. I have tryed the things you said but i dont know if im doing it right. I may be messing stuff up.
Is there a way i can just reload the system and get what i want?
What do i have to do the hard drive to put window back on here?
 
Old 11-15-2009, 10:21 PM   #12
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
I guess this is frustrating, but don't give up yet. What happens when you "modprobe floppy" from a terminal - do you get
Quote:
FATAL: Error inserting floppy (/lib/modules/blah blah blah .../floppy.ko): Operation not permitted
If so, try "sudo modprobe floppy" (you'll need to enter your password again).
If that works, do this to make it permanent
Code:
echo "floppy" | sudo tee -a  /etc/modules
 
Old 11-15-2009, 10:30 PM   #13
DaveQB
Member
 
Registered: Oct 2003
Location: Sydney, Australia.
Distribution: PCLinuxOS 2010.12, Debian Lenny
Posts: 387

Rep: Reputation: 38
I am surprised the floppy module is not loaded when the system boots and detects a floppy control on the motherboard and turned on.
 
Old 11-15-2009, 10:44 PM   #14
chevyiron420
LQ Newbie
 
Registered: Nov 2009
Posts: 21

Original Poster
Rep: Reputation: 0
I did modprobe floppy and sudo modprobe floppy and it didnt do anything i can see.
 
Old 11-15-2009, 11:11 PM   #15
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,505

Rep: Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079Reputation: 1079
Try these and see if you get anything back
Code:
lsmod | grep -i floppy
find /lib/modules/ -iname floppy*
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I am trying to install ubunto with command dickie stangimon LinuxQuestions.org Member Intro 4 02-23-2009 08:43 AM
installed ubunto twice by mistake now in boot up screen get 2 options for ubunto salpapa Linux - Newbie 8 06-28-2007 06:24 PM
do i need to install all my drivers after installing ubunto everything works ok salpapa Linux - Newbie 1 06-28-2007 06:01 PM
Debian Woody floppy install problems with ATAPI floppy jturnicate Linux - Newbie 0 02-17-2004 10:45 AM
Floppy disk fail to boot when install suse 8 with boot from floppy ffang Linux - Newbie 0 08-18-2003 09:44 PM


All times are GMT -5. The time now is 03:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration