LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-15-2003, 02:14 AM   #1
cherup
LQ Newbie
 
Registered: Apr 2003
Posts: 11

Rep: Reputation: 0
No fefault GW with PPP0


Hi,

i've installed a RH9 distribution and
wanted to get connected though the Internet
with a DSL modem.

I used the RH network-config-setup GUI
for configure the connection.
It seems everything OK... (but it does't work)

When i take a look at my routing table I see the following:


Ziel Router Genmask Flags Metric Ref Use
Iface
145.253.1.132 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.0.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.0.1 0.0.0.0 UG 0 0 0 eth1


theres no default gw for ppp0.
When I set it manually with

route add default gw 145.253.1.132

everything works fine.

In the config-gui the option "set default route" is chosen
on my ppp0 connection, I don't know wy the route isn't
added correctly...

maybe someone can give my a hand

]
 
Old 05-15-2003, 02:32 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
make these entries in /etc/sysconfig/network

GATEWAY=0.0.0.0
GATEWAYDEV=ppp0

that should do it.

 
Old 05-15-2003, 03:44 PM   #3
cherup
LQ Newbie
 
Registered: Apr 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Thumbs up

Thnx,

now it works fine!!!!
 
Old 05-15-2003, 06:55 PM   #4
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
Great,

This is the second time this week that I have seen this problem.

Cool!

Don't forget affero, you could be a winner.

Last edited by DavidPhillips; 05-15-2003 at 06:56 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ppp0 paul62 Mandriva 1 09-04-2005 02:58 AM
eth1 and ppp0, need to send UDP packets through ppp0 smhs Linux - Networking 2 07-12-2005 09:54 AM
ppp0 is down! pdmackenzie Linux - Networking 3 05-24-2005 12:25 AM
ADSL-STATUS: linked to ppp0 but ppp0 seems to be down. mikkime23 Linux - Networking 1 01-01-2005 12:00 PM
Endless Loop: ppp0 Unregister Netdevice: waiting for ppp0 to be free. oberon-ken-obi Linux - Networking 1 07-21-2004 12:04 AM


All times are GMT -5. The time now is 06:43 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration