LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-15-2011, 06:32 AM   #1
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Rep: Reputation: 33
No eth0 at startup


Hello,

I notice that there is no eth0 when I restart my Fedora server. There is only the local interface.

This is my eth0 config :
Code:
[root@webserver ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0 
DEVICE=eth0
BOOTPROTO=none
DNS1=192.168.1.250
HWADDR=08:00:27:bd:f5:3c
ONBOOT=no
SEARCH="jocan.local"
IPADDR=192.168.1.151
NETMASK=255.255.255.0
GATEWAY=192.168.1.250
TYPE=Ethernet
IPV6INIT=no
USERCTL=no
The only way I can get this interface up is :
Code:
[root@webserver ~]# ifconfig eth0 192.168.1.151 up
How come this interface is not brought up ?
 
Old 07-15-2011, 06:37 AM   #2
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389
Hi,

Change this:
Code:
ONBOOT=no
to
Code:
ONBOOT=yes
Hope this helps.
 
Old 07-15-2011, 07:34 AM   #3
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
I changed that, but it does not help.

After reboot, the eth0 interface is not up. Only the local interface lo.
 
Old 07-15-2011, 07:52 AM   #4
minnarky
LQ Newbie
 
Registered: Nov 2010
Location: MN
Distribution: Fedora and RHEL
Posts: 20

Rep: Reputation: 2
Which release of Fedora are you on?
And are you using Network Manager to manage the interfaces? If so, then there is a checkbox in the gui controls for starting that IF on boot.
 
Old 07-15-2011, 09:17 AM   #5
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by minnarky View Post
Which release of Fedora are you on?
And are you using Network Manager to manage the interfaces? If so, then there is a checkbox in the gui controls for starting that IF on boot.
Fedora 10. Not using GUI, not using NetworkManager, only /sbin/service network and network-scripts.
 
Old 07-15-2011, 09:29 AM   #6
druuna
LQ Veteran
 
Registered: Sep 2003
Posts: 10,532
Blog Entries: 7

Rep: Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389Reputation: 2389
Hi,

Try a simpler config file and try to expand with extra options if necessary:
Code:
DEVICE=eth0
BOOTPROTO=static
HWADDR=08:00:27:bd:f5:3c
IPADDR=192.168.1.151
NETMASK=255.255.255.0
ONBOOT=yes
Take the above as starting point.

BTW: You have BOOTPROTO set to none in your original, try setting that to static.

Hope this helps.
 
Old 07-15-2011, 09:20 PM   #7
gardenair
Member
 
Registered: Oct 2004
Location: LH
Posts: 610

Rep: Reputation: 31
Well i agree with to make it static
 
Old 07-16-2011, 05:28 PM   #8
schneidz
LQ Guru
 
Registered: May 2005
Location: boston, usa
Distribution: fc-15/ fc-20-live-usb/ aix
Posts: 5,076

Rep: Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861Reputation: 861
this is a stock-cap solution:

Code:
sudo echo "ifconfig eth0 192.168.1.151 up" >> /etc/rc.local
 
Old 07-23-2011, 04:24 AM   #9
jonaskellens
Member
 
Registered: Jul 2008
Location: Ghent, Belgium
Distribution: Fedora, CentOS
Posts: 632

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by schneidz View Post
this is a stock-cap solution:

Code:
sudo echo "ifconfig eth0 192.168.1.151 up" >> /etc/rc.local
Well, this is the only thing that helped.

Putting BOOTPROTO=static resulted in still no eth0 at startup.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 missing on startup :-( Mufasa Linux - Networking 3 10-03-2008 12:37 PM
eth0 does not get configured at startup bullfrog1870 Linux - Networking 8 05-07-2007 05:20 PM
eth0 startup delphig Linux - Newbie 1 10-24-2003 10:16 PM
eth0 hangs on startup reichhorn Linux - Networking 1 06-19-2003 03:25 AM
eth0: Delaying startup? dannyboy259 Linux - Networking 0 04-18-2002 10:50 AM


All times are GMT -5. The time now is 02:35 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration