LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-12-2014, 02:05 PM   #16
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127

Oh my friend, you really are confused! :-) (Please, no offence meant, we all need to start somewhere. I'm glad to be able to help!)
Quote:
Originally Posted by AlexBoter View Post
After changing permission of ifcfg-eth0 file I managed to change the parameters as follows:
Quote:
In network-scripts directory was additional file named etho-lo, but I didn't find file of eth1, moreover the network-scripts directory doesn't permit to add/delete files.
So you are not doing this as root or using 'sudo'.
You see, these files under /etc/sysconfig/ are meant to be changeable by root only, that's because they are a bit sensitive and ordinary users should never need to write into them. I can't go deep into details, but in Linux ordinary users never have the right to change system files. Only the "administrator", which in linux is named "root", is allowed to do that. So in order to change anything about your system, such as the file "/etc/sysconfig/network-scripts/ifcfg-eth0", you need root privileges.
One way is to login as root, another is to login as a user and then switch to root, a third approach is to use 'sudo' which roughly means "do this as root" - for this, the user account must have been granted rights to use sudo.
Maybe you know this already, maybe not. I just want to make it clear.

So, let's look into your problem:
The interface configuration for eth0 & eth1 was not in place. (= the files "/etc/sysconfig/network-scripts/ifcfg-eth0" & ifcfg-eth1 do not exist, or they have the wrong content.)

Troubleshoot:
The file "/etc/udev/rules.d/70-persistent-net.rules" keeps parameters for network cards.
You can see in your output from that file that the system knows about two nic's:
eth0 with HWADDR="ATTR{address}=="00:0c:29:4b:ff:29""
eth1 with HWADDR="ATTR{address}=="00:0c:29:4b:ff:33""
One of these should actually be usable - maybe both, but it depends. For instance, let's say you have only eth0 to start with, then when you clone or copy a system the HWADDR (which is also called "mac address") changes. Since there is a nic with a different HWADDR the system recognizes it a second nic, and assign the name "eth1" to it.
The file /etc/sysconfig/network-scripts/ifcfg-eth1 does not exist, I know. That's why I wanted you to copy /etc/sysconfig/network-scripts/ifcfg-eth0 to /etc/sysconfig/network-scripts/ifcfg-eth1, and then change DEVICE & HWADDR in the latter file.
Please do that now.
You need to do everything mentioned here in a terminal - it could be done using a GUI but it's a lot more difficult to guide you then.
Command to copy: "sudo cp /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth1".
Then edit /etc/sysconfig/network-scripts/ifcfg-eth1 as described.
Use DHCP for now, it's good to start with since you will know for sure if the config is correct (if not you don't get an ip).
Now type:
sudo ifdown eth0
sudo ifdown eth1
sudo ifup eth0
sudo ifup eth1

Any result?
What does command "ifconfig" say? (Or, if this is CentOS 7. then "ifconfig" doesn't exist, use "ip addr" instead.)
If you still canšt get it to work, please post complete command chain including the prompt!
 
Old 12-12-2014, 06:03 PM   #17
AlexBoter
LQ Newbie
 
Registered: Dec 2014
Posts: 9

Original Poster
Rep: Reputation: Disabled
Hi,

Thank u for your thorough answer.

For ifup eth0 the output is:

Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/571
Error: Timeout 90 sec expired.

For ifup eth1 output is:

** (process:4863): WARNING **: _nm_object_get_property: Error getting 'State' for /org/freedesktop/NetworkManager/ActiveConnection/566: (19) Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist

state: unknown
Error: Connection activation failed.

Brrrrr....one more post and I'll start with vino.
 
Old 12-13-2014, 02:19 PM   #18
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,350

Rep: Reputation: 127Reputation: 127
Didn't notice, if you want to handle network manually then change "NM_CONTROLLED=yes" to "NM_CONTROLLED=no". (My personal recommendation for servers, but as always it depends on needs & wants.)
Then try again let's see what happens.

Now you also need to check Vmware's config for this guest.
I don't have a vmware host so I can't check, taking everything from memory.
In hosts vmware control-panel you will find settings for the guests nic. It should be "bridged" mode, also check what mac address it has. If the mac differs from what's in your ifcfg-eth file then change it in that file.
You can delete the file "/etc/udev/rules.d/70-persistent-net.rules" and reboot the guest, this file will be recreated and should now have actual values.

Vino - you don't have access to the guest directly? Is the host placed in a data center?
Is the host a Windows or Linux, if so which Linux? Does it have a working network config?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No DHCPOFFERS received m0llbuz_ Linux - Networking 6 07-29-2010 03:08 PM
No DHCPOFFERS received ryedunn Linux - Wireless Networking 1 09-27-2008 02:22 PM
no DHCPOFFERS received. murrayfoss *BSD 9 02-09-2007 09:32 PM
No DHCPOFFERS received antonucc Linux - Networking 8 12-07-2006 05:06 AM
NO DHCPOFFERS received ekdya Debian 7 04-27-2006 05:09 AM


All times are GMT -5. The time now is 02:56 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration