LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 04-12-2011, 09:08 AM   #1
tethysgods
Member
 
Registered: May 2004
Posts: 166

Rep: Reputation: 17
No connection with Wireless BT Homehub


I have just dual booted a friends Vista PC with fedora core 14. Unfortunately
he needs a wireless connection to the internet vi a BT homehub 2.

I had thought this should just work straight off!

Can anyone give me a pointer to a step by step guide to do this (on FC14 preferably).

On Vista, I can get info using "ipconfig /all" at command line that gives stuff like default gateway, dhcp server, and so on. It's talking to
the hub via a REALTEK8187B wireless USB (802.11g)

I suppose I have to add the hub via sys->Pref->Network_Connections->Wireless->Add.


If so, where do I ger the info to put in?
 
Old 04-12-2011, 10:12 AM   #2
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hi,

as far as I see (Wikipedia) the BT Home Hub 2.0 is a wireless router. You will need to know the configurationdata for the wireless network, wpa-key, ssid (networkname) and it is important to know if the device provides your computer with an IP-configuration via DHCP.

In order to check this, I'd recommend to boot the Windowssystem und check the configuration. On Windows please open a terminal (Start->execute "cmd") and post the output of
Code:
ipconfig /all
Markus
 
1 members found this post helpful.
Old 04-13-2011, 11:25 AM   #3
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
Some notes

I can't get round there til Sunday, but last Sunday I took down a few notes from ipconfig /all.

Incomplete as this is, does it help?
________________________________________________________
Network-> BTHomeHub-Cs23
Name BT H.H.2.0 Media Gateway

Connect to

SSID=VirginMedia6697121
Soc WPA2-PSK
Radio Type 802.11g

Home Hub
SSID=BTHomeHub2-CS23
__________________________________________________________

MS windows command tool
use
ipconfig /all
Physical Address 00-11-3Bxxxxxxx
DHCP Autoconf
Link Local IVP6 Address fe80::xxxxxxxx
Link Local IvP6 add 192.168xxxxxx
Subnet mask 255.255.255.0
Default Gateway 192xxxxxx
DHCP Server 192xxxxxxxx
DHCPv6 iaid 234885xxxxx
__________________________________________________________
Sees REALTEX RTL8187B USB wireless device 802.11g
___________________________________________________________
 
Old 04-13-2011, 01:39 PM   #4
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
could you please boot Linux and post the output of
Code:
lspci -k | grep -iA5 wireless
and
Code:
ifconfig
and
Code:
iwconfig
it is clear that you're using wpa2, so you will have to configure for wpa_supplicant in order to connect to the wireless network.

Markus
 
Old 10-14-2011, 09:00 AM   #5
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
starting again

Well, I have bee ill for some time, but now I'm back on the problem.

As it happens, I have installed fedora on HPG7000 laptop for a friend of my daughter, and I actually have the machine in my house. This should make things easier.

So to begin with I have. from lspci

01:00.0 Ethernet controller: Atheros Communications Inc. AR5001 Wireless Network Adapter (rev 01)
Subsystem: Hewlett-Packard Company Device 137b
Kernel driver in use: ath5k
Kernel modules: ath5k
02:01.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Hewlett-Packard Company Presario C700
Kernel driver in use: 8139too
Kernel modules: 8139too, 8139cp

lsmod tells me that ath5k is up and running on boot

then ifconfig gives

eth0 Link encap:Ethernet HWaddr 00:1E:EC:78:902
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:16 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:480 (480.0 b) TX bytes:480 (480.0 b)

and finally iwconfig gives

wlan0 IEEE 802.11bg ESSIDff/any
Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementff

So this is the problem. On fc14 I go to

System->Preferences-Network Connections

eth0 is there under "wired" but there was nothing under wireless.

So the question is, how can I get the network manager to see the device? Once I manage that I will go back to the BTHomeHub.

The thing is, I get a hardware/MAC address from ifconfig, but no hardware address from iwconfig.
 
Old 10-14-2011, 09:41 AM   #6
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
Hello tethysgods,

do you have wpa_supplicant installed? I'm not experience with Fedora, I use wpa_supplicant on Slackware and have no problems.

Do you know which encryption your wireless network uses?

Markus
 
Old 10-14-2011, 11:37 AM   #7
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
wpa_supplicant

Hi Markush


Yes, wpa_supplicant was installed with fedora fc14 (rfkill was not).
 
Old 10-14-2011, 11:47 AM   #8
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
encryption

I forgot to add, that as far as I can make out, the BT Home Hub 2 uses WPA encryption.
 
Old 10-14-2011, 05:00 PM   #9
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
If you have a proper wpa_supplicant.conf you can try manually
Code:
wpa_supplicant -Dwext -iwlan0 -c/etc/wpa_supplicant.conf &
and when iwconfig shows that you are authenticated you may use
Code:
dhcpcd wlan0
note that you have to use the proper path to wpa_supplicant.conf in the first command and note that not every distribution uses dhcpcd as a DHCP-client. The above commands work for Slackware.

Markus
 
Old 10-14-2011, 07:03 PM   #10
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
Thanks Markush

I think I might have been very stupid! (Homer Simpson Doh moment!) But then I am very much a newbie on networking of any kind...

I need to give that wpa_supplicant.conf the MAC address of the BT Home Hub Router - not the wireless adaptor?

I need to use the (at moment) BT Home Hub default password with wpa_passphrase and use that as the to generate the key -- not the password itself.

I shall tell you how I get on tomorrow.

Last edited by tethysgods; 10-14-2011 at 09:44 PM. Reason: passphrase
 
Old 10-15-2011, 04:06 AM   #11
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
No, it doesn't need a MAC-adress. Here an example from my computer:
Code:
samsung:~# cat /etc/wpa_supplicant.conf
ctrl_interface=/var/run/wpa_supplicant GROUP=0

network={
       ssid="Wlan-09"
       proto=WPA RSN
       key_mgmt=WPA-PSK
       pairwise=TKIP 
       psk="xxxxxxxxxxxxxxxxxxxxxxxxxxx"
}
where psk is the key for your wireless network.
I'm using WPA2, note that you'll find many sample configurations in the /usr/share/doc/wpa_supplicant directory (the path on Slackware) and that there is a manpage for wpa_supplicant.conf

Markus
 
Old 10-18-2011, 10:31 AM   #12
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
I hadn't tried the BT Home Hub 2 with a wired connection to the laptop. On trying it, it wouldn't work!

So I changed to my Zoom ADSL router, which did work, and did an update. (The fc14 install DVD which I used on the laptop is as old as fc14.) Anyway, at least the laptop can use the BT hub as a wired connection now, but as my daughters friend is in a shared house, she needs a wireless connection.
Next, I had been following

http://www.linuxquestions.org/questi...t-woes-667069/


however ps -ef | grep wpa shows that wpa_supplicant is already started at boot. If you try kill -9 on the process, it immediately restarts, and this software blocks any manual attempt to get wpa_supplicant connected to the BT Hub.

I found that I needed to edit a /etc/sysconfig/wpa_supplicant file and put

INTERFACES="-iwlan0"
DRIVERS="-Dwext"

Also, I see that I get a boot message that starting wpa_supplicant failed.

At the bottom of the boot message I get

/sbin/shclient, no such file or directory.

I also noted that the wpa_supplicant that starts at boot wants /etc/wpa_supplicant/wpa_supplicant.conf and not /etc/wpa_supplicant.conf which I had put there --- yes that really was daft!

So although I must be a bit nearer to get this wireless connection going, it still won't work.

On fc14 I have system->preferences->network connections

Early on I added a wireless device

Put the SSID (BTHumeHub2-XXXX where XXXX is on a label on the back of the BT hub)

I chose Mode=Infrastructure (other option is Ad-hoc and I don't know what either of them mean)


It also wants a MAC address - on the wired connection this is the MAC address of eth0 returned by ifconfig -a. I have tried leaving it blank, and I have tried using the mac address of wlan0 returned by ifconfig -a. I left MTU as "Automatic".
Also, there is a BSSID and a Cloned MAC address. I have left these blank.
Under the security tab I choose WPA & WPA2 personal. It also wants you to set a password. I have no idea what this password is about, but I put
in something and password=same_thing in the wpa_supplicant.conf file. (I assume it is definitely not the wpa key.)


Finally I have been using this as the wpa_supplicant.conf file

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0
network={
ssid="BTHomeHub2-j4Z9" #do I need to drop the quotes
scan_ssid=0
proto=WPA RSN
key_mgmt=WPA-PSK
pairwise=CCMP TK
psk=ffxxxxxxe7 #no quotes?, it's the wpa key on the label on the back of the hub.
password="WhatIPutIn" #what I put in system->preferences->newtwork devices under security tab with quotes
}

Note, there are no # comments in the actual file


Last of all, at one point, the wireless connection did see the home hub but couldn't connect to the internet. When I re-booted
on saturday, it couldn't see the BT hub again. At any rate, the machines Atheros wireless adapter and the ath5k driver must be working.

Anyway, I still have no wireless connection for the laptop.

Last edited by tethysgods; 10-18-2011 at 10:32 AM. Reason: added last sentence
 
Old 10-18-2011, 11:30 AM   #13
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
Looking in /var/log/wpa_supplicant.log I see

line 9: invalid PSK "ffxxxxxxe7" # same if I change from double quotes to no quotes and reboot
line 9: failed to pass psk 'ff9cxxxxx'
line 10: WPA-PSK accepted but no PSK configured
line 10: failed to parse network block

(I have now chopped out the password)

I am assuming I need the wpa key on the back of the Hub (10 digit Hex number) rather than a 512 bit strong generated by wpa_passphrase
with a password. Is this the password that system->preferences->Networkdevices bit earlier on. Do I need to put this as a password
in wpa_supplicant.conf or is it not needed here?

This seems to be a large part of the problem.
 
Old 10-18-2011, 11:34 AM   #14
markush
Senior Member
 
Registered: Apr 2007
Location: Germany
Distribution: Slackware
Posts: 3,979

Rep: Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850Reputation: 850
the psk needs quotes!

But be sure to read the manpage for wpa_supplicant.conf, there is a slight difference in the configuration between wpa and wpa2 when configuring wpa_supplicant. The wpa_supplicant.conf I posted above is used with wpa2.

Markus
 
Old 10-20-2011, 12:00 PM   #15
tethysgods
Member
 
Registered: May 2004
Posts: 166

Original Poster
Rep: Reputation: 17
P.S where are "thread tools"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 06:55 PM
Debian - Gnome: Wireless connection list missing my connection bio2009 Linux - Newbie 5 12-18-2009 12:07 AM
Slackware 13.0 & WICD - Slow wired connection, no wireless connection xTyrant Linux - Laptop and Netbook 2 10-15-2009 12:58 AM
Networking problems can find wireless router (BT HomeHub) but fails to connect-Fedora dan.bar Linux - Wireless Networking 1 06-29-2009 04:46 PM
wireless connection ok with knoppix dvd , no connection with installed fedora 4 docharmony Linux - Wireless Networking 2 11-27-2005 05:33 PM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration