LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-16-2012, 03:03 AM   #1
terrapinstation
LQ Newbie
 
Registered: May 2012
Posts: 6

Rep: Reputation: Disabled
Unhappy no clue completely green


I purchased a toshiba laptop with linux debian as the operating system I have no clue as to why the usb will not work when i plug it in. I am totally green to the lingo and computer science in general, although I am eager to learn.
when I plug in the usb I get a note saying unable to mount usb20FD
error mounting mount exited with error code 1 helper failed with etc etc,.. there were similar responses, and I suppose solutions but i have no clue as to what it all means or how to make a command etc.
please help thanks in advance
Terrapinstation
 
Old 05-16-2012, 03:18 AM   #2
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
First enter "sudo tail -f /var/log/messages" in a terminal and then plug in the USB drive. Note the device nodes mentioned such as /dev/sdb for the entire device and /dev/sdb1 for the filesystem on the device. Sometimes a USB pendrive won't be partitioned, and the filesystem will be on /dev/sdb instead of /dev/sdb1 for example. Is there a message about recognizing a filesystem?

Here are some of the lines I get. I deleted some lines for brevity:
Code:
May 16 02:08:35 qosmio kernel: [271621.636084] usb 2-2: new high speed USB device number 10 using ehci_hcd
May 16 02:08:35 qosmio kernel: [271621.751793] usb 2-2: New USB device found, idVendor=0781, idProduct=5406
May 16 02:08:35 qosmio kernel: [271621.751803] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 16 02:08:35 qosmio kernel: [271621.751810] usb 2-2: Product: U3 Cruzer Micro
May 16 02:08:35 qosmio kernel: [271621.751814] usb 2-2: Manufacturer: SanDisk Corporation
May 16 02:08:35 qosmio kernel: [271621.751819] usb 2-2: SerialNumber: 0000060412098585
May 16 02:08:35 qosmio kernel: [271621.753680] scsi7 : usb-storage 2-2:1.0
May 16 02:08:36 qosmio kernel: [271622.757098] scsi 7:0:0:0: Direct-Access     SanDisk  U3 Cruzer Micro  2.16 PQ: 0 ANSI: 2
May 16 02:08:36 qosmio kernel: [271622.810293] sd 7:0:0:0: [sde] No Caching mode page present
May 16 02:08:36 qosmio kernel: [271622.810297] sd 7:0:0:0: [sde] Assuming drive cache: write through
May 16 02:08:36 qosmio kernel: [271622.815667]  sde: sde1
May 16 02:08:36 qosmio kernel: [271622.830035] sd 7:0:0:0: [sde] No Caching mode page present
May 16 02:08:36 qosmio kernel: [271622.830039] sd 7:0:0:0: [sde] Assuming drive cache: write through
May 16 02:08:36 qosmio kernel: [271622.830043] sd 7:0:0:0: [sde] Attached SCSI removable disk
May 16 02:08:37 qosmio dbus-daemon[1212]: **** EMITTING ADDED for /sys/devices/pci0000:00/0000:00:1d.7/usb2/2-2/2-2:1.0/host7/target7:0:0/7:0:0:0/block/sde/sde1
The pen drive is /dev/sde and it has one partition, /dev/sde1. You can use the command "file -s" to get information on filesystems.
Code:
> sudo file -s /dev/sde

/dev/sde: x86 boot sector; GRand Unified Bootloader, stage1 version 0x3, stage2 address 0x2000, stage2 segment 0x200; partition 1: ID=0x83, starthead 1, startsector 63, 8000307 sectors, code offset 0x48
> sudo file -s /dev/sde1
/dev/sde1: Linux rev 1.0 ext2 filesystem data, UUID=ca98a523-dd64-47a2-a10d-63eecb85f180, volume name "suse" (large files)
If the system had problems mounting it automatically, you can try mounting it manually. Here ext2 is the filesystem. Most pendrives are fat32. In that case, use the type "vfat" instead:
Code:
sudo mount -t ext2 /dev/sde1 /mnt/
Some things that could be causing your problem.
  • usb drive isn't partitioned and desktop setup doesn't like that.
  • The filesystem is corrupt.
  • The kernel module for the filesystem isn't loaded. For fat32 you need the "vfat" kernel module.
  • Mounting removable devices is disabled using PolicyKit.
 
Old 05-16-2012, 03:37 AM   #3
terrapinstation
LQ Newbie
 
Registered: May 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Thumbs up terminal ? again I am an infant lol laymans terms please

what is a terminal,.. also where would i put in a command ?
in addition to the previously mentioned etc etc ,
is
mount; wrong fs type, bad option, bad superblock on /dev/sdb1,
missing code page or helper program, or other error in some cases
useful info is found in syslog try dmesg l tail or so
 
Old 05-16-2012, 04:33 AM   #4
brianL
LQ 5k Club
 
Registered: Jan 2006
Location: Oldham, Lancs, England
Distribution: Slackware & Slackware64 14.1
Posts: 7,453
Blog Entries: 55

Rep: Reputation: Disabled
The terminal is available from the menu. You just type in the command and hit Enter. Easy, really.
BUT...you'll need the root (that's like admin in Windows) password. Who did you get the laptop from, and did they provide a password for root? Any more details would be helpful, please.
 
Old 05-16-2012, 08:12 AM   #5
terrapinstation
LQ Newbie
 
Registered: May 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Question root,.. IROOT, IROOT,IROOT

I purchased it off craigslist, from a fellow who is a consultant for a software company. Unfortunately, I do not have his number any more also I do not see a menu that would allow me to open up a terminal,.. if you could could you walk me thru it ,.. it says applications, places and system up above in the left hand corner
 
Old 05-16-2012, 08:37 AM   #6
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
It will be under Applications>Accessories>Termianl

Good luck to you.
 
Old 05-16-2012, 08:55 AM   #7
terrapinstation
LQ Newbie
 
Registered: May 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
applications ,......root terminal ? or terminal ?

i typed in "password" for password in the root terminal and it seemed to let me go forward
it also says that I am a superuser
then it says
root@debian-laptop:/home/debian#(blinking cursor)
I have no idea what this means
 
Old 05-16-2012, 09:06 AM   #8
terrapinstation
LQ Newbie
 
Registered: May 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
Exclamation ok applications accessories terminal,.. then what remember i am super green

Quote:
Originally Posted by TroN-0074 View Post
It will be under Applications>Accessories>Termianl

Good luck to you.
can you elaborate,. ok i go to applications then accessories then terminal
then the blinking cursor I type in _______________ ?
sorry but I'm no techie I need to be spoon fed this information
thanks
 
Old 05-16-2012, 09:15 AM   #9
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
type su then hit enter then type the word password and see if it doesn't report anything back that means that is your root password.

From there you can follow the suggestion in post #2 skipping the word sudo.



On another note:
Having the word password as root password is not a good idea. I would suggest you to change it at some point.
you can change it by typing passwd then type the password you want to use.

You must issue this command while log it in as root though.

If you want to change the password to your user then issue the command in the form of

passwd 'username'
 
Old 05-16-2012, 10:02 AM   #10
terrapinstation
LQ Newbie
 
Registered: May 2012
Posts: 6

Original Poster
Rep: Reputation: Disabled
troN,.. I typed in su , thenn password, but alas my password is not password afterall

should I try to track this fella down who sold me the computer to solve this problem,.. or do I have any alternative solutions ?
 
Old 05-16-2012, 11:03 AM   #11
TroN-0074
Senior Member
 
Registered: Dec 2011
Location: Michigan USA
Distribution: OpenSUSE 13.2 64bit-Gnome on ASUS U52F
Posts: 1,444

Rep: Reputation: 340Reputation: 340Reputation: 340Reputation: 340
you can
1) Contact the person from who you acquired this computer and nicely ask him for the password and other information you might need in order to use the machine the way you want.
2) You can download and re install the OS adding all the settings and preferences you would like to have in your computer. Debian and other linux base distributions are distributed for free at no monetary cost at all
3) You can just use the computer the way it is right now and never worry about installing any new software, updates, nor modifying any file.

Good luck to you.
 
Old 05-18-2012, 01:30 PM   #12
DavidMcCann
Senior Member
 
Registered: Jul 2006
Location: London
Distribution: CentOS, Salix
Posts: 4,162

Rep: Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223Reputation: 1223
Don't despair! So far you've learned how to start the terminal and how to become the root user with "su" and the password. You say you got
Code:
mount; wrong fs type, bad option, bad superblock on /dev/sdb1,
 missing code page or helper program, or other error in some cases 
 useful info is found in syslog try dmesg | tail or so
That means that your usb thing is called /dev/sdb1, so that's something else you've learned. So, open the terminal, become root, plug in the usb stick, and then try the command "dmesg | tail" to see if it says anything useful. (Incidentally, another way to see what's happening is to use the Logfile viewer: that's in the menu under System tools.) Tell us what message you get and we should be able to see whether the problem is on the computer or in the usb stick.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change light green text color to dark green of xterm ? cola Slackware 13 01-03-2010 10:07 AM
Completely new to LQ, and very green at Linux Mint matt00 LinuxQuestions.org Member Intro 1 08-09-2009 01:53 PM
LXer: 5 Ways to Save Green by going Green LXer Syndicated Linux News 0 05-16-2009 12:31 AM
LXer: The Green Penguin: Going Green With Google LXer Syndicated Linux News 0 10-08-2008 05:00 PM
I Have No Clue mr_svperstar Linux - Newbie 6 08-15-2003 12:58 PM


All times are GMT -5. The time now is 10:22 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration