LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-19-2009, 07:27 PM   #1
Marty21
Member
 
Registered: Jan 2009
Posts: 46

Rep: Reputation: 15
No bell sound?


Hi guys,
when i execute the command, echo '\a' i dont hear any bell sound,why?
Thanks
 
Old 03-19-2009, 07:44 PM   #2
snowman81
Member
 
Registered: Aug 2006
Location: Michigan
Distribution: Ubuntu
Posts: 237

Rep: Reputation: 30
Try it without the quotes?
 
Old 03-19-2009, 07:54 PM   #3
Marty21
Member
 
Registered: Jan 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Not working-echo \a , echo "\a" ,echo '\\a'
 
Old 03-19-2009, 08:00 PM   #4
snowman81
Member
 
Registered: Aug 2006
Location: Michigan
Distribution: Ubuntu
Posts: 237

Rep: Reputation: 30
what distro? paste the output of this: modprobe -l pcspkr
 
Old 03-19-2009, 08:38 PM   #5
Marty21
Member
 
Registered: Jan 2009
Posts: 46

Original Poster
Rep: Reputation: 15
No Output
Could you please give me eg -echo \n
 
Old 03-20-2009, 01:17 AM   #6
Valery Reznic
ELF Statifier author
 
Registered: Oct 2007
Posts: 676

Rep: Reputation: 136Reputation: 136
Quote:
Originally Posted by Marty21 View Post
Hi guys,
when i execute the command, echo '\a' i dont hear any bell sound,why?
Thanks
1) Does your motherboard have speaker at all ?
2) Starting from Fedora 5 (may be early) you have to load kernel module (I think it's called speaker.ko. but may be something smilar) in order to beep produce any sound
 
Old 03-20-2009, 01:32 AM   #7
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 11,736

Rep: Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585Reputation: 1585
The module's name is pcspkr.ko, so you have to
Code:
modprobe pcspkr
to load the module into the kernel. Then you can try:
Code:
echo -e "\a"
 
Old 04-19-2009, 08:03 PM   #8
Marty21
Member
 
Registered: Jan 2009
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks snowman81,Valery Reznic,bathory.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound does not work well in Packard Bell EasyNote lamiaa_ak Linux - Hardware 1 10-26-2008 05:38 PM
System bell but no sound __spc__ Linux - Hardware 2 03-02-2006 12:59 AM
aterm: display bell and audio bell hallamigo Linux - Software 4 05-02-2004 12:00 AM
No sound system bell-9.2 akihandyman Mandriva 1 02-11-2004 06:34 PM
No sound aRTs and system bell(mdk9.2) akihandyman Mandriva 0 02-09-2004 02:26 PM


All times are GMT -5. The time now is 08:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration